Subject: RE: [dix] Re: attribute assertions

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 18 Jan 2006 14:02:52 -0800

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dick Hardt

> On 18-Jan-06, at 11:55 AM, Peter Saint-Andre wrote:
> 
> >
> >> I agree - anything that has zero traction today should not be 
> >> included. I'm am also of the same mind as far as building 
> something 
> >> that can be implemented today and work across multiple 
> services, both 
> >> entrenched (HTTP) and emerging (SIP). Currently there's a 
> big fight 
> >> between SAML and WS-Federation, I think we have to choose 
> one to make 
> >> this work (SAML), but leave the exchange language extensible.
> >
> > Given that XMPP (RFC 3920) is built atop TLS and SASL, it 
> might be a 
> > good option for the transport protocol. But I'm biased.
> 
> In the ID that John Merrells posted, HTTP is the transport 
> being discussed.
> 
> No reason for DIX to not run on XMPP or SIP. Would be *good* 
> objectives for that to be possible.

There are different levels of commitment that can be expressed in a
charter:

  * XMPP and SIP support are deliverables with specified milestones
  * XMPP and SIP support are optional deliverables
  * Proving the possibility of XMPP and SIP support is a deliverable
  * Discussion of XMPP and SIP is out of scope

I definitely think we do not want the last option. On the other hand I
would be nervous about specifying milestones at this point.

I think that we need to be sure we have convinced ourselves that the
ideas can be applied to SIP and XMPP. I regard that type of test as
being essential to make sure that we have the base architecture right, I
would suggest doing that even if we did not intend to actually realize
that support.

_______________________________________________
dix mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dix

---

From: John Merrells <[email-masked]>
Date: Wed, 18 Jan 2006 14:06:52 -0800

> would suggest doing that even if we did not intend to actually realize

I think that the proposed charter reflects this statement:

"Any solution should support multiple transport layers, but it is  
anticipated that this working group will focus on a HTTP based  
solution. "

John

---

From: "Suresh Venkatraman" <[email-masked]>
Date: Wed, 18 Jan 2006 14:53:11 -0800

> would suggest doing that even if we did not intend to actually realize

I would argue that SIP and XMPP, as protocols built for user or
identity-based communications, are exceptionally well suited to take
advantage of a common identity solution. I'm not arguing against the use of
HTTP as the spec'd binding, but I would push for bindings in these other
protocols as well, even if only in draft form.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Hallam-Baker, Phillip
Sent: Wednesday, January 18, 2006 2:03 PM
To: Digital Identity Exchange
Subject: RE: [dix] Re: attribute assertions