Subject: [dix] use cases

From: John Merrells <[email-masked]>
Date: Mon, 23 Jan 2006 11:19:58 -0800

If people want to offer up some use cases i'll wrangle them into an  
ID...

(I'd rather somebody else did the editing on this draft though...)

John

_______________________________________________
dix mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dix

---

From: James Benedict <[email-masked]>
Date: Mon, 23 Jan 2006 14:29:13 -0500 (EST)

If no one else volunteers, then i'll do it.  I'm
working on some use cases for myself anyways... still
trying to get a picture in my head of exactly what
this protocol is doing.

I think in pretty (or at least ASCII) pictures :)

--
James

---

From: Dick Hardt <[email-masked]>
Date: Mon, 23 Jan 2006 11:32:27 -0800

Great to hear that James!

I think it would be useful for us all to agree what a use case is. :-)

---

From: James Benedict <[email-masked]>
Date: Mon, 23 Jan 2006 14:43:58 -0500 (EST)

Good question! Especially since we have a "chicken and
egg" issue here.  Personally, I'de like to see some
"example executions" of the current draft to get a
better understanding of how it works... and to spot
potential issues.

However, in the real (well, maybe ideal is a better
word) software engineering world, the "use cases"
would represent an expected "walk through" of the
application functionality ... from which requirements
would be derived ... then the applications, protocols,
etc would be implemented.

Interestingly enough, we already have the end-product.
 Hence, my interest in "examples" of the current
draft. I'de rather take what we've got and analyse the
"use cases" to determine suitability than to try to
re-derive the draft from scratch, although some might
disagree with me here :)

Since you put out the question Dick, what do you
propose?

--
James

---

From: Dick Hardt <[email-masked]>
Date: Mon, 23 Jan 2006 12:11:52 -0800

Well, my question was more of "What is a use case?"

Is it a detailed "Detailed Scenario"?

I retained Tim Bray of XML fame to assist me with documenting SXIP  
1.0. His recommendation (which he and I executed on) was to write  
scenarios, where the user activity and what happens on the wire are  
discussed so that the reader can tie it all together. We wrote  
different scenarios so that the reader would be able to see enough  
facets of the protocol to understand it. The use of names and  
specific activities made it easy for the reader to grasp. I think  
this is a useful, but non-normative way to document a protocol.

I think this might be too detailed.

Here is a simple example of what I think a use case is:

Sally wants to register at a website. She does some action that sends  
her to her software agent that manages her identity, that allows her  
to select which data she wants to release.
When returning to the site later, Sally clicks on a button to log  
into the site.

Sally is in control of what data was released to the site.
Sally did not have to type in any of the data.
Sally does not have new username and password for the site.

-- Dick

---

From: James Benedict <[email-masked]>
Date: Mon, 23 Jan 2006 15:22:19 -0500 (EST)

I agree with you, I'de rather see something a little
less detailed.  

I still would prefer to see something less like a
classic use case, and something more illustrative of
the existing draft.  John's already got something that
(IMO) looks pretty good, I'de just like to see some
use-cases for it; and i'm worried if we take the
traditional "forget about prior art" attitude when we
do use-cases, they'll set the process way back.

So, can we agree?  Something lightweight, with the
intent to illustrate the existing draft to start?

--
James

--- Dick Hardt <[email-masked]> wrote:

> >> I think it would be useful for us all to agree
> what
> >> a use case is. :-)
> >>
> >>>> (I'd rather somebody else did the editing on
> this
> >>>> draft though...)
> >>>>
> >>>> John
> >>>>
> >>>>

---

From: "Duane Nickull" <[email-masked]>
Date: Mon, 23 Jan 2006 13:54:27 -0800

This exact conversation has persisted in many groups.

Myself and Matt Mackenzie built a patterns template to capture use cases
and derive requirements from which to feed into development of
specifications.  The idea is to start capturing the high level business
conversation then gradually refine it to a set of architectural
patterns, expressed in UML notation, to speak to implementers (see line
#176 for details).  The architectural patterns metamodel is based on the
works of Christopher Alexander and the infamous gang of four.  The work
is publicly, freely available at:

http://www.nickull.net/work/MacKenzie-Nickull_ArchitecturalPatternsRefer
enceModel-v0.91.pdf

If this is relevant, we would consider donating this IP to IETF.

Duane Nickull

*******************************
Adobe Systems, Inc. - http://www.adobe.com
Vice Chair - UN/CEFACT  http://www.uncefact.org/
Chair - OASIS SOA Reference Model Technical Committee
Personal Blog - http://technoracle.blogspot.com/
******************************* 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dick Hardt
Sent: Monday, January 23, 2006 12:12 PM
To: Digital Identity Exchange
Subject: Re: [dix] use cases

-- Dick

---

From: "Suresh Venkatraman" <[email-masked]>
Date: Mon, 23 Jan 2006 14:40:45 -0800

The term 'use case' has different meanings when discussing UML versus an
internet protocol. The use case document may deal with more than one set of
scenarios. I'll repost an example of a use case draft being used by the p2p
sip group:

http://www.ietf.org/internet-drafts/draft-bryan-sipping-p2p-usecases-00.txt

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James
Benedict
Sent: Monday, January 23, 2006 12:22 PMh
To: Digital Identity Exchange
Subject: Re: [dix] use cases

--
James