Subject: RE: [dix] use of non-ietf work in ietf standards

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Sun, 12 Feb 2006 09:16:48 -0800

Eric was making was the pedantic point that the Javascript 'standard' is
called ECMAScript and that is what the spec should reference.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dave Crocker
> Sent: Saturday, February 11, 2006 7:29 PM
> To: Digital Identity Exchange
> Subject: [dix] use of non-ietf work in ietf standards
> 
> 
> 
> > dumb clients but given that Javascript isn't any kind of IETF 
> > standard--it's hard to see how we could require it in an IETF 
> > standard.
> 
> 
> small procedural point:  the ietf does it all the time.
> 
> x.400 interoperability specs. IP-over-* specs. Anything using Unicode.
> 
> And so on.
> 
> (The subject line of this message is changed so that no one 
> confuses this note with a comment on dix or your substantive 
> review of it.)
> 
> d/
> -- 
> 
> Dave Crocker
> Brandenburg InternetWorking
> <http://bbiw.net>
> 
> _______________________________________________
> dix mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dix
> 
> 

_______________________________________________
dix mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dix

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 12 Feb 2006 17:09:38 -0800

Quite so. And Dave is of course right about being able to reference
non-IETF standards. A spurious "IETF" snuck into what should be
a one IETF sentence there...

-Ekr

---

From: Dave Crocker <[email-masked]>
Date: Mon, 13 Feb 2006 00:49:08 -0800

> a one IETF sentence there...

ahh.  i see your point.

it can, indeed, be a bit challenging to create a stable standards specification,
when it includes an unstable -- or nonexistent -- component specification.

d/
-- 

Dave Crocker

---

From: John Merrells <[email-masked]>
Date: Mon, 13 Feb 2006 10:00:22 -0800

> called ECMAScript and that is what the spec should reference.

Thanks. I've reflected this into the draft... which I'll republish  
just before the BOF.

John