Subject: RE: [dix] Re: Dix & OpenId?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 9 Aug 2006 09:02:04 -0700

I think that we are moving to a point where OpenID is more useful as a generic term for what we are building. It has mindshare.

Since the protocols must by their nature share a good deal of structural similarity and since the idea is for everything to talk to esach other to the maximum extent I think this is the best approach.

I would like to see SAML, Liberty, CardSpace seen as high end instances of an OpenID. 

This is more about marketecture than technology.

Lets start building some use cases that look beyond the bloggy, wiki world.

> -----Original Message-----
> From: Dick Hardt [mailto:[email-masked]] 
> Sent: Wednesday, August 09, 2006 10:52 AM
> To: David Fuelling
> Cc: 'Digital Identity Exchange'
> Subject: [dix] Re: Dix & OpenId?
> 
> On 9-Aug-06, at 7:14 AM, David Fuelling wrote:
> > The OpenId 2.0 draft spec has many similar components to 
> the DIX draft 
> > 1 (pre-saml) spec.  In addition, it looks like Sxip Identity is a 
> > founding sponsor of the OpenId bounty program, which seems a bit 
> > counter-intuitive to me (although I can see the motivation 
> of wanting 
> > to publicize Identity 2.0 in general).  Regardless, Sxip 
> Identity has 
> > based Sxip 2.0 on dix, and has been a major backer of dix.
> Hi David
> 
> The timing of your question is impeccable!
> 
> The Sxip people are working with incorporating much of DIX 
> into OpenID 2.0. There have been a number of backroom 
> conversations going on  (mostly with the folks at JanRain and 
> David Recordon of VeriSign) and there is a meeting at 
> VeriSign's Mountain View offices tomorrow if anyone on this 
> list is interested in attending.
> 
> Converging the protocols seems to make the most sense 
> (features from each were being incorporated in the other anyway)
> 
> -- Dick
> 
> _______________________________________________
> dix mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dix
> 
> 

_______________________________________________
dix mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dix

---

From: Dan Connolly <[email-masked]>
Date: Wed, 09 Aug 2006 11:14:05 -0500

> Lets start building some use cases that look beyond the bloggy, wiki world.

Yes... it's clear to me how I can use an OpenID persona in the bloggy
wiki world, but I also want to use it for calendar synchronization,
banking and bill paying and getting credit card statements...
maybe even with OFX and quicken. I can't seem to work that out in
my head.

Is this a case of "doctor, doctor, it hurts when I do that; so don't"?
Or does anybody expect that it will, in fact, scale up? Any pointers
to reading material would be appreciated.

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E

---

From: Dan Connolly <[email-masked]>
Date: Wed, 09 Aug 2006 11:44:29 -0500

Oh... I neglected to mention...

I'm very pleased to hear that Sxip and OpenID folks are talking...
Here's hoping they'll save me the trouble of having to figure
out exactly how the 2 protocols are different ;-)