Subject: [dmarc-ietf] ADSP to Historic?

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Sep 2013 14:54:25 -0700

Folks,

G'day.

DomainKeys Identified Mail (DKIM) Author Domain Signing Practices (ADSP) 
(RFC 5617, August 2009) is currently an IETF Proposed Standard.

It appears to have little or no community traction, after 4 years.  In 
fact, my impression is that it has been actively rejected by the community.

Especially given an effort like DMARC, it would simplify the landscape 
-- that is, avoid possible confusion -- if ADSP were deprecated.

So I'd like to ask for comment about an effort to move RFC 5617 to 
Historical status.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Paul Midgen <[email-masked]>
Date: Wed, 11 Sep 2013 15:43:37 -0700

do you just need votes in support or something else?

my vote in support: +1 to historical.

awaiting instructions on "something else". ;)

-p

From:  Dave Crocker <[email-masked]>
Date:  Wednesday, September 11, 2013 2:54 PM
To:  "[email-masked]" <[email-masked]>
Subject:  [dmarc-ietf] ADSP to Historic?

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>

---

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Sep 2013 16:03:40 -0700

> awaiting instructions on "something else". ;)

just looking for initial reactions, to judge whether to make the formal 
request.  a +/- 1 certainly qualifies.

thanks.

d/

---

From: Paul Midgen <[email-masked]>
Date: Wed, 11 Sep 2013 16:11:36 -0700

ok. i know this area can be a polarizing issue, but when i planned the SPF
implementation at hotmail a few years ago, i also researched the use of ADSP
on our inbound mail and found that ADSP records existed for less than 0.003%
of traffic where it would ostensibly have been used, and that any effect it
would have had was utterly and indisputably dwarfed first by an internal
domain policy system, then by DMARC.

in my case it was hello nail, meet coffin.

disclaimers: i am no longer a hotmail employee. that data is now at least 2
years old. there is a good chance that i'm off by a zero in either direction
(not that it matters much in this case). if you want current data to bolster
your case i can connect you offline with some former colleagues.

From:  Dave Crocker <[email-masked]>
Date:  Wednesday, September 11, 2013 4:03 PM
To:  Paul Midgen <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  Re: [dmarc-ietf] ADSP to Historic?

---

From: John Sweet <[email-masked]>
Date: Wed, 11 Sep 2013 22:34:07 -0700

On Sep 11, 2013, at 2:54 PM, Dave Crocker <[email-masked]> wrote:

> So I'd like to ask for comment about an effort to move RFC 5617 to Historical status.

Yes, please.

Maybe a wake? I feel like there should be a wake. ADSP, we hardly knew ye.

---

From: Andreas Schulze <[email-masked]>
Date: Thu, 12 Sep 2013 12:27:40 +0200

> So I'd like to ask for comment about an effort to move RFC 5617 to  

I just removed all my _adsp records from dns.
Some of them where disabled anyway since I started using dmarc.

so +1 for historical.

Andreas

---

From: Olga Gavrylyako <[email-masked]>
Date: Thu, 12 Sep 2013 07:08:13 -0700

+1 for historical. In Gmail we already deprecated ADSP-related code.

On Wed, Sep 11, 2013 at 2:54 PM, Dave Crocker <[email-masked]> wrote:

> Especially given an effort like DMARC, it would simplify the landscape --
> that is, avoid possible confusion -- if ADSP were deprecated.
>
> ______________________________**_________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/dmarc<https://www.ietf.org/mailman/listinfo/dmarc>
>

---

From: Krish Vitaldevara <[email-masked]>
Date: Thu, 12 Sep 2013 14:33:02 +0000

+1.

And Paul, the numbers didn't change much there.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Midgen
Sent: Wednesday, September 11, 2013 4:12 PM
To: Dave Crocker
Cc: [email-masked]
Subject: Re: [dmarc-ietf] ADSP to Historic?

ok. i know this area can be a polarizing issue, but when i planned the SPF implementation at hotmail a few years ago, i also researched the use of ADSP on our inbound mail and found that ADSP records existed for less than 0.003% of traffic where it would ostensibly have been used, and that any effect it would have had was utterly and indisputably dwarfed first by an internal domain policy system, then by DMARC.

disclaimers: i am no longer a hotmail employee. that data is now at least 2 years old. there is a good chance that i'm off by a zero in either direction (not that it matters much in this case). if you want current data to bolster your case i can connect you offline with some former colleagues.

From: Dave Crocker <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 11, 2013 4:03 PM
To: Paul Midgen <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dmarc-ietf] ADSP to Historic?

thanks.

d/

---

From: "Rolf E. Sonneveld" <[email-masked]>
Date: Thu, 12 Sep 2013 17:25:31 +0200

On 09/11/2013 11:54 PM, Dave Crocker wrote:
> Folks,
>
> G'day.
>
> DomainKeys Identified Mail (DKIM) Author Domain Signing Practices 
> (ADSP) (RFC 5617, August 2009) is currently an IETF Proposed Standard.
>

+1 for moving it to Historic.

/rolf

---

From: Steven M Jones <[email-masked]>
Date: Thu, 12 Sep 2013 08:38:26 -0700

> And Paul, the numbers didn't change much there.

+1 provided the data supports it. I know Microsoft sees an enormous 
volume, but I would still suggest getting some additional, corroborating 
sources to support any formal application. But you probably had that in 
mind already any way...

--S.

---

From: Matt Simerson <[email-masked]>
Date: Thu, 12 Sep 2013 08:38:42 -0700

+1

On Sep 11, 2013, at 4:03 PM, Dave Crocker <[email-masked]> wrote:

> just looking for initial reactions, to judge whether to make the formal request.  a +/- 1 certainly qualifies.
> 
> thanks.
> 
> d/
> -- 
> Dave Crocker

---

From: Elizabeth Zwicky <[email-masked]>
Date: Thu, 12 Sep 2013 15:37:20 +0000

+1. The only uptake we've noticed is from people who complain that the name returns a non-TXT non-fail for yahoo.com (which the standard says is a legitimate case meaning "there is no ADSP record here, move on"). So uptake looks both minimal and buggy.

Elizabeth

From: Krish Vitaldevara <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 12, 2013 7:33 AM
To: Paul Midgen <[email-masked]<mailto:[email-masked]>>, Dave Crocker <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dmarc-ietf] ADSP to Historic?

+1.

And Paul, the numbers didn’t change much there.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Paul Midgen
Sent: Wednesday, September 11, 2013 4:12 PM
To: Dave Crocker
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [dmarc-ietf] ADSP to Historic?

thanks.

d/

---

From: Tim Draegen <[email-masked]>
Date: Thu, 12 Sep 2013 16:18:04 -0400

+1   Bonus pluses for inserting some forward reference so that naive ADSP deployers know where to go next.

=- Tim