Subject: [dmarc-ietf] The AR and the header.from and multiple address in from

From: Franck Martin <[email-masked]>
Date: Mon, 6 Jan 2014 20:31:48 -0600 (CST)

I noticed the AR indicates in header.from the the domain portion of the RFC5322 .From field, but it is not necessary where the dmarc policy is. Shouldn't we add a field to indicate the domain where we found the policy where all alignments will be based upon. I suggest using header.d for it. We can query to find the orgdomain and the policy but this may be changing, and as finding the org domain is not an adopted standard, indicating what was used could be helpful. 

When there is an email with multiple addresses in the RFC5322 .From field? I think we need to clarify the language in the spec in 16.1 to: 
value:  the domain portion of the RFC5322 .From field that was used to obtain the dmarc result. 
What happens if the RFC5322 .From does not have a domain like for some form of EAI? I suggest header.from=nil

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 6 Jan 2014 21:42:05 -0800

We can't use header.d if the Domain Owner only uses SPF, because there
won't be a "d" anywhere.  Off the top of my head, we could use header.from,
and then just report the organizational domain as the "value extracted".

On Mon, Jan 6, 2014 at 6:31 PM, Franck Martin <[email-masked]>wrote:

> I noticed the AR indicates in header.from the the domain portion of the
> RFC5322 <http://tools.ietf.org/html/rfc5322>.From field, but it is not
> necessary where the dmarc policy is. Shouldn't we add a field to indicate
> the domain where we found the policy where all alignments will be based
> upon. I suggest using header.d for it. We can query to find the orgdomain
> and the policy but this may be changing, and as finding the org domain is
> not an adopted standard, indicating what was used could be helpful.
>
> When there is an email with multiple addresses in the RFC5322<http://tools.ietf.org/html/rfc5322>.From
> field? I think we need to clarify the language in the spec in 16.1 to:
>
>  value:  the domain portion of the RFC5322 <http://tools.ietf.org/html/rfc5322>.From field that was used to obtain the dmarc result.
>
> What happens if the RFC5322 <http://tools.ietf.org/html/rfc5322>.From
> does not have a domain like for some form of EAI? I suggest header.from=nil
>
> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>
>

---

From: Franck Martin <[email-masked]>
Date: Tue, 7 Jan 2014 00:17:00 -0600 (CST)

I think you think about the header.d for dkim, here I'm suggesting using header.d in for dmarc, may be they should be named differently to avoid confusion, may be header.dmarc=<domain where the dmarc policy is> 

something like: 
Return-path: [email-masked] 
Dkim-signature: d=d3.example.com 
From: [email-masked] 
Authentications results: spf=pass mail.from=d1.example.com; dkim=pass header.d=d3.example.com; dmarc=pass header.from=d4.example.com header.dmarc=example.com; 

----- Original Message -----

From: "Murray S. Kucherawy" <[email-masked]> 
To: "Franck Martin" <[email-masked]> 
Cc: [email-masked] 
Sent: Monday, January 6, 2014 9:42:05 PM 
Subject: Re: [dmarc-ietf] The AR and the header.from and multiple address in from 

We can't use header.d if the Domain Owner only uses SPF, because there won't be a "d" anywhere. Off the top of my head, we could use header.from, and then just report the organizational domain as the "value extracted". 

On Mon, Jan 6, 2014 at 6:31 PM, Franck Martin < [email-masked] > wrote: