Subject: [dmarc-ietf] spec missing ABNF for "fo" tag

From: Tim Draegen <[email-masked]>
Date: Tue, 11 Feb 2014 11:18:32 -0500

Hi,

Section 5.3. of the DMARC spec is missing ABNF for the "fo" tag.

The necessary changes could be (I'm no ABNF master):

Adding to "dmarc-record" definition:
    [dmarc-sep dmarc-fopt]

And adding the actual definition:
    dmarc-fopt    = ( "0" / "1" / "d" / "s" )
    dmarc-fo      = "fo" *WSP "=" *WSP
                    dmarc-fopt *(*WSP ":" *WSP dmarc-fopt)

Hope this helps,

=- Tim

PS. Thanks to as astute dmarcian.com user for pointing this out!

---

From: Vlatko Salaj <[email-masked]>
Date: Tue, 11 Feb 2014 15:49:37 -0800 (PST)

>                 dmarc-fopt *(*WSP ":" *WSP dmarc-fopt)

some comments on this, nothing crucial:

if we keep the proposed names, dmarc-record addition should read: [dmarc-sep dmarc-fo].

i guess, it should be placed between dmarc-ainterval and dmarc-rfmt entries, as it defines failure reports more closely; so, less important than aggregate report options, but more valuable than rfmt one. not that order matters, as specified in txt.

also, i'm not sure if it needs two definitions, as it could be done with only one:
dmarc-fo      = "fo" *WSP "=" *WSP
                ( "0" / "1" / "d" / "s" )
                *(*WSP ":" *WSP ( "0" / "1" / "d" / "s" ))

i was always less into occupying memory than processor resource.

however, this also allows for duplicate multiples. but i don't think that would be an issue during processing.

however, as mentioned some time ago, having possibility of fo=0:1 may introduce some grief.

> PS. Thanks to as astute dmarcian.com user for pointing this out!

yes, i'm to blame. hi all. hopefully my contribution will not remain at only
this, and my brain will force me to make another useful contribution eventually. seems i came to that point of my life when this kind of activity comes naturally to me; all tnx go to tim for inviting me here.

i've been rereading drafts for awhile now, almost every single version. i like how dmarc progresses nicely towards a full standard. good job all.

dmarcian.com isn't the only free testing suite i nudged about standards before; unlock the inbox has me in their "special thanks" section somewhere too.

well, i guess this is enough for an introduction. until next time.

-- 
Vlatko Salaj aka goodone
http://goodone.tk