Subject: [dmarc-ietf] draft-kucherawy-dmarc-base-04 issue

From: Scott Kitterman <[email-masked]>
Date: Fri, 29 Aug 2014 23:39:24 -0400

Since this is the WG list, I'm not sure if this is still the right list for 
issues with the base spec or not, but here goes ...

The definition of "fo" in Section 5.2, General Record Format, allows both 
values of "0" and "1" to be specified.  It was suggested to me offlist that this 
might not be appropriate, so I thought it worth a discussion.

Does anyone who's implemented "fo" have a problem with both "0" and "1" being 
specified?  If it is somehow problematic, then the base spec ought to say so.

Scott K

---

From: Tim Draegen <[email-masked]>
Date: Sat, 30 Aug 2014 10:12:32 -0400

> issues with the base spec or not, but here goes ...

Right list.  Just to set precedent, any thoughts on this issue will be captured in the WG's issue tracker.  Once the WG shifts to considering specification changes (next year), we'll bring it up again and fold necessary changes into spec.

=- Tim

---

From: Scott Kitterman <[email-masked]>
Date: Sat, 30 Aug 2014 11:02:55 -0400

On Saturday, August 30, 2014 10:12:32 Tim Draegen wrote:
> Right list.  Just to set precedent, any thoughts on this issue will be
> captured in the WG's issue tracker.  Once the WG shifts to considering
> specification changes (next year), we'll bring it up again and fold
> necessary changes into spec.

Since the base spec isn't published yet, it'd be nice to see a nit like this 
resolved before publication.

Scott K
> > values of "0" and "1" to be specified.  It was suggested to me offlist
> > that this might not be appropriate, so I thought it worth a discussion.
> > 
> > Does anyone who's implemented "fo" have a problem with both "0" and "1"
> > being specified?  If it is somehow problematic, then the base spec ought
> > to say so.
> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc

---

From: Dave Crocker <[email-masked]>
Date: Sat, 30 Aug 2014 08:23:32 -0700

On 8/30/2014 7:12 AM, Tim Draegen wrote:
> Right list.  
...

While this might be a reasonable list for the question, it might be more
useful to /start/ with a broader and more operations-oriented dmarc
list, and then bring the topic here when there is some convergence from
the discussion elsewhere.

That is, perhaps start by asking the question on:

   http://www.dmarc.org/mailman/listinfo/dmarc-discuss

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Franck Martin <[email-masked]>
Date: Sat, 30 Aug 2014 14:17:01 -0700

> Right list.  Just to set precedent, any thoughts on this issue will be captured in the WG's issue tracker.  Once the WG shifts to considering specification changes (next year), we'll bring it up ag…

I would suggest we just convert draft-kucherawy-dmarc-base-04 into draft-dmarcwg-dmarc-base-01 to reflect the current spec has been accept by this WG for further work.

Is this the way it is done, usually?

Then all issues can be directed, tracked, and emailed to this wg using the IETF tools (and others) as the spec will have this WG email address attached to it.

---

From: "Stephen J. Turnbull" <[email-masked]>
Date: Sun, 31 Aug 2014 15:47:19 +0900

>    http://www.dmarc.org/mailman/listinfo/dmarc-discuss

Last I heard that list was deprecated in favor of this one.  It
certainly has been mostly inactive for quite a long time.

Murray?  Franck?

---

From: Pete Resnick <[email-masked]>
Date: Sun, 31 Aug 2014 10:18:51 -0500

On 8/30/14 4:17 PM, Franck Martin wrote:
> On Aug 30, 2014, at 7:12 AM, Tim Draegen<[email-masked]>  wrote:
>
>    
>> On Aug 29, 2014, at 11:39 PM, Scott Kitterman<[email-masked]>  wrote:
>>      

If this is a nit that really should be handled before the base spec gets 
published by the ISE, then bring it to the author of that spec. If it is 
an issue that requires some discussion and resolution, then putting it 
into the WG issue tracker for later handling is exactly right.

> I would suggest we just convert draft-kucherawy-dmarc-base-04 into draft-dmarcwg-dmarc-base-01 to reflect the current spec has been accept by this WG for further work.

There was a very conscious choice to put the following text into the 
charter:

    The existing DMARC base specification has been submitted as an
    Independent Submission to become an Informational RFC.

and a very conscious choice to make any review of the base spec part of 
"phase 3" of this WG's work. This WG is chartered to address the 
indirect mail flow issues *first*, *then* work on the usage document, 
and only *then* take on a review of the base spec. These are issues with 
current deployments that need to be addressed in the short term. Opening 
up the base spec for rewrite has a high likelihood of derailing that 
initial work.

Furthermore, you will note that there is no requirement in the charter 
that this WG do an entire rewrite of the base spec, even when it gets to 
phase 3. The WG could decide to simply publish smaller extension or 
correction documents that reference the ISE spec. It is certainly a 
reasonable possibility that the WG might choose to publish the entire 
base spec, with its changes, as a new standards track document that 
replaces the Informational document, but the WG will cross that bridge 
when it gets to it.

> Is this the way it is done, usually?

Yes, but the history of the base spec is rather unusual. That's why it's 
being published, outside of IETF process, as an Informational RFC in the 
Independent Submission stream.

> Then all issues can be directed, tracked, and emailed to this wg using the IETF tools (and others) as the spec will have this WG email address attached to it.

As I said, for issues that need discussion, the WG should track those in 
its issue tracker. But the intent is to have the base spec published 
ASAP by the ISE so that the WG has a stable reference to work from for 
its initial work.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478