Subject: Re: [dmarc-ietf] draft-kucherawy-dmarc-base-04 issue

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 2 Nov 2014 01:44:16 -0700

Just noticed that I never replied to this:

On Fri, Aug 29, 2014 at 8:39 PM, Scott Kitterman <[email-masked]>
wrote:

> Since this is the WG list, I'm not sure if this is still the right list for
> issues with the base spec or not, but here goes ...
>
> The definition of "fo" in Section 5.2, General Record Format, allows both
> values of "0" and "1" to be specified.  It was suggested to me offlist
> that this
> might not be appropriate, so I thought it worth a discussion.
>
> Does anyone who's implemented "fo" have a problem with both "0" and "1"
> being
> specified?  If it is somehow problematic, then the base spec ought to say
> so.
>

How about this?

      1: Generate a DMARC failure report if any underlying
         authentication mechanism produced something other
         than an aligned "pass" result.

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 10 Nov 2014 14:14:01 -0500

>          than an aligned "pass" result.

I think it's fine.  It is a bit of an odd situation where reports for fo=0 are 
a strict subset of fo=1 reports.  As a result, having both 0 and 1 specified is 
somewhat pointless.  OTOH, I don't expect an interoperability problem with it, 
so meh.

Scott K