Subject: [dmarc-ietf] update on dmarc from a mailing list USER'S perspective?

From: eugene hayhoe <[email-masked]>
Date: Sat, 24 Jan 2015 03:08:51 -0800

As an IT non-professional (in every sense of the word, I only joined this group out of frustration at no longer having reliable access to several email lists I had enjoyed for years previously, in an attempt to understand WHY that was so) VERY frustrated by the bouncing mess dmarc created a year ago for people like me, I'm here to ask ''is there any kind of a fix on the horizon yet?''

My occasional perusing of messages on this list leads me to believe ''not yet.'' Is this accurate?

ANY ''update for the layman'' that anyone could volunteer would be MUCH appreciated. I miss my mailing lists.

Gene Hayhoe

---

From: Steve Atkins <[email-masked]>
Date: Sat, 24 Jan 2015 16:29:16 -0800

> As an IT non-professional (in every sense of the word, I only joined this group out of frustration at no longer having reliable access to several email lists I had enjoyed for years previously, in…

Your ISP has made a policy statement that you are not allowed to use mailing lists from their service. DMARC didn't create the issue, Yahoo did.

You have two choices if you want to be able to reliably participate in mailing lists - persuade Yahoo to reverse their decision about what they will allow you to do with a yahoo.com email address, or move to a different email provider.

> My occasional perusing of messages on this list leads me to believe ''not yet.'' Is this accurate?

Kinda. "Not any time soon" would be more accurate. "Not ever" might be even more accurate.

> ANY ''update for the layman'' that anyone could volunteer would be MUCH appreciated. I miss my mailing lists.

Move to a different ISP. All the ISPs highlighted in red on this - http://dmarc.wordtothewise.com - list have stated that they do not wish their users to send email via anything other than their mail systems. That includes, amongst other things, typical mailing lists. That list of ISPs has been pretty stable for a while - I don't expect any of those listed in red to change any time soon, and I hope there won't be any changes to red either.

Cheers,
 Steve

(apologies for possible duplicate mail)

---

From: Hector Santos <[email-masked]>
Date: Sat, 24 Jan 2015 19:35:14 -0500

> ANY ''update for the layman'' that anyone could volunteer would be MUCH appreciated. I miss my mailing lists.

Gene,

I feel ya, but IMO your options are:

[1] Change your favorite email to another that isn't strict,
[2] Wait until the IETF designs new 3rd party DKIM Policy protocols,
[3] Encourage your list provider/market to support and push for #2, ASAP.

None of this is new. Its been known for at least 10+ years now.  Its 
like politics now, DEM vs GOP.  DEM wants DKIM POLICY designs, the GOP 
want DKIM TRUST designs.  DMARC is providing new hope DKIM POLICY will 
prevail and now that more BIG systems are supporting it and also 
turning on the REJECTION switch, maybe 3rd party POLICIES is next.

Cross your fingers.

Vote for 3rd Party Domain Authorization Signing Solutions. <g>

--
HLS