Subject: Re: [dmarc-ietf] [arc-discuss] arc-05 draft released

From: Kurt Andersen <[email-masked]>
Date: Tue, 28 Jun 2016 08:13:58 -0700

[email-masked] since the protocol has been adopted there...

On Sat, Jun 25, 2016 at 11:27 PM, Murray S. Kucherawy <[email-masked]>
wrote:

> On Sun, Jun 19, 2016 at 1:34 AM, Brandon Long <[email-masked]> wrote:
>
>> I recently wrote an authres parser and it seemed fairly easy to support
>> both authres and aar, but I also wrote the parser with that expectation,
>> not sure how easy/hard it would be to change that now.
>>
>>
> The authres syntax is fairly irritating, an over abundance of allowance
>> for CFWS and then using actual WS as a delimiter... that and the /version
>> stuff made it hard to take short cuts.
>>
>
> AR's CFWS use and use of WS as a delimiter is pretty much the same as most
> other things in email as I recall, with the notable exception of DKIM.
>
> And, I'd think you can recycle it, you just pass it the part after the
>> first semi-colon assuming the first stanza consists of i=N.
>>
>
> The section defining AAR doesn't actually say that it's "i=N;" (with the
> semi-colon).  It should.  Note though that the rest of that header field is
> not pure tag=value syntax.
>
> So here's a bit of hand grenade: You could separate the AAR parts from the
> AR parts by doing something like:
>
> ARC-Authentication-Results: i=1;
> ar=<base64-or-qp-encoded-copy-of-AR-you-want-to-preserve>
>
> That makes AAR into a purely tag=value syntax.  If there's no need for any
> part of ARC to care what the preserved thing is, this seems mighty clean.
>
> -MSK
>

I'm OK with this sort of strategy. Presumably the ar tag value would be
canonicalized before encoding?

--Kurt

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 28 Jun 2016 18:35:11 +0200

On Tue 28/Jun/2016 17:13:58 +0200 Kurt Andersen wrote:
> [email-masked] <mailto:[email-masked]> since the protocol has been adopted
> there...

-ARC Discussion <[email-masked]> to reduce cross-posting...

> On Sat, Jun 25, 2016 at 11:27 PM, Murray S. Kucherawy <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>> semi-colon).  It should.  Note though that the rest of that header field
>> is not pure tag=value syntax.
>>
>> So here's a bit of hand grenade: You could separate the AAR parts from
>> the AR parts by doing something like:
>>
>> That makes AAR into a purely tag=value syntax.  If there's no need for
>> any part of ARC to care what the preserved thing is, this seems mighty
>> clean.
>

What's wrong with something readable?  E.g.:

      arc-authres-header = "ARC-Authentication-Results:" [CFWS] arc-instance
               [ CFWS] authserv-id
               [ CFWS authres-version ]
               ( no-result / 1*resinfo ) [CFWS] CRLF

      arc-instance = %x69 [FWS] "=" [FWS] 1*3DIGIT ";"
               ; i=N;

Ale
--

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 28 Jun 2016 10:18:00 -0700

>      arc-instance = %x69 [FWS] "=" [FWS] 1*3DIGIT ";"

I didn't say there was anything wrong with it.  I'm just looking for a way
to have all three ARC fields be parsable by a single grammar.  Currently,
AAR isn', because it's not a pure DKIM-style tag-value sequence.

-MSK

---

From: Brandon Long <[email-masked]>
Date: Wed, 29 Jun 2016 17:41:50 -0700

I'd hate to lose the readability of this field by encoding it like that.

I understand the desire to simplify, but arc users are going to need an
authres parser to take advantage of the data it provides, so it seems like
a good idea to include one.

Brandon

On Jun 28, 2016 12:18 PM, "Murray S. Kucherawy" <[email-masked]> wrote:

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 30 Jun 2016 06:56:10 -0700

On Wed, Jun 29, 2016 at 5:41 PM, Brandon Long <[email-masked]> wrote:

> a good idea to include one.

Yeah, just an idea.  In either case, the document needs to include an ABNF
for the modified format.

-MSK