Subject: [dmarc-ietf] Proposal: Writing a DMARC usage guide is not a good task for this WG

From: "Kurt Andersen (b)" <[email-masked]>
Date: Wed, 31 May 2017 20:32:44 +0800

For the sake of discussion:

I'd like to suggest that writing a DMARC usage guide under a BCP sort of
moniker is not a useful activity for this WG. There are lots of white
papers and other "how to use DMARC" guides available on the internet. What
value would it add to have something preserved in the perpetuity of IETF
archives that repeats what is already available?

We've written the interoperability review, we've seen the development of
the ARC spec to address a large portion of those interoperability problems
and we're on the verge of having ARC available for wide deployment and
implementation. I'm not sure that we can make useful conclusions about how
the state of email usage will be affected until there has been some time
for the protocol to bake in.

--Kurt

---

From: Barry Leiba <[email-masked]>
Date: Wed, 31 May 2017 21:47:14 +0900

I agree with this.  If there's stable documentation on DMARC usage
that we can cite, there's little value in adding our own, which is
likely to end up diverging from the others.

Does anyone think we *should* proceed with writing this?

Barry

On Wed, May 31, 2017 at 9:32 PM, Kurt Andersen (b) <[email-masked]> wrote:
> moniker is not a useful activity for this WG. There are lots of white papers
> and other "how to use DMARC" guides available on the internet. What value
> would it add to have something preserved in the perpetuity of IETF archives
> that repeats what is already available?
>
> We've written the interoperability review, we've seen the development of the
> ARC spec to address a large portion of those interoperability problems and
> we're on the verge of having ARC available for wide deployment and
> the state of email usage will be affected until there has been some time for
> the protocol to bake in.
>
> --Kurt
>
> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>

---

From: Tim Draegen <[email-masked]>
Date: Wed, 31 May 2017 11:13:55 -0400

> On May 31, 2017, at 8:47 AM, Barry Leiba <[email-masked]> wrote:
> 

A draft has been started on this, with slow progress. The draft aims to fill documentation gaps based on how domain-level policies can impact organizations (across the whole email food chain) and how to best manage impact/interoperability.

The original intent of the document was to share operational experience from the PoV of Domain Owners, third party senders, and email receivers/processors. For example, if a third party sender wants to start sending on behalf of Domain Owners, the document would describe how to do this in a ~normal way. The production of the document was supposed to get people to share experience, especially in areas outside of commercial activity.

That said, given the WG's history of thin participation, I'm OK with dropping the Usage Guide. The existing gaps in documentation will be filled outside of the IETF. On the one hand I'm a believer that an IETF-produced Usage Guide is better for interoperability than a collection of to-be-published documents spread throughout the Internet. On the other hand, forcing a bunch of people to work on a draft isn't how I like to spend my Internet time.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 31 May 2017 21:23:26 -0700

> Does anyone think we *should* proceed with writing this?

Hard to say.  Maybe, with development of a DMARC on the standards track.
But I'd like to see some momentum first in general, and secondly a good
reason why this has to come from the IETF.  Otherwise, some informative
text in appendices in either ARC or DMARCbis should suffice, rather than a
separate document.

-MSK