Subject: [dmarc-ietf] "Fixing" A-R for ARC's AAR use (and downstream DMARC reporting)

From: Kurt Andersen <[email-masked]>
Date: Wed, 12 Jul 2017 12:41:32 -0700

On Wed, Jul 12, 2017 at 11:38 AM, Terry Zink via arc-discuss <
[email-masked]> wrote:

> This structure has always bugged me:
>
> > authentication-results: google.com; dkim=none (message not signed)
> >  header.d=none;google.com; dmarc=none action=none header.from=
> linkedin.com;
>
> What's going on is that there are separate agents that do the DKIM
> evaluation and the DMARC evaluation. Their output result is <recipient
> domain>; <output of agent>. They are all concatenated onto the end of the
> Authentication-Results header. There isn't a "clean up" afterwards (DKIM
> and DMARC agents individually may fail as well which gets even more
> confusing, but at least one of them gets stamped). And on an outbound
> message (which is what you see here), there is no SPF check so it just
> looks weird.
>

I don't know if you've see the other threads on the dmarc@ietf list, but
the A-R header(s) and the content thereof have been a bit of an open item.
If we were to recreate something other than RFC7601 to become the AAR
header, do you have some suggestions for a better approach?

--Kurt

---

From: Brandon Long <[email-masked]>
Date: Wed, 12 Jul 2017 12:43:49 -0700

I think he means that what bugs him is the fact that their authres header
doesn't match the spec... at least, I hope that's the case.

Brandon

On Wed, Jul 12, 2017 at 12:41 PM, Kurt Andersen <[email-masked]> wrote:

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>
>