Subject: [dmarc-ietf] Milestones changed for dmarc WG

From: IETF Secretariat <[email-masked]>
Date: Thu, 25 Oct 2018 04:42:44 -0700

Changed milestone "Complete Authenticated Received Chain (ARC) protocol
spec", resolved as "Done".

URL: https://datatracker.ietf.org/wg/dmarc/about/

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 30 Oct 2018 18:47:23 +0000

Is this milestone really done?  The protocol document references draft-ietf-dmarc-arc-multi, which isn't done yet.  Doesn't it need to be done too before this gets checked off (there is no separate milestone for multi).

Scott K

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 31 Oct 2018 17:28:11 +0000

Hi Scott,

On Tue, Oct 30, 2018, at 6:47 PM, Scott Kitterman wrote:
> Is this milestone really done?  The protocol document references draft-
> ietf-dmarc-arc-multi, which isn't done yet.  Doesn't it need to be done 
> too before this gets checked off (there is no separate milestone for 
> multi).

This might have been me too eager to mark it as done. But I prefer a separate milestone for arc-multi anyway.

Best Regards,
Alexey

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc

---

From: "John Levine" <[email-masked]>
Date: 31 Oct 2018 14:04:50 -0400

In article <[email-masked]> you write:
>Is this milestone really done?  The protocol document references draft-ietf-dmarc-arc-multi, which
>isn't done yet.  Doesn't it need to be done too before this gets checked off (there is no separate
>milestone for multi).

I gather there are practical issues: we don't see any way to do
algorithm rotation in a way that is backward compatible with existing
implemntations, and we'd like to publish something that matches the
running code.

R's,
John

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 01 Nov 2018 01:26:57 -0400

On Wednesday, October 31, 2018 02:04:50 PM John Levine wrote:
> >Is this milestone really done?  The protocol document references
> >draft-ietf-dmarc-arc-multi, which isn't done yet.  Doesn't it need to be
> >done too before this gets checked off (there is no separate milestone for
> >multi).
> 

I think -18 of the protocol document does that reasonably well.  

I reviewed dkimpy with a view towards updating it from roughly -08 to -18 and 
it didn't need a lot of changes.  I did skip oldest-pass and related stuff 
since, per my last call comment, it seems superfluous as well as not extending 
the API to include passing in the connect IP address to include that, but 
there's no interoperability issue there.  Dkimpy 0.9.0 should interoperate 
with other -18 implementations.

Whether we leave this marked done and add a new one for multi or re-open this 
one, I don't care.  We ought to have some kind of milestone open against the 
residual work though.

Scott K