Subject: [dmarc-ietf] DKIM

From: Hector Santos <[email-masked]>
Date: Tue, 23 Apr 2019 22:02:46 -0400

Can anyone provide me some C/C++ or pseudo-code to do DKIM ecdhc 
encryption?... Using OpenSSL API in v1.1 format?

Thanks

PS: Not sure where to post this, but it equally applies to OpenSSL at 
GitHub.

-- 
HLS

---

From: Дилян Палаузов <[email-masked]>
Date: Wed, 24 Apr 2019 11:34:29 +0000

Hello Hector,

you can check 

https://github.com/Exim/exim/commit/286b9d5fa4344de72fe6575fa089237 (Exim+GnuTLS)

or 

https://github.com/trusteddomainproject/OpenDKIM/commit/35bf6c901a2 (OpenDKIM+OpenSSL)

and the last discussion at https://mailarchive.ietf.org/arch/browse/dcrup/ ([email-masked]) .

Regards
  Дилян

---

From: Erik Lax <[email-masked]>
Date: Wed, 24 Apr 2019 14:02:58 +0200

And this using libsodium

https://github.com/halon/libdkimpp/commit/7e73f5b6a115b2cfdf8122824575b321d1c114f2

Regards
Erik

On 2019-04-24 13:34, Дилян Палаузов wrote:
> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc

---

From: Vsevolod Stakhov <[email-masked]>
Date: Wed, 24 Apr 2019 13:11:17 +0100

> PS: Not sure where to post this, but it equally applies to OpenSSL at

Here is my pretty minimalistic (~3k LoC in total) implementation of DKIM
in Rspamd:

https://github.com/rspamd/rspamd/blob/master/src/libserver/dkim.c#L2832

It uses OpenSSL supporting both 1.1+ and previous versions. This
implementation supports both signing, verification, ARC and ed25519 sigs
(via own library but can easily be adopted for libsodium).