Subject: Re: [dmarc-ietf] Should 'undeliverable mail' be included in DMARC rua reports?

From: "Freddie Leeman" <[email-masked]>
Date: Wed, 7 Aug 2019 00:08:01 +0200

Thanks for you input John. I know the difference between missing and empty. Most (larger) organizations omit the element completely (zoho.com, google.com, linkedin.com, mail.ru, comcast.net, Yahoo! Inc.). Only 34 percent of all DMARC report generating organizations publish reports with an empty envelope_from (stats based on last 7 days).

If we agree that messages with a 'null reverse-path' should be included in reports, than Appendix C should state that this element is mandatory but can be empty. Another solution would be to allow the element to be omitted, saving bytes (personal preference). Are these non-delivery notifications, delivery status notifications and message disposition notifications useful in DMARC reports? If so, than we have to agree on how to report these messages and make the appendix clearer so that there can be no misinterpretation.

-- Freddie Leeman

-----Oorspronkelijk bericht-----
Van: John Levine [mailto:[email-masked]]
Verzonden: dinsdag 6 augustus 2019 22:24
Aan: [email-masked]
CC: [email-masked]
Onderwerp: Re: [dmarc-ietf] Should 'undeliverable mail' be included in DMARC rua reports?

In article <[email-masked]> you write:
>I've noticed that, even though RFC7489 appendix C states that the 
>'envelope_from' element has a minOccurs of '1', this element is missing 
>quite frequently.

It's not missing, it's empty.  That's not the same thing.

R's,
John

---

From: "Freddie Leeman" <[email-masked]>
Date: Thu, 8 Aug 2019 14:52:58 +0200

So how should 'null reverse-path'-messages be processed (in the future)? I see three options:
 
-	Element's minOccurs gets changed to 0 and ‘null reverse-path’ messages are added without the 'envelope_from' element
-	Element's minOccurs stays 1 and ‘null reverse-path’ messages get an empty 'envelope_from' value
-	‘null reverse-path’ messages are excluded from DMARC reports

Do 'null reverse-path' messages add any substantial value to DMARC reports?

Pros/Cons? Your thoughts?

-- Freddie Leeman

---

From: Alessandro Vesely <[email-masked]>
Date: Thu, 8 Aug 2019 18:50:32 +0200

> -	Element's minOccurs stays 1 and ‘null reverse-path’ messages get an empty 'envelope_from' value

This option is easy to grasp, as it parallels SMTP's mail from:<>

> Do 'null reverse-path' messages add any substantial value to DMARC reports?

Not less nor more than the ones having a possibly spoofed reverse path.

jm2c
Ale
--

---

From: "Freddie Leeman" <[email-masked]>
Date: Sun, 18 Aug 2019 09:34:32 +0200

> This option is easy to grasp, as it parallels SMTP's mail from:<>

After some thought I think this would be the best solution. Not omitting the element, keeping the MinOccurs '1', but allowing the value to be empty for null reverse-path messages. I will adjust Appendix C with these guidelines for now.

-- Freddie