Subject: Re: [dmarc-ietf] Setting From: MLM, To: author, Bcc: subscribers

From: Jesse Thompson <[email-masked]>
Date: Fri, 10 Jul 2020 17:22:16 -0500

On 6/29/20 4:18 AM, Alessandro Vesely wrote:
> Hi all,
> 
> I mentioned setting To: author instead of From: author-like, near the bottom of a message[*] a week ago, but missed any WG comments on it.  That setting would result if I run a mailing list "by hand", using a normal email client.  I'd hit reply and then add a bunch of Bcc:'s.  Of course, a suitable template would insert a subject tag instead of "Re:", et cetera.
> 
> It'd be a cleaner solution than From: rewriting, inasmuch as it saves the association between display names and addresses, for the sake of address books consistency.  The anomaly of seeing authors in To: fields, with some getting used to it, may even become a distinguished characteristic of indirect mail flows.
> 
> How unbearable would that be?  And why?  Maybe some comments on this subject can bring out some more details about the rightness or wrongness of the various flavors of From: rewriting.

If nothing else changes; as in: MLMs have to keep promoting the use of From munging to their list operators, then I think it would be useful for these MLM to also offer (and perhaps default-to-ON if it works well in practice) your idea of replacing the To with the author during the munging process.

It would increase the odds that the author will be added to the recipient's address book, either manually, or via auto-collection by MUAs when they Reply-all (I believe that most MUAs will include the To in the recipient list if it differs from the user's own address)

Recipients (and individual list operators) may still complain about the From munging, but I like your line of reasoning of getting people used to "distinguished characteristic of indirect mail flows".  

Recipients will still be saddled with "author via listname" polluting their address books (via address auto-collection).  This idea doesn't solve that problem.

Jesse

---

From: Alessandro Vesely <[email-masked]>
Date: Sat, 11 Jul 2020 13:29:03 +0200

> Recipients will still be saddled with "author via listname" polluting their address books (via address auto-collection).  This idea doesn't solve that problem.

If the author is in To:, both name and address, rather than a munged field we'd 
have something like From: Mailing List ID <[email-masked]>

Best
Ale
--

---

From: "Douglas E. Foster" <[email-masked]>
Date: Sat, 11 Jul 2020 23:03:29 GMT

Rewriting the Message To seems to have no characteristics that are likely to cause messages to be blocked as not trustworthy.

This approach will not be detected as anomalous by an incoming gateway.   Messages to BCC recipients and messages to non-modifying distribution lists are already received with the message From address being different from the SMTP RCPT address.  

Since a user knows that a received message is for himself, a message that reports "To" as someone other than himself may cause minor confusion, but is not likely to cause significant misunderstanding..

In sum, no one seems to be concerned about the integrity of the "To" header currently, and there is no obvious reason why we would expect this to change in the future.

For mailing lists that are insist on editing submissions, changing SMTP MAIL FROM and Message From into the list domain, and the Message To into the author domain, will solve the sender authentication problems created by doing so.   Just as importantly, it requires no special pleading to participant domain administrators.

DF

----------------------------------------
From: jesse.thompson=[email-masked]
Sent: 7/10/20 6:22 PM
To: [email-masked]
Subject: Re: [dmarc-ietf] Setting From: MLM, To: author, Bcc: subscribers

Jesse

_______________________________________________
dmarc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmarc