Subject: [dmm] Comparison matrix drafty draft available

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 Jun 2011 11:17:32 -0700

Hello folks,

<re-sending to proper mailing list!>

I have created the following draft.

http://www.psg.com/~charliep/txt/ietf81/draft-perkins-dmm-matrix-000000.txt

It's not really complete, but it could be submitted
this week.  I can add a lot more text and References,
according to any suggestions you might have.  I can
also add discussion sections for particular approaches
as may be needed.  I am still not clear how to co-exist
with the other comparison draft.

Regards,
Charlie P.

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 29 Jun 2011 14:21:22 -0400

Hi Charlie,

  For your matrix what did you base your "Y" or "N" answers in the entries?

Were they subjective or objective analysis?

Carl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Charles E. Perkins
Sent: Wednesday, June 29, 2011 2:18 PM
To: dmm
Subject: [dmm] Comparison matrix drafty draft available

Hello folks,

Regards,
Charlie P.
_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 Jun 2011 11:36:57 -0700

Hello Carl,

Well, I tried to be objective...  I'm not sure exactly
how to answer your question.  Could you give an example
of the difference between a subjective decision versus
an objective decision for some of the entries?

Regards,
Charlie P.

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 29 Jun 2011 15:15:04 -0400

Did you base your numbers on specific experiments. I know that there was a
presentation on some experiments presented on one method in Prague.

If you just marked "Y" and "N" based on your opinion then I am not sure this
is worth publishing.

Carl

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: Wednesday, June 29, 2011 2:37 PM
To: Carl Williams
Cc: 'dmm'
Subject: Re: [dmm] Comparison matrix drafty draft available

Hello Carl,

Regards,
Charlie P.

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Jun 2011 12:18:51 -0700 (PDT)

Hi Charlie,

In view of efforts to come up with a complete solution possibly by combining 
some pieces that are mentioned in your matrix as in:

http://tools.ietf.org/id/draft-sarikaya-mext-multicastdmm-00.txt

I don't know how valuable your matrix would contribute to the discussion?

Personally I don't view CN-wo-HA as a solution to dmm problem.

Regards,

Behcet

---

From: Romain KUNTZ <[email-masked]>
Date: Wed, 29 Jun 2011 14:19:18 -0700

Hello Charlie, 

Thanks for this document. Now that DMM is part of the MEXT charter, would it make sense to advertise and discuss it on MEXT ML instead?

Do you refer to [1] as the "other comparison draft"? I believe your draft provides a higher-level description on the approaches rather than comparing existing potential solutions (which is what we did in [1]).

[1] http://tools.ietf.org/html/draft-kuntz-dmm-summary-00

It's good to agree on the approach before further designing or improving the solutions. However, that could help to cite some drafts behind the concepts. For example, I believe Global HAHA would fall into the "DynHA" category, and it does support IP address continuity (but it is marked as "N" in your chart).

Also, DMM is about mobility management, so does it still make sense to consider approaches that do not consider IP address continuity? And one last comment: maybe source address selection should be seen as a criteria and not an approach as itself? 

Thank you,
romain

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 Jun 2011 14:26:40 -0700

Hello Carl,

> presentation on some experiments presented on one method in Prague.

Do any matrix entries conflict with those experiments?

> If you just marked "Y" and "N" based on your opinion then I am not sure this

Ouch!  I was hoping for some more constructive
feedback -- especially if you find that some of
the matrix entries are incorrect or questionable.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 Jun 2011 16:16:54 -0700

On 6/29/2011 2:19 PM, Romain KUNTZ wrote:
>
> Thanks for this document. Now that DMM is part of the MEXT charter,
> would it make sense to advertise and discuss it on MEXT ML instead?

I see your point -- but does this imply that the [dmm] mailing list
is no longer serving a useful function?

> Do you refer to [1] as the "other comparison draft"? I believe your draft
> provides a higher-level description on the approaches rather than comparing
> existing potential solutions (which is what we did in [1]).

Yes, that's the draft I read (and need to re-read).

> It's good to agree on the approach before further designing or improving
> the solutions. However, that could help to cite some drafts behind the
> concepts. For example, I believe Global HAHA would fall into the "DynHA"
> category, and it does support IP address continuity (but it is marked as
> "N" in your chart).

I do need to cite more drafts, and I need to mull over your
point about Global HAHA and go back to check that document also.

> Also, DMM is about mobility management, so does it still make sense to
> consider approaches that do not consider IP address continuity?

It is O.K. with me to exclude approaches that do not
offer IP address continuity.

>                                                                  And one
> last comment: maybe source address selection should be seen as a criteria
> and not an approach as itself?

I had thought that source address selection was offered as a
potential solution to DMM.  By your argument just above, I am
O.K. to exclude it.  But I don't understand how it can be
considered a criterion for other approaches.  Can you say more?

Regards,
Charlie P.

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 29 Jun 2011 23:18:21 -0400

Hi Charlie,

   I think that publishing the draft may be ok.  I just think that you
should explain how you  arrived at your "Y" and "N" notations in the matrix.

Carl

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: Wednesday, June 29, 2011 5:27 PM
To: Carl Williams
Cc: 'dmm'
Subject: Re: [dmm] Comparison matrix drafty draft available

Hello Carl,

Regards,
Charlie P.

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 30 Jun 2011 08:14:52 -0700 (PDT)

Hi Romain,

Is this what you mean?

Operational considerations for distributed use of Mobile IPv6

They are ;looking for an Informational document.

Regards,

Behcet

> Hello Charlie, 
> 
> Thanks for this document. Now that DMM is part of the  MEXT charter, would it 
>make sense to advertise and discuss it on MEXT ML  instead?
> 
> It's good to agree  on the approach before further designing or improving the 
>solutions. However,  that could help to cite some drafts behind the concepts. 
>For example, I believe  Global HAHA would fall into the "DynHA" category, and it 
>
>does support IP address  continuity (but it is marked as "N" in your chart).
> 
>consider approaches that do  not consider IP address continuity? And one last 
>comment: maybe source address  selection should be seen as a criteria and not an 
>
>approach as itself? 
>
> 
> Thank you,
> romain
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 30 Jun 2011 08:41:47 -0700

Hello Carl,

> should explain how you  arrived at your "Y" and "N" notations in the matrix.

Understood -- and the drafty draft has a paragraph
indicating that explanations will be forthcoming.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 30 Jun 2011 09:01:14 -0700

Hello Romain,

More follow-up below...

> existing potential solutions (which is what we did in [1]).

For now, I will cite your draft as relevant information, most
likely in support of some matrix entries.  If you want to suggest
specifically related entries, that would be appreciated.

> solutions. However, that could help to cite some drafts behind the concepts.

Indeed -- I thoroughly agree.

> For example, I believe Global HAHA would fall into the "DynHA" category, and
> it does support IP address continuity (but it is marked as "N" in your chart).

Thanks again for the reminder about Global HAHA.  I had not
remembered it, and I think it does qualify as a sort of "DynHA".
I need to think about a way to distinguish between the kinds
of "DynHA" that do support address continuity, versus the
kinds that do not.

> consider approaches that do not consider IP address continuity?

I'm still awaiting to see if consensus will develop for
excluding approaches that do not provide IP address continuity.

Regards,
Charlie P.

---

From: Romain KUNTZ <[email-masked]>
Date: Thu, 30 Jun 2011 18:46:41 -0700

Hi Behcet,

> They are ;looking for an Informational document.

Yes, this is what I meant. I understand some of the below discussion is not only related to Mobile IPv6, so I'm fine if we stick to the dmm ML. 

Regards,
romain

---

From: liu dapeng <[email-masked]>
Date: Fri, 1 Jul 2011 09:46:53 +0800

Hello all,

I have a question: for current approach comparison, shall we consider
all relevant individual drafts or just compare the one has RFC?
Thanks.

Best regards,
Dapeng Liu

2011/7/1, Charles E. Perkins <[email-masked]>:
>> the

-- 

------
Best Regards,
Dapeng Liu

---

From: Romain KUNTZ <[email-masked]>
Date: Thu, 30 Jun 2011 19:32:31 -0700

Hello Charlie,

> is no longer serving a useful function?

Re-reading the MEXT charter, it seems that they only have interest in DMM considerations for Mobile IPv6. 
Our drafts goes beyond that scope, so this ML seems to be the right place. However, as we also consider Mobile IPv6-based solutions, we should deliver MEXT some input at some point.

> point about Global HAHA and go back to check that document also.

I'm not sure if you plan to consider only WG documents, but currently Global HAHA is not one of them.

> considered a criterion for other approaches.  Can you say more?

My mistake, that is more relevant as an approach. Note that in the current DMM solution space, it is usually not considered as an apporach by itself, but coupled with other mechanisms to achieve "dynamic" use of the mobility support (e.g. to choose between CoA and HoA as source address).

Regards,
Romain

---

From: Romain KUNTZ <[email-masked]>
Date: Thu, 30 Jun 2011 20:10:45 -0700

Hello Charlie, 

> specifically related entries, that would be appreciated.

Sure. Let me try to match the solutions cited in our draft with some of the approaches listed in yours, and point what criterion would be different from your chart:

- FAMA and DMI combines source address selection and local anchor. FAMA does not allow for local routing (all addresses are anchored) but DMI does (CoA can be used for communication). This is not very app friendly as multiple usable addresses can co-exist on the node; this may require a specific application API maybe? Similarly, DMA combines source address selection and local anchor, and allows local routing. 

- HMIPv6 combines local anchor and RO. For the "backhaul friendly" criterion, I would say "No" because a centralized HA still remains,

- DLMA combines local anchor and RO, but reduces the signaling by centralizing the location management;

Also, adding a criterion on failure would be useful (whether the approach can survive a failure of the anchor or one of the anchors), what do you think?

> of "DynHA" that do support address continuity, versus the

Ok.

> excluding approaches that do not provide IP address continuity.

Sure, let's see.

Thank you,
romain