Subject: Re: [DMM] DMM and the framework discussion

From: <[email-masked]>
Date: Tue, 8 Jan 2013 15:25:18 +0000

Hi Jouni,

IMHO, it is worth to use generic mobility functions (e.g. ingress/egress redirection, location update, and so on) to describe and compare mobility solutions. Such a framework shall facilitate comparison of solutions and gap analysis. Actually, I think it is the only fair approach. For example, GTP and PMIP may look different from a protocol point of view, but, functionally, these protocols are similar and meet same requirements. Besides, if I understood well draft-liebsch-dmm-framework-analysis, a functional framework should also allow to identify DMM specific functions in a mobility architecture. Here, I'm just expressing interest for a functional framework and the WG can debate on the exact definition of this functional framework but, anyway, I think draft-liebsch-dmm-framework-analysis is a good start.

BR,
Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Jouni Korhonen
> Envoyé : jeudi 20 décembre 2012 14:50
> À : [email-masked]
> Objet : [DMM] DMM and the framework discussion
> 
> Folks,
> 
> During the last meeting we had a presentation(s) on DMM framework
> approaches. The discussion was somewhat left unfinished during and
> after the meeting. It might be useful to have the discussion on the
> mailing list now and not to postpone in to the next f2f meeting :)
> 
> Have a read e.g. on draft-liebsch-dmm-framework-analysis and say what
> you have to say about DMM frameworks. I keep hearing we lack the
> framework and at least I need to understand the possible need for one..
> 
> - Jouni
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 8 Jan 2013 15:37:03 +0000

Hi all,

As I already mentioned during the DMM WG meeting in Atlanta,
the DMM WG will benefit when having a framework draft, such the one described in well draft-liebsch-dmm-framework-analysis, for mainly two reasons:

1) comparison of existing solutions can be done using common terminology and generic mobility functions

2) during the specification of the DMM solution well defined mobility functions will be used that are considered to be well understood by the DMM WG members!

So I am in favour of having a framework draft and use draft-liebsch-dmm-framework-analysis as a start!

Best regards,
Georgios

> > Jouni Korhonen Envoyé : jeudi 20 décembre 2012 14:50 À : [email-masked]
> __________________________________________________________
> __________________________________________________________
> _____
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites
> ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez
> le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration, France Telecom -
> Orange decline toute responsabilite si ce message a ete altere, deforme ou
> falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.
> As emails may be altered, France Telecom - Orange is not liable for messages
> that have been modified, changed or falsified.
> Thank you.
>

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 9 Jan 2013 10:40:15 +0000

Hi Jouni, all,

to complement what has been written already, I think once we agreed on a
framework it helps doing a comprehensive gap analysis. Based on a common
understanding of how DMM scenarios work, the framework defines functions
that can add to a basic set of assumed mobility/tunnel management functions.
If a certain mobility protocol supports one or more DMM function intrinsically,
fine. If not, the available protocol may be extended to enable that function. Or
an external protocol can be considered to provide that functionality.

My impression from past DMM meetings is that there is a common understanding
of DMM in general, but folks still have different expectation from DMM support and
associated IP address continuity. Also assumptions on hosts are different (e.g. multi-anchor
capability, maintenance of associated uplink routes, etc.).

A framework could classify DMM functions as mandatory or optional, dependent
on the target scenario and level of path optimization that should be supported.
Some functions according to draft-liebsch-dmm-framework-analysis could be
placed even on the host to see if host mobility protocols can contribute to DMM operation.

I see the framework as required portion of the top-down gap analysis and design
approach. Last but not least it allows building a DMM architecture and deployment of
associated protocols beyond mobility protocol scope, e.g. by contributions from the routing plane
above mobility anchor level. I understand that the DMM WG may focus mainly on mobility protocols
first, but the framework can document DMM solutions in a broader scope, which may attract
readers beyond the DMM WG.  

marco 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>Jouni Korhonen
>Sent: Donnerstag, 20. Dezember 2012 14:50
>To: [email-masked]
>Subject: [DMM] DMM and the framework discussion
>
>Folks,
>
>approaches. The discussion was somewhat left unfinished during and after the
>meeting. It might be useful to have the discussion on the mailing list now and
>not to postpone in to the next f2f meeting :)
>
>Have a read e.g. on draft-liebsch-dmm-framework-analysis and say what you
>have to say about DMM frameworks. I keep hearing we lack the framework and
>at least I need to understand the possible need for one..
>
>- Jouni