Subject: Re: [DMM] Last Call comment on dmm requirements

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 1 Jul 2013 10:32:35 -0500

Hi Danny,

On Sun, Jun 30, 2013 at 4:22 AM, Moses, Danny <[email-masked]> wrote:

>  Hi,****
>
> ** **
>
> I am sorry by this requirement sounds to me too generic and limiting. What
> functionality must not be modified? Why?****
>
> I am assuming that the motivation might be related to backwards
> compatibility.
>

No. It is related to the protocol being network based. It does not make
sense to get MN's help in such a protocol, because otherwise it is no
longer network based.

Network based protocols with MN modification blur the difference between
client based and network based protocols.

So everything becomes client based.

> If this is the case, it is already addressed. Furthermore, I do not see a
> reason why not to enable modifications that may enhance performance or
> improve user experience as long as they are optional (hence do not violate
> the backwards compatibility requirement).****
>
> ** **
>
> Regards,****
>
>                 /Danny****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Behcet
> Sarikaya
> *Sent:* Saturday, June 29, 2013 00:35
> *To:* [email-masked]
> *Subject:* [DMM] Last Call comment on dmm requirements****
>
> ** **
>
> Add this requirement:
>
> R. XX. In network based dmm solutions, the mobile node MUST not be
> modified. No changes on the mobile node behavior can be allowed.
>
>
> Regards,
>
> Behcet****
>
> ---------------------------------------------------------------------
> A member of the Intel Corporation group of companies
>
> This e-mail and any attachments may contain confidential material for
> the sole use of the intended recipient(s). Any review or distribution
> by others is strictly prohibited. If you are not the intended
> recipient, please contact the sender and delete all copies.
>

---

From: Peter McCann <[email-masked]>
Date: Mon, 1 Jul 2013 16:02:32 +0000

This is not the netlmm working group.  Client modifications are very 
much in scope.

I think that mobile nodes will at least need to be enhanced with more
flexibility about the way they handle assigned addresses.  The scope
of mobility for a given address may be limited or it may cost resources
to extend the scope too far with network-based means.  The MN must be
allowed to monitor its applications' use of IP addresses and release
those addresses that are no longer used, and get a new IP address for
new application connections.  This does not necessarily involve a new
protocol for the MN but is a modification of its usual behavior.

-Pete

Behcet Sarikaya wrote:
> 	Hi,
> 	I am sorry by this requirement sounds to me too generic and limiting.
> What functionality must not be modified? Why?
> 
> No. It is related to the protocol being network based. It does not 
> make sense to get MN's help in such a protocol, because otherwise it 
> is no longer network based.
> 
> Network based protocols with MN modification blur the difference 
> between client based and network based protocols.
> 
> 	If this is the case, it is already addressed. Furthermore, I do not 
> see a reason why not to enable modifications that may enhance 
> performance or improve user experience as long as they are optional 
> (hence do not violate the backwards compatibility requirement).
> 
> 
> 
> 	Regards,
> 
> 	                /Danny
> 
> 
> 
> 	From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> Behcet Sarikaya
> 	Sent: Saturday, June 29, 2013 00:35
> 	To: [email-masked]
> 	Subject: [DMM] Last Call comment on dmm requirements
> 
> 
> 
> 	Add this requirement:
> 
> 	Behcet
> 	----------------------------------------------------------------- ----

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 1 Jul 2013 11:49:23 -0500

> This is not the netlmm working group.  Client modifications are very
Who said so?

The chair is not saying it.

I would stay away from making big statements.

> protocol for the MN but is a modification of its usual behavior.

Then let's not call such a protocol network-based :-).

---

From: <[email-masked]>
Date: Mon, 1 Jul 2013 17:32:02 +0000

Hello Behcet, All,

I think that almost all current DMM approaches that are based on MIPv6 or PMIPv6 require a new source address selection (SAS) mechanism, even the PMIPv6-based ones.

Yes, in part of them, the MN is not required to participate in the mobility-related signaling... and those could be categorized network-based.

Well, "MN MUST not be modified. No changes on the MN behavior can be allowed" is a very strict constraint that, as I believe, blocks all current DMM proposals.

Best regards,
Hassan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Monday, July 01, 2013 6:49 PM
To: Peter McCann
Cc: [email-masked]
Subject: Re: [DMM] Last Call comment on dmm requirements

On Mon, Jul 1, 2013 at 11:02 AM, Peter McCann <[email-masked]<mailto:[email-masked]>> wrote:
This is not the netlmm working group.  Client modifications are very
much in scope.

Who said so?

-Pete

Behcet Sarikaya wrote:
> Hi Danny,
>
>
>
> On Sun, Jun 30, 2013 at 4:22 AM, Moses, Danny <[email-masked]<mailto:[email-masked]>>
> wrote:
>
>
>       Hi,
>
>
>
>       From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of
> Behcet Sarikaya
>       To: [email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Peter McCann <[email-masked]>
Date: Mon, 1 Jul 2013 17:55:02 +0000

> The chair is not saying it.

Yes he is:

Jouni Korhonen wrote:
> The charter makes it clear that solutions that may involve a host
> are within our scope.
> 
> - JOuni

> I would stay away from making big statements.

I would stay away from making incorrect statements.

> Then let's not call such a protocol network-based :-).

There will be a network component and a (possibly optional) client component.
The network component will get you only so far.  Then behavior and/or protocols
on the client will be required.

-Pete

---

From: "Moses, Danny" <[email-masked]>
Date: Thu, 4 Jul 2013 07:24:22 +0000

I agree that one example of optimizing network overhead is by improving the mobile node's usage of it source IP address and I am sure there are more examples.

So the proposed new requirement is too restrictive.

Having said that, I do not think we should allow functionality that will break if backwards compatibility is not maintained. Only optimizations that are optional.

Regards,
	/Danny

-----Original Message-----
From: Peter McCann [mailto:[email-masked]] 
Sent: Monday, July 01, 2013 19:03
To: [email-masked]; Moses, Danny
Cc: [email-masked]
Subject: RE: [DMM] Last Call comment on dmm requirements

This is not the netlmm working group.  Client modifications are very much in scope.

I think that mobile nodes will at least need to be enhanced with more flexibility about the way they handle assigned addresses.  The scope of mobility for a given address may be limited or it may cost resources to extend the scope too far with network-based means.  The MN must be allowed to monitor its applications' use of IP addresses and release those addresses that are no longer used, and get a new IP address for new application connections.  This does not necessarily involve a new protocol for the MN but is a modification of its usual behavior.

-Pete