Subject: [DMM] DMM framework

From: Marco Liebsch <[email-masked]>
Date: Sun, 27 Oct 2013 21:01:56 +0000

Folks,

during my presentation at last IETF about http://www.ietf.org/id/draft-liebsch-dmm-framework-analysis-02.txt, 
around 20 people indicated interest in working on a framework.

We think this framework, the described functional entities and associated reference points to
enable unicast DMM is mature. The original idea of this framework was to be mobility protocol-agnostic
and identify components of available transport network technology, including SDN technology, to
complement mobility protocols and enable optimized DMM operation. Such optimization we see
in terms of transport costs, routing path, latency, etc.

We'd appreciate any comments and contributions to the framework. Please also refer to the
slides from last meeting to recall the status of the work.

http://www.ietf.org/proceedings/87/slides/slides-87-dmm-11.pdf

marco

---

From: <[email-masked]>
Date: Thu, 31 Oct 2013 16:58:53 +0100

Dear Marco, all,

I think the idea of describing mobility management functions in a generic and modular way can help to allow for fair comparison of different existing approaches and new extensions towards fulfillment of DMM requirements. As your draft shows also routing-protocol based approaches as LISP can be described by this nomenclature.  With the new functional entities - and the defined reference points in between - and the abstraction of the mobility related ones it thus should help to analyse general network architectures and functional decompositions for both fixed and mobile sessions - in a similar fashion as SDN/NFV (Software Defined Networks/Network Function Virtualization) concepts proceed.

As usually the network analysis will focus on the performance parameters denoted below.  I think therefore the framework activities are valuable work from an operators point of view which we should intensify - thus perhaps helping the resulting protocol proposals to be deployed in reality one day.

Perhaps one could add in sect. 4.1/4.2 that within MN in Fig. 2 and Fig.3 the corresponding FEs FE_MU_U and FE_MU_C are not included since for PMIP6 they reside in MAG ... this surely will become clear from the appendices A1/A2 later on. 

If I remember correctly it was agreed that both framework documents (i.e. compared to http://tools.ietf.org/id/draft-chan-dmm-framework-03.txt) with their different way of abstraction can complement each other and should continue, right?

Thanks!

Best regards
Dirk

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marco Liebsch
Sent: Sonntag, 27. Oktober 2013 22:02
To: [email-masked]
Subject: [DMM] DMM framework

Folks,

marco

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm