Subject: [DMM] rechartering draft text updated

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 12:02:32 +0200

Folks,

Take a look at the latest revision. I have added the initial stab
for the milestones. Comments and flames are welcome. If you want
something to be changed, just propose text & diff. You might also
want to say why the change is needed.

https://github.com/jounikor/dmm-re-charter/blob/master/recharter_draft.txt

- Jouni

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 26 Mar 2014 14:32:04 +0000

Hi Jouni,

In paragraph 5, it says:

"At least IPv6 is assumed to be present in both the mobile host/router
 and the access networks."

I disagree with the trailing phrase "and the access networks"
since many access networks may remain as IPv4-only for a long
time yet. It would satisfy my concern if the sentence were
modified to simply drop the trailing phrase.

Thanks - Fred
[email-masked]

> -----Original Message-----
> From: dmm [mailto:[email-masked]] On Behalf Of Jouni Korhonen
> Sent: Wednesday, March 26, 2014 3:03 AM
> To: [email-masked]
> Subject: [DMM] rechartering draft text updated
> 
> Folks,
> 
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: Alper Yegin <[email-masked]>
Date: Wed, 26 Mar 2014 17:08:20 +0200

Hi Jouni,

      DMM can be used to realise such a distributed deployment
      model, by distributing forwarding functions at optimal location; for
      example, closer either to the mobile user or the corresponding node.

s/user/node

      Although the maintenance of stable home address(es) and/or prefix(es)
      and upper level sessions is a desirable goal when mobile hosts/routers
      change their point of attachment to the Internet, it is not a strict
      requirement. Mobile hosts/routers should not assume that IP
      addressing including home address(es) and/or home network prefix(es)
      remain the same throughout the entire upper level session lifetime,
      or that support for mobility functions is provided on the network side
      in all conditions, unless these properties are specifically indicated
      to the mobile node and its applications from the network.

Is this trying to say "the network may not be able to provide a stable IP address to the MN"?
Even in the presence of a DMM solution?

  Mar 2014 - Submit 'The deployment models and scenarios' submitted to the IESG.
                    To be Informational RFC.
  Marc 2014 - Submit 'Enhanced gateway and mobility anchor selection' submitted to the
                    IESG. To be Proposed Standard.

I guess these are meant to be 2015.

Btw, the milestones do not seem to have an item to cover for "Forwarding path and signalling management"

Thanks Jouni

Alper

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 17:41:02 +0200

I hear you.. but this is what the original charter already said.
We deliberately scope the charter in a way that we could avoid
tunnelling between the end host and the access router.

- Jouni

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 17:47:19 +0200

>       example, closer either to the mobile user or the corresponding node.

Ack.

> Even in the presence of a DMM solution?

Yes.. it is imho a valid use case that the mn just does not care all addresses having mobility. The DMM solution may provide stable address only for a subset of addresses available for the mn.

> I guess these are meant to be 2015.

Uhh.. yes. (copy-paste is always dangerous)

> Btw, the milestones do not seem to have an item to cover for "Forwarding path and signalling management"

Not at this point. Two reasons: I could not figure a good name for the milestone and also was a bit concerned whether we would have all the energy to work on this many documents in parallel.

- Jouni

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 26 Mar 2014 15:50:39 +0000

Hi Jouni,

> From: Jouni Korhonen [mailto:[email-masked]]
> Sent: Wednesday, March 26, 2014 8:41 AM
> To: Templin, Fred L
> Cc: [email-masked]
> Subject: Re: [DMM] rechartering draft text updated
> 
> 

What I am suggesting entails tunneling *over* the access router and
to a mobility gateway of some kind, or tunneling directly from end
host to end host when route optimization is employed. The tunneling
could be IPv6-over-IPv6 or IPv6-over-IPv4.

Thanks - Fred

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 26 Mar 2014 10:59:46 -0500

Hi Jouni,

Thanks for your hard work on the charter text.

> want to say why the change is needed.

I don't understand why we have re-selection as a separate charter item?
Do you have an example document, draft which would qualify for this item?

I would also suggest taking currently available solution candidate, i.e.
vEPC draft and please tell us how that document fits into this charter?

Lastly, at the end of the charter a statement on rechartering or closing
down is needed for technical reasons, I think.

Regards,

Behcet

---

From: Alper Yegin <[email-masked]>
Date: Wed, 26 Mar 2014 20:11:08 +0200

> Not at this point. Two reasons: I could not figure a good name for the milestone and also was a bit concerned whether we would have all the energy to work on this many documents in parallel.

Jouni, that is the essential deliverable of the DMM WG, IMO.

Alper

---

From: Jouni <[email-masked]>
Date: Wed, 26 Mar 2014 20:25:55 +0200

> Jouni, that is the essential deliverable of the DMM WG, IMO.

And how you would like to see that milestone to be formulated here?
Give some text us to jump into..

Cheers,
	2001:db8::4a:6f75:6e69

---

From: Alper Yegin <[email-masked]>
Date: Thu, 27 Mar 2014 09:05:13 +0200

You already have text for that: "Forwarding path and signalling management"

You can use that name for the deliverable.

Alper

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 27 Mar 2014 09:30:58 +0200

> You can use that name for the deliverable.

Right. I was, though, expecting something that I could copy-paste directly.
Any desires for timelines?

Cheers,
	49.1972.0112.1111.1711.0105.00