Subject: [DMM] DMM solution space

From: Alper Yegin <[email-masked]>
Date: Sat, 12 Jul 2014 14:13:29 +0300

Folks,

I went over the solutions and categorized them.

I haven't covered all of the solutions (due to lack of time). For any I-D that is missing, please state the name and where you think it belongs to.

When we agree with the categorization and the candidates for each, then we can proceed to discussing how we can converge. 

Note: Multiple I-Ds under each category may be complementary, competing, or orthogonal (e.g., due to different applicability). It's case by case.

Cheers,

- Per-flow IP address configuration according to mobility needs

Apps indicating their mobility needs to the IP stack on the MN, and associated IP configuration signaling between the MN and the network.

draft-bhandari-dhc-class-based-prefix-03
draft-korhonen-dmm-prefix-properties-00.txt
draft-yegin-dmm-ondemand-mobility-02

- Mobility solution selection 

MN determining the type of mobility solution(s) it'd apply to a given flow.

draft-yegin-ip-mobility-orchestrator-00

- IP anchor selection

MN selecting the IP anchor node after it decides to use IP anchoring (whether in the access network or the core network).

draft-aliahmad-dmm-anchor-selection-00.txt

- Access network anchoring

Anchoring IP address within the access network using IP-in-IP tunneling.

draft-bernardos-dmm-cmip-01
draft-bernardos-dmm-pmip-03
draft-bernardos-dmm-distributed-anchoring-04
draft-chan-dmm-enhanced-mobility-anchoring-00
draft-sarikaya-dmm-for-wifi-00.txt
draft-seite-dmm-dma-07.txt
draft-xuan-dmm-nemo-dmm-02.txt

- Corresponding node/network anchoring

Anchoring IP address on the Corresponding Node or Corresponding Network.

Mobile IPv6 route optimization
draft-yegin-dmm-cnet-homing-02
draft-xiong-dmm-ip-reachability-01

- Host-route based intra-domain solutions

Non-tunneling solutions.

draft-chan-dmm-enhanced-mobility-anchoring-00
draft-matsushima-stateless-uplane-vepc-02
draft-mccann-dmm-flatarch-00

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 14 Jul 2014 15:59:20 +0000

Hi Alper,

Please add AERO to your list:

draft-templin-aerolink-29

To categorize, I would say the best fit is "Corresponding node/network anchoring",
but AERO also handles mobile networks and not just mobile hosts.

Thanks - Fred

From: dmm [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: Saturday, July 12, 2014 4:13 AM
To: [email-masked]
Subject: [DMM] DMM solution space

Folks,

Cheers,

- IP anchor selection

Non-tunneling solutions.

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 14 Jul 2014 16:34:02 -0500

Hi Alper,

Two comments:

1. I think you should include only the active contributions. This
might reduce your list quite a bit.

2. Please put draft-sarikaya-dmm-for-wifi-
00.txt
into non-tunneling solutions category.

Regards.

Behcet

On Sat, Jul 12, 2014 at 6:13 AM, Alper Yegin <[email-masked]> wrote:
> I haven't covered all of the solutions (due to lack of time). For any I-D
> that is missing, please state the name and where you think it belongs to.
>
> When we agree with the categorization and the candidates for each, then we
> can proceed to discussing how we can converge.
>
> Note: Multiple I-Ds under each category may be complementary, competing, or
> orthogonal (e.g., due to different applicability). It's case by case.
>
>
> Cheers,
>
>
>
> Apps indicating their mobility needs to the IP stack on the MN, and
> associated IP configuration signaling between the MN and the network.
>
> MN selecting the IP anchor node after it decides to use IP anchoring
> (whether in the access network or the core network).
>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: Alper Yegin <[email-masked]>
Date: Thu, 17 Jul 2014 09:19:49 +0300

Folks,

Let's change gears.

We'd like to propose draft-yegin-dmm-ondemand-mobility-02 for WG adoption.

This draft falls under the following deliverable:

        Exposing mobility state to mobile nodes and network nodes:
        define solutions that allow, for example, mobile nodes to select
        either a care-of address or a home address depending on an
        application' mobility needs. In order to enable this
        functionality, the network side control functions and other
        networking nodes must also be able to exchange appropriate
        control information, as well as to the mobile nodes and their
        applications.

Comments welcome.

Alper

Behcet/Fred: I've updated the list with your input.

- IP anchor selection

Non-tunneling solutions.

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 17 Jul 2014 19:03:30 +0300

Alper,

The charter text you cite is not approved yet. I-D adoption requests at 
this point are premature.

- Jouni

7/17/2014 9:19 AM, Alper Yegin kirjoitti:
> *
> *
> _define solutions that allow, for example, mobile nodes to select_
> _        either a care-of address or a home address depending on an_
> _        application' mobility needs_. In order to enable this
> *
> *
> *
> *
> *- Per-flow IP address configuration according to mobility needs*
>
> *- Mobility solution selection *
>
> *- IP anchor selection*
> *- Access network anchoring*
>
> *- Corresponding node/network anchoring*
>
> *- Host-route based intra-domain solutions*
>
> Non-tunneling solutions.
>

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 17 Jul 2014 19:07:12 +0300

Since you are collecting the list, there is one PMIPv6 extension that 
deals with access network short lived addresses (where MAG would be the 
access DPA): draft-korhonen-dmm-local-prefix-01

I think it belongs to "Anchoring IP address within the access network 
using IP-in-IP tunneling" in your categorization.

- Jouni

7/12/2014 2:13 PM, Alper Yegin kirjoitti:
> I haven't covered all of the solutions (due to lack of time). For any
> I-D that is missing, please state the name and where you think it
> belongs to.
>
> When we agree with the categorization and the candidates for each, then
> we can proceed to discussing how we can converge.
>
> Note: Multiple I-Ds under each category may be complementary, competing,
> or orthogonal (e.g., due to different applicability). It's case by case.
>
>
> Cheers,
>
>
>

---

From: Alper Yegin <[email-masked]>
Date: Thu, 17 Jul 2014 19:42:31 +0300

Hi Jouni,

We cannot have an official approval of the documents,
but what we can do is:
- check the WG to see if they are willing to accept a document, based on the assumption that the new charter would be approved
- if the WG is OK, then when the charter is approved, we can double check on the mailing list and make WG adoption official.

We should progress…

Alper

On Jul 17, 2014, at 7:03 PM, Jouni Korhonen wrote:

> Alper,
> 
> The charter text you cite is not approved yet. I-D adoption requests at this point are premature.
> 
> - Jouni
>

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 17 Jul 2014 20:22:02 +0300

Lets get the charter approved first.

- jouni

---

From: Alper Yegin <[email-masked]>
Date: Thu, 17 Jul 2014 21:04:49 +0300

Why? Why not make technical progress at every opportunity? 
This extreme serialization and every step overly stretching…. am I the only one having issue with the slow progress?

Alper

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Thu, 17 Jul 2014 18:11:53 +0000

I'm in favor of this approach. This was my suggestion as well in the past
(when we presented prefix coloring spec) to move forward some documents.
But, those should be documents which are considered common across multiple
solution approaches. The issue seems to be charter approval.

Sri

On 7/17/14 11:04 AM, "Alper Yegin" <[email-masked]> wrote:

>This extreme serialization and every step overly stretchingŠ. am I the
>only one having issue with the slow progress?
>
>Alper
>
>

---

From: Alper Yegin <[email-masked]>
Date: Thu, 17 Jul 2014 22:45:09 +0300

On Jul 17, 2014, at 9:11 PM, Sri Gundavelli (sgundave) wrote:

> solution approaches.

Obviously. And that's the case in this particular instance.

Recapping the DMM solution space analysis below.

Per-flow IP address configuration according to mobility needs

Mobility solution selection 

IP anchor selection

Access network anchoring

Corresponding node/network anchoring

Host-route based intra-domain solutions

Non-tunneling solutions.

Alper

> The issue seems to be charter approval.
> 
> 
> 
> 
> Sri
> 
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 17 Jul 2014 15:19:49 -0500

Hi Alper,

draft-sarikaya-dmm-for-wifi-
00.txt does not use anchoring, I don't know how many times I should tell?

It simply extends vEPC, so it should be classified wherever vEPC is
classified, and I don't care where.

Regards,

Behcet

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 18 Jul 2014 00:22:45 +0300

The list is still missing draft-korhonen-dmm-local-prefix-01.

- Jouni

7/17/2014 10:45 PM, Alper Yegin kirjoitti:
> *Per-flow IP address configuration according to mobility needs*
>
> *Mobility solution selection *
>
> *IP anchor selection*
> *Access network anchoring*
>
> *Corresponding node/network anchoring*
>
> *Host-route based intra-domain solutions*
>
> Non-tunneling solutions.
>
>> On 7/17/14 11:04 AM, "Alper Yegin" <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>>