Subject: Re: [DMM] WGLC #2 for draft-ietf-dmm-best-practices-gap-analysis-04

From: h chan <[email-masked]>
Date: Thu, 3 Jul 2014 20:07:44 +0000

I also like to try more generic wording. How about the following:

   2.  Internetwork Location Information (LI) function: managing and
       keeping track of the internetwork location of an MN.  The
       location information may be a binding of the IP advertised
       address/prefix (e.g., HoA or HNP) to the IP routing address of
       the MN or of a node that can forward packets destined to the MN.
       It is a control plane function.

       In a client-server protocol model, location information query and update
       messages may be exchanged between a location information client
       (LIc) and a location information server (LIs).

   3.  Forwarding Management (FM) function: packet interception and
       forwarding to/from the IP address/prefix assigned to the MN,
       based on the internetwork location information, either to the
       destination or to some other network element that knows how to
       forward the packets to their destination.

       FM may optionally be split into the control plane (FM-CP) and
       data plane (FM-DP).

They are two basic functions of a network: to process information and to forward. It also specifically includes "binding" in the information. 

H Anthony Chan

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 05, 2014 3:23 AM
To: Jouni Korhonen; Charlie Perkins; [email-masked]
Cc: [email-masked]
Subject: Re: [DMM] WGLC #2 for draft-ietf-dmm-best-practices-gap-analysis-04

Hi,

Just to explain why we chose the term "Location management" instead of "binding management": 

Actually, we have considered that "binding management" has too much IP mobility flavor and we wanted something more generic. BTW, of course, LM refers to IP location management...  "binding management" is fine but it may implicitly lead the reader to consider only IP mobility protocols... So,  we use "Location management" to be more generic and open the door to other mobility management mechanisms. That said, I'll not oppose to use "binding management" if there is a group consensus.

Pierrick

>-----Message d'origine-----
>De : dmm [mailto:[email-masked]] De la part de Jouni Korhonen 
>Envoyé : mercredi 4 juin 2014 22:29 À : Charlie Perkins; [email-masked] 
>Cc : [email-masked] Objet : Re: [DMM] WGLC #2 for 
>draft-ietf-dmm-best-practices-gap-analysis-
>04
>
>
>Charlie,
>
>Right, sorry for missing these.
>
>- jouni
>
>
>6/3/2014 8:37 AM, Charlie Perkins kirjoitti:
>>
>> Hello Jouni,
>>
>> I communicated three issues:
>>
>> - The gap does not explain the gaps between the requirements and
>>      FMIP / [seamoby] documents / [hokey]
>> - The document does not explain the relevance of the SIPTO example
>>      in fulfilling the requirements.  In fact, SIPTO has "limited mobility
>>      support".
>> - The document uses terminology "LMs" and "LMc" that could be
>>      improved.  Almost every existing IETF approach refers to some sort
>>      of "binding management", and it would be better to stay aligned
>>      with that.  This is especially true lately, since "location 
>> management"
>>      is relevant to advertisements and even surveillance.
>>
>> Regards,
>> Charlie P.
>>
>>
>> On 6/2/2014 9:25 PM, Jouni Korhonen wrote:
>>> Folks,
>>>
>>> The WGLC has ended for this I-D. There was one comment on the list:
>>> http://www.ietf.org/mail-archive/web/dmm/current/msg01152.html
>>>
>>> I also sent few editorial/typo correction comments offline to the 
>>> authors while doing my review for the proto write-up.
>>>
>>> We take the I-D passed the WGLC #2 but a new quick revision to 
>>> include the two comments is needed before we ship the I-D out of the
>WG.
>>>
>>> - Jouni (as a DMM co-chair)
>>>
>>>
>>> 5/26/2014 6:39 AM, Jouni Korhonen kirjoitti:
>>>> Folks,
>>>>
>>>> This email starts a one week WGLC #2 for 
>>>> draft-ietf-dmm-best-practices-gap-analysis-04. Issue you comments 
>>>> to the mailing list and place possible tickets to the issue tracker.
>>>> There are quite a few changed mainly to tackle Charlie's comments.
>>>>
>>>> The WGLC ends 2ns June 2014 EOB (EEST). Silence is accounted as an 
>>>> acceptance for the content.
>>>>
>>>> - Jouni (as a DMM co-chair)
>>>
>>> _______________________________________________
>>> dmm mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dmm
>>>
>>
>
>_______________________________________________
>dmm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dmm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: Alper Yegin <[email-masked]>
Date: Thu, 3 Jul 2014 23:37:47 +0300

Anthony,

LI == FM-CP ?

Alper

---

From: h chan <[email-masked]>
Date: Mon, 7 Jul 2014 22:05:46 +0000

Alper,

First of all, I am open to suggestions to improve the description. If you feel it is simpler to combine RM-CP and LI under CP-DP separation, I am open to suggestions to make the description simple and general.

The change, however, was an attempt to resolve all the previous comments. So I first try to make the description correct in the current draft: 

The current draft has Routing management and Location Information.
Without CP-DP separation, they are RM and LI
With CP-DP separation, the data plane has RM-DP, and the control plane has RM-CP and LI.

H Anthony Chan

-----Original Message-----
From: Alper Yegin [mailto:[email-masked]] 
Sent: Thursday, July 03, 2014 3:38 PM
To: h chan
Cc: [email-masked]; Jouni Korhonen; Charlie Perkins; [email-masked]; [email-masked]
Subject: Re: [DMM] WGLC #2 for draft-ietf-dmm-best-practices-gap-analysis-04

Anthony,

LI == FM-CP ?

Alper

On Jul 3, 2014, at 11:07 PM, h chan wrote:

> Subject: Re: [DMM] WGLC #2 for 
> draft-ietf-dmm-best-practices-gap-analysis-04
> 
> Hi,
> 
> ______________________________________________________________________
> ___________________________________________________
>