Subject: [DMM] question on 'draft-moses-dmm-dhcp-ondemand-mobility'

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 3 Apr 2015 18:12:50 +0000

Hi Danny and Alper,

In this draft, you seem to be considering only DHCPv6 address delegation for
when the node is acting as a mobile host. I am wondering if there are similar
considerations for DHCPv6 prefix delegation for when the node is acting as
a mobile router.

But then, I wonder whether any type of prefix delegation other than a
fixed prefix makes any sense. For example, if the mobile router received
a nomadic prefix delegation, would it need to renumber its connected
networks every time it moves and receives a new nomadic prefix?

Should this document discuss prefix delegation considerations for mobile
routers, or only address delegation for mobile hosts?

Thanks - Fred
[email-masked]

---

From: "Moses, Danny" <[email-masked]>
Date: Sun, 5 Apr 2015 11:49:07 +0000

Hi Fred,

I think we should explore prefix delegation as well. I am not familiar enough if router requirements for prefix delegation and thus would appreciate your help - please describe a use-case and we can evaluate it.

I can also think of a use-case for mobile hosts and Sustained IP addresses:

In the past, I presented a scenario is which it is preferable to anchor an IP flow in an anchor that is not necessarily the closest to the mobile node (please refer to draft-aliahmad-dmm-anchor-selection-01). This situation can be detected either by the network or by the mobile node.

If we want to enable mobile nodes to select a preferred anchor, we need to provide means for mobile nodes to express the desired selection. One way is enable mobile nodes to request a specific anchor by indicating an IP prefix that was provided by that anchor in the past. This could be done by 'hinting' the preferred IP prefix (rather than a specific IP address).

Clearly there is more work to be done on this draft and we are welcoming help from anyone in the group. Can you help us with the router part?

Thanks,

                /Danny

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Friday, April 03, 2015 21:13
To: [email-masked]
Subject: [DMM] question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Danny and Alper,

In this draft, you seem to be considering only DHCPv6 address delegation for when the node is acting as a mobile host. I am wondering if there are similar considerations for DHCPv6 prefix delegation for when the node is acting as a mobile router.

But then, I wonder whether any type of prefix delegation other than a fixed prefix makes any sense. For example, if the mobile router received a nomadic prefix delegation, would it need to renumber its connected networks every time it moves and receives a new nomadic prefix?

Should this document discuss prefix delegation considerations for mobile routers, or only address delegation for mobile hosts?

Thanks - Fred

[email-masked]<mailto:[email-masked]>

_______________________________________________

dmm mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dmm
---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 7 Apr 2015 22:35:37 +0000

Hi Danny,

Let me know what I can do to help with the mobile router part.

Thanks - Fred

From: Moses, Danny [mailto:[email-masked]]
Sent: Sunday, April 05, 2015 4:49 AM
To: Templin, Fred L; [email-masked]
Subject: RE: question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Fred,

Thanks,

                /Danny

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Friday, April 03, 2015 21:13
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Danny and Alper,

Thanks - Fred

dmm mailing list

---

From: "Moses, Danny" <[email-masked]>
Date: Tue, 14 Apr 2015 08:06:31 +0000

Hi,

Can you please provide text that describes the use-case and the proposed technical modifications/additions to support the use-case?

Thanks,
                /Danny

From: Templin, Fred L [mailto:[email-masked]]
Sent: Wednesday, April 08, 2015 01:36
To: Moses, Danny; [email-masked]
Subject: RE: question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Danny,

Thanks - Fred

From: Moses, Danny [mailto:[email-masked]]
Sent: Sunday, April 05, 2015 4:49 AM
To: Templin, Fred L; [email-masked]<mailto:[email-masked]>
Subject: RE: question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Fred,

Thanks,

                /Danny

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Friday, April 03, 2015 21:13
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] question on 'draft-moses-dmm-dhcp-ondemand-mobility'

Hi Danny and Alper,

Thanks - Fred

dmm mailing list

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 21 Apr 2015 21:45:44 +0200

Le 03/04/2015 20:12, Templin, Fred L a écrit :
> [email-masked]

I second this question.

I have already tried to raise this issue to authors and believe they 
have an oppinion on it.

Alex