Subject: Re: [DMM] conclusion of adoption calls

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 8 Jan 2016 13:54:24 +0100

Le 22/12/2015 04:56, Jouni a écrit :
>
> Behcet,
>
> Thank you for your constructive comments. I believe academic
> conferences/journals are not appropriate venues for PMIPv6/MIPv6
> maintenance since these protocol families are already past their
> prime time as “hot research topics". Looking at the existing charter
> I cannot find too much love towards anything IPv4 so I think we can
> let MIPv4 finally rest in peace.

Jouni I can agree with you in general.

But let me suggest that MIPv4 and MIPv6 are two implementations very 
important in some places including where I work.

They are no longer 'hot' as you say, but there are certainly protocol 
and implementation bugs which need correction.  Actually some of the 
corrections have already been applied but are not reflected in RFCs.

Sometimes there is a feeling of frustration if implementations thrive 
where WG cares little.

<provocative> a widespread implementation of MIP6 is still bugged and 
does not respect the MIPv6 RFC - do you want that discussed 
publicly?</provocative>.

Alex

>
> - Jouni
>
>
>> On 21 Dec 2015, at 09:46, Behcet Sarikaya <[email-masked]>
>> wrote:
>>
>> Hi Jouni, all,
>>
>> Let me ask what is the point in maintaining the protocols that no
>> one uses? For academic purposes? If yes, then they should find
>> their places in the conferences or journals.
>>
>> Now, mip4 WG has been closed. So is dmm going to maintain mip4 as
>> well?
>>
>> Regards,
>>
>> Behcet
>>
>> On Fri, Dec 18, 2015 at 5:45 AM, Carlos Jesús Bernardos Cano
>> <[email-masked]> wrote:
>>> Hi Jouni, all,
>>>
>>> Although I'm already late, I just wanted to express my
>>> post-adoption call to the three drafts.
>>>
>>> Carlos
>>>
>>> On Wed, 2015-12-16 at 08:32 -0800, Jouni Korhonen wrote:
>>>> Folks,
>>>>
>>>> The WG adoption call for all three I-Ds have completed:
>>>> draft-gundavelli-dmm-lma-controlled-mag-params-00
>>>> draft-yan-dmm-hnprenum-03 draft-seite-dmm-rg-multihoming-02
>>>>
>>>> The adoption for the first two was unanimous. The last
>>>> (draft-seita- *) received few concerns but the number of
>>>> supporters was enough to convince the chairs there is enough
>>>> interest and support to work on it. The chairs encourage the
>>>> authors of draft-seite-* to pay close attention and work out
>>>> the concerns raised during the adoption call.
>>>>
>>>> For the I-D authors. Please, submit draft-ietf-*-00 versions of
>>>> the documents as soon as possible.
>>>>
>>>> - Jouni & Dapeng
>>>>
>>>> _______________________________________________ dmm mailing
>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/dmm
>>>
>>> _______________________________________________ dmm mailing list
>>> [email-masked] https://www.ietf.org/mailman/listinfo/dmm
>
> _______________________________________________ dmm mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/dmm
>

---

From: Thierry Ernst <[email-masked]>
Date: Fri, 8 Jan 2016 15:50:31 +0100

Hi Alex, all,

My understanding of what Jouni wrote is that it’s fine to work on MIP6 improvement, but the MIP4 can live its life as is, to which I totally agree. And I also agree with Alex that we need to fix bugs in MIP6 (and the related suite, in particular NEMO) and progress them in the standard track. It has been too long since we last work on those and now it is certainly right to do it. 

So, the question is if DMM is the right place or not to do the work, if not I would like to hear about alternatives within the IETF. 

Regards,
Thierry. 

> Le 8 janv. 2016 à 13:54, Alexandre Petrescu <[email-masked]> a écrit :
> 
> 
> 
> But let me suggest that MIPv4 and MIPv6 are two implementations very important in some places including where I work.
> 
> They are no longer 'hot' as you say, but there are certainly protocol and implementation bugs which need correction.  Actually some of the corrections have already been applied but are not reflected in RFCs.
> 
> Sometimes there is a feeling of frustration if implementations thrive where WG cares little.
> 
> <provocative> a widespread implementation of MIP6 is still bugged and does not respect the MIPv6 RFC - do you want that discussed publicly?</provocative>.
> 
> Alex
> 
>> 
>> - Jouni
>> 
>> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Fri, 8 Jan 2016 15:06:29 +0000

Hi Thierry,

DMM has the charter for  the NEMO protocol maintenance. So, it is the right group and you should be able to bring maintenance and deployment related extensions to this group. 

Regards
Sri

> On Jan 8, 2016, at 6:50 AM, Thierry Ernst <[email-masked]> wrote:
> 
> 
> Hi Alex, all,
>

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 8 Jan 2016 08:39:56 -0800

As Sri pointed out DMM is OK to work on "maintenance-oriented extensions 
of the Mobile IPv6 protocol family". So this is likely the venue within 
IETF. Mobile IPv4 as such has no place here.

- Jouni

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 8 Jan 2016 11:15:40 -0600

On Fri, Jan 8, 2016 at 10:39 AM, Jouni Korhonen <[email-masked]> wrote:
>
> As Sri pointed out DMM is OK to work on "maintenance-oriented extensions of
> the Mobile IPv6 protocol family". So this is likely the venue within IETF.
> Mobile IPv4 as such has no place here.
>

Why not ISE? For both MIPv6 and MIPv4.
Of course you may not be able modify existing RFCs but just write it
as a new draft and do not bother dmm where future protocol work is
supposed to be done.

Behcet

>> My understanding of what Jouni wrote is that it’s fine to work on MIP6
>> improvement, but the MIP4 can live its life as is, to which I totally agree.
>> And I also agree with Alex that we need to fix bugs in MIP6 (and the related
>> suite, in particular NEMO) and progress them in the standard track. It has
>> been too long since we last work on those and now it is certainly right to
>> do it.
>>
>> So, the question is if DMM is the right place or not to do the work, if
>> not I would like to hear about alternatives within the IETF.
>>
>> Regards,
>> Thierry.
>>
>>
>>
>>> They are no longer 'hot' as you say, but there are certainly protocol and
>>> implementation bugs which need correction.  Actually some of the corrections
>>> have already been applied but are not reflected in RFCs.
>>>

---

From: "Jouni.nosmap" <[email-masked]>
Date: Fri, 8 Jan 2016 10:34:32 -0800

Well one can always pursue ISE/AD sponsored track if one so feels like.

Just saying there are options..  if one desires to go through the WG process DMM has provisions for Mobile IPv6 protocol family maintenance work. 

Jouni

Sent from a smart phone.. Mind the typos..

> Behcet Sarikaya <[email-masked]> kirjoitti 8.1.2016 kello 9.15:
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 8 Jan 2016 13:48:32 -0600

> Just saying there are options..  if one desires to go through the WG process DMM has provisions for Mobile IPv6 protocol family maintenance work.

I started this thread by stating that:

Let me ask what is the point in maintaining the protocols that no one uses?
For academic purposes? If yes, then they should find their places in
the conferences or journals.

No one objected to the first point.

So what is the justification for maintenance? As I said before,
charter items can be changed or they do not have to be used.

Behcet

---

From: Thierry Ernst <[email-masked]>
Date: Sat, 9 Jan 2016 12:56:52 +0100

What are protocols you think no one uses ? 

MIPv6 and NEMOv6 needs maintenance, and probably more than than maintenance. 

Regards,
Thierry Ernst.

> Le 8 janv. 2016 à 20:48, Behcet Sarikaya <[email-masked]> a écrit :
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 11 Jan 2016 10:35:31 -0600

> MIPv6 and NEMOv6 needs maintenance, and probably more than than maintenance.

Thierry, I meant PMIPv6 which was designed for operator networks.

For MIPv6/NEMOv6, I think in Europe, some research based use is
happening, to my knowledge at a very small scale.
mip6 WG has been closed long time ago.
I wish it were still open, that would be like in good old days.

So conference papers and ISE is still my recipe.

Regards,

Behcet

---

From: Thierry Ernst <[email-masked]>
Date: Mon, 11 Jan 2016 18:23:09 +0100

The purpose of conference papers is to do research, so I don’t see how conferences papers would help to do … maintenance of IETF RFCs. In addition to bug fixes, MIPv6 and NEMO need to be progressed in the IETF hierarchy of standards. There are issues and options to be discussed, probably even extensions; a WG must host such work. My take is that dmm is the right candidate WG for this to happen.

Regards,
Thierry Ernst.

> Le 11 janv. 2016 à 17:35, Behcet Sarikaya <[email-masked]> a écrit :
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 11 Jan 2016 11:47:07 -0600

> The purpose of conference papers is to do research, so I don’t see how conferences papers would help to do … maintenance of IETF RFCs. In addition to bug fixes, MIPv6 and NEMO need to be progressed…

I still don't see any statements from you on the real need or use. You
talk as if even a BoF is needed, if yes that's what you should go for.

Regards,

Behcet

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 11 Jan 2016 12:55:47 -0800

<in a chair mode>

This thread is starting to sound like a broken record. We are chartered 
to have the maintenance responsibility of Mobile IPv6 protocol family. 
Once the chairs see absence of "maintenance oriented" documents that 
responsibility will be terminated. Till then, if someone does not like 
Mobile IPv6 protocol family work being done - just defer contributing. 
That's the natural way of aging out topics in IETF. Enough of this for now!

Another data point to add here. To my (probably misguided?) 
understanding PMIP6 has more live deployments than MIP6 today. My 
understanding is that there are still operators running PMIP6 based 
networks and some vendors developing networking gear with PMIP6 support.

- Jouni

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Jan 2016 11:19:15 -0600

Hi Jouni,

On Mon, Jan 11, 2016 at 2:55 PM, Jouni Korhonen <[email-masked]> wrote:
> <in a chair mode>
>
> This thread is starting to sound like a broken record. We are chartered to
> have the maintenance responsibility of Mobile IPv6 protocol family. Once the
> chairs see absence of "maintenance oriented" documents that responsibility
> will be terminated. Till then, if someone does not like Mobile IPv6 protocol
> family work being done - just defer contributing. That's the natural way of
> aging out topics in IETF. Enough of this for now!
>
> Another data point to add here. To my (probably misguided?) understanding
> PMIP6 has more live deployments than MIP6 today. My understanding is that
> there are still operators running PMIP6 based networks and some vendors
> developing networking gear with PMIP6 support.
>

This paragraph conflicts the first one, now you are opening another
discussion point.

Can you please kindly be more specific?

Respectfully yours,

Behcet
>>> The purpose of conference papers is to do research, so I don’t see how
>>> conferences papers would help to do … maintenance of IETF RFCs. In addition
>>> to bug fixes, MIPv6 and NEMO need to be progressed in the IETF hierarchy of
>>> standards. There are issues and options to be discussed, probably even
>>> extensions; a WG must host such work. My take is that dmm is the right
>>> candidate WG for this to happen.
>>>
>>
>>>>>>> Just saying there are options..  if one desires to go through the WG
>>>>>>> process DMM has provisions for Mobile IPv6 protocol family maintenance work.
>>>>>>>
>>>>>>
>>>>>>>>>>>>>> list