Subject: Re: [DMM] New version of the OnDemand Mobility draft

From: Jouni Korhonen <[email-masked]>
Date: Fri, 1 Jul 2016 10:46:44 -0700

Danny, Alex,

Would you sort this out asap to some rough consensus..

- Jouni

6/30/2016, 11:40 PM, Alexandre Petrescu kirjoitti:
> My concern is partially addressed, yes.
>
> There is still this text which can be improved:
>>    - Session-lasting IP Address
>>
>>    A session-lasting IP address is an address assigned to the mobile
>>    host by the network [...]
>
> A session-lasting IP address is an address formed in conjunction by the
> host and the network (SLAAC), or assigned by the network (DHCP) [...]
>
> A session-lasting IP prefix is a prefix advertised to the mobile host by
> the network [...]
>
> Alex
>
>
> Le 30/06/2016 à 19:05, Jouni Korhonen a écrit :
>> Seil, Alex,
>>
>> Have your concerns been addressed in the -06 revision?
>>
>> - Jouni
>>
>> 6/30/2016, 2:20 AM, Moses, Danny kirjoitti:
>>>
>>> Hi,
>>>
>>> I have posted a new version of the OnDemand Mobility draft:
>>> _draft-ietf-dmm-ondemand-mobility-06_
>>> <https://datatracker.ietf.org/doc/draft-ietf-dmm-ondemand-mobility/>.
>>> This new version includes some text editing according to the comments
>>> from Seil and change of classification from the Standard track to
>>> Informational.
>>>
>>> Please support it (those who have not cast their support yet).
>>>
>>> Thanks,
>>>         /Danny
>>>
>>>
>>> ---------------------------------------------------------------------
>>> A member of the Intel Corporation group of companies
>>>
>>> This e-mail and any attachments may contain confidential material for
>>> the sole use of the intended recipient(s). Any review or distribution
>>> by others is strictly prohibited. If you are not the intended
>>> recipient, please contact the sender and delete all copies.
>>>
>>>
>>>
>>> _______________________________________________
>>> dmm mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dmm
>>>
>>

---

From: "Moses, Danny" <[email-masked]>
Date: Sun, 3 Jul 2016 14:03:45 +0000

Hi Alex,

>From the standard point of view, IPv6 indeed provides two alternatives: Stateless and Stateful address assignment, and the text in the draft does not mention this and might even be misleading to assume that the network always assigns the source IP address - so I agree with your comment.

The reason for that is that this draft is meant for application developers who need to understand how they can influence the network behavior through address type request. For them, the exact mechanism of address assignment is a detail which might be confusing. Our thinking was, that even in the stateless case the generated source IP address comprises a network prefix that was assigned by some entity in the network. So the text is still true for the Stateless case.

If you still think that this is too misleading, I propose the following change:

1.       Remove the text - 'assigned to the mobile host by the network' in the definition of both the Fixed IP address and Session-lasting IP address.

2.       Add a comment indicating that the IP address may either be assigned to the mobile host by the network (Stateful address assignment) or generated by the host using a Prefix that was assigned by the network (stateless)

As a result, the text in this section will become (new text in red):

   Three types of IP addresses are defined with respect to the mobility
   management.

   - Fixed IP Address

   A Fixed IP address is an address assigned to the mobile host by the
   network with a guarantee to be valid for a very long time, regardless
   of whether it is being used in any packets to/from the mobile host,
   or whether or not the mobile host is connected to the network, or
   whether it moves from one point-of-attachment to another (with a
   different subnet or IP prefix) while it is connected.

   Fixed IP address are required by applications that need both IP
   session continuity and IP address reachability.

   A session-lasting IP address is an address assigned to the mobile
   host by the network with a guarantee to be valid through-out the IP
   session(s) for which it was requested.  It is guaranteed to be valid
   even after the mobile host had moved from one point-of-attachment to
   another (with a different subnet or IP prefix).

   Session-lasting IP addresses are required by applications that need
   IP session continuity but do not need IP address reachability.

   - Non-persistent IP Address

   This type of IP address provides neither IP session continuity nor IP
   address reachability.  The IP address is obtained from the serving IP
   gateway and it is not maintained across gateway changes.  In other
   words, the IP address may be released and replaced by a new IP address
   when the IP gateway changes due to the movement of the mobile host.

   Applications running as servers at a published IP address require a
   Fixed IP Address.  Long-standing applications (e.g., an SSH session)
   may also require this type of address.  Enterprise applications that
   connect to an enterprise network via virtual LAN require a Fixed IP
   Address.

   Applications with short-lived transient IP sessions can use Session-
   lasting IP Addresses.  For example: Web browsers.

   Applications with very short IP sessions, such as DNS client and
   instant messengers, can utilize Non-persistent IP Addresses.  Even
   though they could very well use a Fixed of Session-lasting IP
   Addresses, the transmission latency would be minimized when a Non-
   persistent IP Address is used.

   The network creates the desired guarantee (Fixed, Session-lasting or

   Non-persistent) by either assigning an address (as part of a stateful

   address generation), or by assigning the address prefix (as part of a

   stateless address generation).

Does this change addresses your concerns?

Thanks,

                /Danny

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]]
Sent: Friday, July 01, 2016 09:41
To: [email-masked]; Seil Jeon
Cc: Moses, Danny; [email-masked]
Subject: Re: [DMM] New version of the OnDemand Mobility draft

>    host by the network [...]

A session-lasting IP address is an address formed in conjunction by the host and the network (SLAAC), or assigned by the network (DHCP) [...]

A session-lasting IP prefix is a prefix advertised to the mobile host by the network [...]

Alex

>> [email-masked]<mailto:[email-masked]>

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 5 Jul 2016 16:48:45 +0200

Hi Danny,

Le 03/07/2016 à 16:03, Moses, Danny a écrit :
> Hi Alex,
>
>
>
> From the standard point of view, IPv6 indeed provides two alternatives:
> Stateless and Stateful address assignment, and the text in the draft
> does not mention this and might even be misleading to assume that the
> network always assigns the source IP address – so I agree with your comment.
>
>
>
> The reason for that is that this draft is meant for application
> developers who need to understand how they can influence the network
> behavior through address type request. For them, the exact mechanism of
> address assignment is a detail which might be confusing. Our thinking
> was, that even in the stateless case the generated source IP address
> comprises a network prefix that was assigned by some entity in the
> network. So the text is still true for the Stateless case.
>
>
>
> 1.       Remove the text – 'assigned to the mobile host by the network'
> in the definition of both the Fixed IP address and Session-lasting IP
> address.
>
> 2.       Add a comment indicating that the IP address may either be
> assigned to the mobile host by the network (Stateful address assignment)
> or generated by the host using a Prefix that was assigned by the network
> (stateless)
>
>
>

Yes, this change addresses my concerns.

Alex

>>> [email-masked] <mailto:[email-masked]>
>

---

From: "Moses, Danny" <[email-masked]>
Date: Wed, 6 Jul 2016 07:53:37 +0000

Hi Alex,

Thanks for the support.
I will issue a new version shortly.

Regards,
	/Danny

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]] 
Sent: Tuesday, July 05, 2016 17:49
To: Moses, Danny
Cc: [email-masked]; [email-masked]; Seil Jeon
Subject: Re: [DMM] New version of the OnDemand Mobility draft

Hi Danny,

Le 03/07/2016 à 16:03, Moses, Danny a écrit :
> network always assigns the source IP address - so I agree with your comment.
>
>
>
> behavior through address type request. For them, the exact mechanism 
> of address assignment is a detail which might be confusing. Our 
> thinking was, that even in the stateless case the generated source IP 
> address comprises a network prefix that was assigned by some entity in 
> the network. So the text is still true for the Stateless case.
>
>
>
> If you still think that this is too misleading, I propose the 
> following
> change:
>
> 1.       Remove the text - 'assigned to the mobile host by the network'
> assigned to the mobile host by the network (Stateful address 
> assignment) or generated by the host using a Prefix that was assigned 
> by the network
> (stateless)
>
>
>

Alex

> A session-lasting IP address is an address formed in conjunction by 
> the host and the network (SLAAC), or assigned by the network (DHCP) 
> [...]
>
>
>