Subject: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 9 Jan 2019 18:43:21 +0000

Folks - As we discussed in the WG meeting at IETF103, we are issuing WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11.

The document went through several revisions and there were good amount of reviews on this document.  The authors have addressed all the comments and there are no open issues that we are tracking at this time. We believe the document is ready for IESG reviews and like to confirm the same from the working group.

The following message commences a two week WGLC for all feedback.

Document Link:
https://www.ietf.org/id/draft-ietf-dmm-distributed-mobility-anchoring-11.txt

The target status for this document is "Informational".

Please post any comments/concerns on the draft.

Thanks!
Dapeng & Sri

---

From: "Moses, Danny" <[email-masked]>
Date: Tue, 15 Jan 2019 11:35:26 +0000

Hi,
I support WGLC for this draft.

Danny

From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Wednesday, January 09, 2019 20:43
To: [email-masked]
Subject: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Document Link:

Thanks!
Dapeng & Sri

---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: Fabio Giust <[email-masked]>
Date: Wed, 16 Jan 2019 10:21:03 +0100

Dear all,

I also support moving the draft forward.

Best regards,

Fabio Giust, PhD
Senior System Architect
Athonet S.r.l. - Operations HQ
Via Ca’ Del Luogo, 6/8, 36050 Bolzano Vicentino (VI), Italy
www.athonet.com
Email: fabio.giust@athonet,com
Tel: +39 (0)444 750045
Deploy your own professional LTE network with Athonet Bubblecloud at
https://athonet.cloud/

On Wed, Jan 9, 2019 at 7:43 PM Sri Gundavelli (sgundave) <[email-masked]>
wrote:

> Folks – As we discussed in the WG meeting at IETF103, we are issuing WGLC
> on draft-ietf-dmm-distributed-mobility-anchoring-11.
>
> The document went through several revisions and there were good amount of
> reviews on this document.  The authors have addressed all the comments and
> there are no open issues that we are tracking at this time. We believe the
> document is ready for IESG reviews and like to confirm the same from the
> working group.
>
>
> The target status for this document is “Informational”.
>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

-- 
Fabio Giust, PhD
Senior System Architect
Athonet S.r.l.

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 16 Jan 2019 14:12:08 +0000

I am ok with the current version.

Just update reference to I-D.bernardos-dmm-pmipv6-dlif, which is draft-ietf now.

marco

From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Mittwoch, 9. Januar 2019 19:43
To: [email-masked]
Subject: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Wed, 16 Jan 2019 15:26:33 +0100

Thanks Marco. Will do.

Carlos

On Wed, Jan 16, 2019 at 3:12 PM Marco Liebsch <[email-masked]>
wrote:

> *From:* dmm [mailto:[email-masked]] *On Behalf Of *Sri Gundavelli
> (sgundave)
> *Sent:* Mittwoch, 9. Januar 2019 19:43
> *To:* [email-masked]
> *Subject:* [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11
>
>
>
> <https://www.ietf..org/id/draft-ietf-dmm-distributed-mobility-anchoring-11.txt>
>
>
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 16 Jan 2019 23:24:58 +0000

Hi, I read this document and it seems to imply that anchors necessarily aggregate
short prefixes. For example, an anchor might aggregate a prefix like 2001:db8::/32
and give out ::/64 prefixes to mobile nodes. This preserves the notion of a home
network that is identified by an aggregated prefix - so the global routing system
can identify the home network by the short prefix.

On the other hand, 'draft-ietf-rtgwg-atn-bgp' assumes that there is no such
aggregation, and that the anchor has no short prefix associated with it. Then,
when a mobile associates with an anchor the anchor injects the mobile's ::/64
prefix into the global routing system. If the mobile moves to a new anchor,
the old anchor withdraws the /64 and the new anchor injects it instead. In
other words, the system is based on complete de-aggregation and there is
no notion of a "home" network - the mobile is always "away from home".

This is a very different model, and naturally supports continuity of the mobile's
mobile network prefix at all times due to the nature of the routing system. It
provides "scalable de-aggregation", which is something that the routing
research group (RRG) investigated but has not been accomplished until now.

I think it would be worth considering this model both on its own merits and/or
in conjunction with the dmm document. The notion of a "home network" need
not be preserved, and instead we have scalable de-aggregation. Please have a
look (as I did for the dmm doc) and post comments or questions.

Thanks - Fred

From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Wednesday, January 09, 2019 10:43 AM
To: [email-masked]
Subject: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Document Link:

Thanks!
Dapeng & Sri

---

From: "Luis M. Contreras" <[email-masked]>
Date: Thu, 17 Jan 2019 15:56:37 +0100

Hi all, 

I support the WGLC for this draft. 

Best regards 

Luis 

-- 
___________________________________________

Luis M. Contreras
[email-masked]
[email-masked]

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Thu, 17 Jan 2019 18:05:50 +0000

Thanks Fred for your feedback.

Authors: Please respond to Fred's comments and see if we need any additional text.

Sri

From: "Templin (US), Fred L" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 16, 2019 at 3:24 PM
To: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Thanks - Fred

From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Wednesday, January 09, 2019 10:43 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Sun, 20 Jan 2019 13:21:45 +0100

Hi Fred,

Thanks for your comments. Please see inline below.

On Thu, Jan 17, 2019 at 12:25 AM Templin (US), Fred L <
[email-masked]> wrote:

> network that is identified by an aggregated prefix – so the global routing
> system
>

The draft documents multiple "anchoring" options. One implies that the
anchors do anchor some prefixes. One natural deployment option is that they
are aggregated in short prefixes, but other approaches are also possible.
Non aggregatable prefixes could also be used by the anchors.

>
> On the other hand, ‘draft-ietf-rtgwg-atn-bgp’ assumes that there is no such
>
> when a mobile associates with an anchor the anchor injects the mobile’s
> ::/64
>
> prefix into the global routing system.. If the mobile moves to a new
> anchor,
>
> no notion of a “home” network – the mobile is always “away from home”.
>

This is an example of solution of what the document classifies under
"Mobility case, anchor relocation".

>
> This is a very different model, and naturally supports continuity of the
> mobile’s
>
> provides “scalable de-aggregation”, which is something that the routing
>
> in conjunction with the dmm document. The notion of a “home network” need
>

I think this is already considered in the " Mobility case, anchor
relocation" in the draft. We can add additional references as examples of
this, but I'd prefer not to add more text, as we are trying to keep the
document short and what you have described is covered IMHO with the current
text.

Thanks,

Carlos

> *Sent:* Wednesday, January 09, 2019 10:43 AM
> *To:* [email-masked]

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 21 Jan 2019 18:09:36 +0000

Hi Carlos,

I think this is already considered in the " Mobility case, anchor relocation" in the draft. We can add additional references as examples of this, but I'd prefer not to add more text, as we are trying to keep the document short and what you have described is covered IMHO with the current text.

>> Scalable de-aggregation (and the routing system required to  route it ) is not covered in
>> ‘draft-ietf-dmm-distributed-mobility-anchoring’; it is covered in ‘draft-ietf-rtgwg-atn-bgp’
>> (a wg item of the RTGWG) and ‘draft-templin-intarea-6706bis’ from which the RTGWG
>> doc was derived. Please add references and supporting text.
>>
>> Thanks - Fred

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Mon, 21 Jan 2019 19:40:40 +0100

Hi Fred,

We’ll add the ref in the next revision. Thanks for the feedback.

Carlos

-- 
Sent from a mobile device, please excuse any brevity or typing errors.

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 21 Jan 2019 19:43:46 +0000

Sounds good; thanks Carlos.

Fred

From: CARLOS JESUS BERNARDOS CANO [mailto:[email-masked]]
Sent: Monday, January 21, 2019 10:41 AM
To: Templin (US), Fred L <[email-masked]>
Cc: Sri Gundavelli (sgundave) <[email-masked]>; [email-masked]
Subject: Re: [DMM] WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Hi Fred,

Carlos

On Mon, 21 Jan 2019 at 19:09, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Hi Carlos,

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 28 Jan 2019 18:15:37 +0000

Thanks for all the feedback.

Authors: Please post a revised document, addressing all the comments that you have received.

Sri

From: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 9, 2019 at 10:43 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: WGLC on draft-ietf-dmm-distributed-mobility-anchoring-11

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Mon, 28 Jan 2019 20:52:03 +0100

Hi Sri,

We'll do. Thanks!

Carlos

On Mon, Jan 28, 2019 at 7:15 PM Sri Gundavelli (sgundave) <
[email-masked]> wrote:

> From: Sri Gundavelli <[email-masked]>
> To: "[email-masked]" <[email-masked]>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 29 Jan 2019 16:03:57 +0100

Hi Sri,

We have just submitted a new version addressing all the comments received:

https://tools.ietf.org/html/draft-ietf-dmm-distributed-mobility-anchoring-12

Thanks,

Carlos