Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 9 Jan 2019 18:43:30 +0000

Folks - As we discussed in the WG meeting at IETF103, we are issuing WGLC on https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt.

We have also made one key change to the document status, moving it from Standards Track to Experimental Track. We the chairs have talked to the authors and they are OK with this change. We are dong this as we are not sure about any potential vendor implementations and so we chose to keep this on experimental track.

The document went through several revisions and there were good amount of reviews on this document.  The authors have addressed all the comments and there are no open issues that we are tracking at this time. We believe the document is ready for IESG reviews and like to confirm the same from the working group.

The following message commences a two week WGLC for all feedback.

Document Link:
 https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt

The target status for this document is "Experimental".

Please post any comments/concerns on the draft.

Thanks!
Dapeng & Sri

---

From: "Moses, Danny" <[email-masked]>
Date: Tue, 15 Jan 2019 11:32:56 +0000

Hi,

I support WGLC for this draft.

Danny

From: Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jan 9, 2019 at 7:43 PM
Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Folks – As we discussed in the WG meeting at IETF103, we are issuing WGLC on https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt.

Document Link:
 https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt<https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03..txt>

The target status for this document is “Experimental”.

Thanks!
Dapeng & Sri

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm
---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: Akbar Rahman <[email-masked]>
Date: Tue, 15 Jan 2019 13:34:04 +0000

+1

I support progressing this document.  As mentioned by Sri, this document has good through several reviews already, and I think it is in good shape
.

Best Regards,

Akbar

From: dmm [mailto:[email-masked]] On Behalf Of Moses, Danny
Sent: Tuesday, January 15, 2019 6:33 AM
To: [email-masked]
Subject: Re: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Hi,

Danny

Folks - As we discussed in the WG meeting at IETF103, we are issuing WGLC on https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-ietf-dmm-pmipv6-dlif-03.txt&data=02%7C01%7CAkbar.Rahman%40InterDigital.com%7C60274eeab4b34a7c71ff08d67add3f2c%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636831488005258628&sdata=GoGZrluqjX6gEPkzX3iWJW9mosQw56UHQZJlNEdml%2BE%3D&reserved=0>.

Document Link:
 https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-ietf-dmm-pmipv6-dlif-03..txt&data=02%7C01%7CAkbar.Rahman%40InterDigital.com%7C60274eeab4b34a7c71ff08d67add3f2c%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636831488005258628&sdata=CDUxNnfJvMooSN2666U4mpJmmRT6G54XxU78XgsmKag%3D&reserved=0>

Thanks!
Dapeng & Sri

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=02%7C01%7CAkbar.Rahman%40InterDigital.com%7C60274eeab4b34a7c71ff08d67add3f2c%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636831488005258628&sdata=W7lx74PGJ2u09iyEuJ7lB%2FoBAS4uN9IqpDQgOeU5PZ8%3D&reserved=0>

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 16 Jan 2019 07:21:13 +0000

+1

I support WGLC for this draft. Experimental track seems to be a good choice as well for this draft.

Cheers,
Pablo.

From: dmm <[email-masked]> on behalf of Akbar Rahman <[email-masked]>
Date: Tuesday, 15 January 2019 at 15:34
To: "[email-masked]" <[email-masked]>
Subject: Re: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

+1

Best Regards,

Akbar

Hi,

Danny

Folks – As we discussed in the WG meeting at IETF103, we are issuing WGLC on https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-ietf-dmm-pmipv6-dlif-03.txt&data=02%7C01%7CAkbar.Rahman%40InterDigital.com%7C60274eeab4b34a7c71ff08d67add3f2c%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636831488005258628&sdata=GoGZrluqjX6gEPkzX3iWJW9mosQw56UHQZJlNEdml%2BE%3D&reserved=0>.

Document Link:
 https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt<https://na01.safelinks..protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-ietf-dmm-pmipv6-dlif-03..txt&data=02%7C01%7CAkbar.Rahman%40InterDigital.com%7C60274eeab4b34a7c71ff08d67add3f2c%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636831488005258628&sdata=CDUxNnfJvMooSN2666U4mpJmmRT6G54XxU78XgsmKag%3D&reserved=0>

Thanks!
Dapeng & Sri

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 16 Jan 2019 14:32:31 +0000

I support progressing this version of the document on the experimental track.

marco

From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Mittwoch, 9. Januar 2019 19:44
To: [email-masked]
Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Document Link:

Thanks!
Dapeng & Sri

---

From: <[email-masked]>
Date: Wed, 16 Jan 2019 16:17:39 +0000

Hi all,
I agree to forward the mature and very useful document to IESG.

I just detected 3 very minor nits presumably created during recent re-formatting:
P.7
the MN-ID, Pref1 and MAAr1's address as a Proxy-CoA => the MN-ID, Pref1, and MAAR1's address as a Proxy-CoA

5. MAAR1 stores the BCE described in (1) an unicast a Router Advertisement (RA) to the MN with Pref1 => 5. MAAR1 stores the BCE described in (1) and unicasts a Router Advertisement (RA) to the MN with Pref1
P.9
Step 6. Is an empty one and SHOULD be deleted
;-)

Thanks!
Kind regards
Dirk

From: dmm <[email-masked]> On Behalf Of Sri Gundavelli (sgundave)
Sent: Mittwoch, 9. Januar 2019 19:44
To: [email-masked]
Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Wed, 16 Jan 2019 23:54:28 +0100

Hi Dirk,

Thanks a lot. We'll address your comments once the WGLC is finished.

Carlos

On Wed, Jan 16, 2019 at 5:17 PM <[email-masked]> wrote:

> 5. MAAR1 stores the BCE described in (1) an unicast a Router Advertisement
> (RA) to the MN with Pref1 => 5. MAAR1 stores the BCE described in (1) and
> unicasts a Router Advertisement (RA) to the MN with Pref1
>
> P.9
>
> *From:* dmm <[email-masked]> *On Behalf Of *Sri Gundavelli
> (sgundave)
> *Sent:* Mittwoch, 9. Januar 2019 19:44
> *To:* [email-masked]
> *Subject:* [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03
>
>
>
> Folks – As we discussed in the WG meeting at IETF103, we are issuing WGLC
> on https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt.
>
>
>
> *We have also made one key change to the document status, moving it from
> Standards Track to Experimental Track. We the chairs have talked to the
> authors and they are OK with this change. We are dong this as we are not
> sure about any potential vendor implementations and so we chose to keep
> this on experimental track.*
>
>
>
> The document went through several revisions and there were good amount of
> reviews on this document.  The authors have addressed all the comments and
> there are no open issues that we are tracking at this time. We believe the
> document is ready for IESG reviews and like to confirm the same from the
> working group.
>
>
>
>
>
> <https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03..txt>
>
>
>

---

From: "Luis M. Contreras" <[email-masked]>
Date: Thu, 17 Jan 2019 15:57:53 +0100

Hi all, 

I support the WGLC for this draft, as well. 

Best regards 

Luis 

On 2019-01-09 19:43, Sri Gundavelli (sgundave) wrote:

> WE HAVE ALSO MADE ONE KEY CHANGE TO THE DOCUMENT STATUS, MOVING IT FROM STANDARDS TRACK TO EXPERIMENTAL TRACK. WE THE CHAIRS HAVE TALKED TO THE AUTHORS AND THEY ARE OK WITH THIS CHANGE. WE ARE DONG THIS AS WE ARE NOT SURE ABOUT ANY POTENTIAL VENDOR IMPLEMENTATIONS AND SO WE CHOSE TO KEEP THIS ON EXPERIMENTAL TRACK. 
> 
> https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03.txt [1] 
> 
> [email-masked]

-- 
___________________________________________

Luis M. Contreras
[email-masked]
[email-masked] 

Links:
------
[1] https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03..txt

---

From: John Kaippallimalil <[email-masked]>
Date: Sat, 19 Jan 2019 17:11:36 +0000

Review and comments on draft-ietf-dmm-pmipv6-dlif-03.

The text in the draft is clear, and it is ready to move forward in my view.

A couple of comments below:
(not repeating nits that Dirk has already posted)

Section 3:
"As another note, the solution described in this document allows performing per-prefix anchoring decisions, to support e.g., some flows to be anchored at a central Home-DPA (like a traditional LMA)"
Would be good to clarify a bit here: is this a result of the MN requesting central anchoring (or not), or the result of the mobility topology (MAARs, CMDs).

Section 3.4:
Does the implementation with parallel operations need to mention something about race conditions.
It is probably fine in practice, but not a completely safe operation (e.g., MAAR2 may forward data to MAAR1 before the route update at MAAR1 is complete)
Overall - the draft looks really good and ready.

John

From: dmm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, January 16, 2019 10:18 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Hi all,

Thanks!
Kind regards
Dirk

From: dmm <[email-masked]<mailto:[email-masked]>> On Behalf Of Sri Gundavelli (sgundave)
Sent: Mittwoch, 9. Januar 2019 19:44
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Sun, 20 Jan 2019 13:11:29 +0100

Thanks a lot John! We'll address your comments in the next revision.

Carlos

On Sat, Jan 19, 2019 at 6:11 PM John Kaippallimalil <
[email-masked]> wrote:

> “As another note, the solution described in this document allows
> performing per-prefix anchoring decisions, to support e.g., some flows to
> be anchored at a central Home-DPA (like a traditional LMA)”
>
> Would be good to clarify a bit here: is this a result of the MN requesting
> central anchoring (or not), or the result of the mobility topology (MAARs,
> CMDs).
>
>
>
> Section 3.4:
>
> It is probably fine in practice, but not a completely safe operation
> (e.g., MAAR2 may forward data to MAAR1 before the route update at MAAR1 is
> complete)
>
> Overall – the draft looks really good and ready.
>
>
>
> John
>
>
>
>
>
>
>
> *From:* dmm [mailto:[email-masked]] *On Behalf Of *
> [email-masked]
> *Sent:* Wednesday, January 16, 2019 10:18 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03
>
>
>
> Hi all,
>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 28 Jan 2019 18:16:02 +0000

Thanks for all the feedback.

Authors: Please post a revised document, addressing all the comments that you have received.

Sri

From: dmm <[email-masked]<mailto:[email-masked]>> on behalf of Sri Gundavelli <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 9, 2019 at 10:43 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [DMM] WGLC on draft-ietf-dmm-pmipv6-dlif-03

Document Link:

Thanks!
Dapeng & Sri

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Mon, 28 Jan 2019 20:51:55 +0100

Hi Sri,

We'll do. Thanks!

Carlos

On Mon, Jan 28, 2019 at 7:16 PM Sri Gundavelli (sgundave) <
[email-masked]> wrote:

> From: dmm <[email-masked]> on behalf of Sri Gundavelli <
> [email-masked]>
> <https://www.ietf.org/id/draft-ietf-dmm-pmipv6-dlif-03...txt>
>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 29 Jan 2019 16:42:39 +0100

Hi Sri,

We have submitted a new version addressing all the comments we received:

https://tools.ietf.org/html/draft-ietf-dmm-pmipv6-dlif-04

Thanks!

Carlos