Subject: [Dmsp] RE: DMSP vs EMMA

From: "Engelsma Jonathan-QA2678" <[email-masked]>
Date: Fri, 14 Apr 2006 10:04:59 -0400

Hello Aurelien,
 
See my response embedded below.  Thanks for reading the draft and providing your input.
 
-jre
 
ps - I've cc'd the dmsp list on my response, as there are others there who have made similar suggestions.

________________________________

From: GUILLOU Aurelien RD-SIRP-LAN [mailto:[email-masked]] 
Sent: Friday, April 14, 2006 4:17 AM
To: Engelsma Jonathan-QA2678
Subject: DMSP vs EMMA

Hi Jonathan, 

I've read the specification of the EMMA at the W3C, and I wonder how we can insert the EMMA messages in the 
DMSP protocol. My view is that EMMA should describe the recognition results for example from the server to the client in 

a DSMP response MESSAGE. Is DSMP should really encapsulates EMMA messages ?  

JRE: Yes.  EMMA messages could be carried as "extended recognition results".  See section 4.2.2.9 in the spec. 

DSMP messages are really closed to VoiceXML events / commands (NOINPUT, NOMATCH,...). Multimodal services can be done without VoiceXML browser (without VXML scripts) with only simple ASR/TTS ressources (only launch recognition or synthesis process). Do you plan to open / enlarge the DMSP protocol to "simple" Voice server (ASR+TTS without VoiceXML) ?   

JRE: We intentionally designed the protocol to operate at the dialog level, as this helps keep the protocol amenable to implementations that involve low bandwidth, high latency networks and resource constrained clients.   That said, you aren't the first one to bring this point up both on the mailing list and in offline discussions.  If there are additional features required by the particular multimodal use cases you have in mind that aren't already adequately addressed by MRCP,  please share them on the dmsp list.    We would like to maintain support for dialog level control messages, but at the same time are open to supporting other configurations as well, as long as we can keep the message set and associated state machines simple and compact. 

Thanks for your response, 
Best Regards. 
Aurélien. 

Aurélien Guillou 
France Télécom 
Recherche & Développement 
SIRP/SIS/SIT 
Ingénieur R&D 
2, avenue Pierre Marzin 
22307 LANNION Cedex 
Tel : + 33 (0)2 96 05 94 26 
Fax : + 33 (0)2 96 05 18 49 
http://www.francetelecom.com/rd <http://www.francetelecom.com/rd>  

_______________________________________________
Dmsp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dmsp

---

From: Chris Cross <[email-masked]>
Date: Fri, 14 Apr 2006 12:47:05 -0400

> DSMP messages are really closed to VoiceXML events / commands
> (NOINPUT, NOMATCH,…). Multimodal services can be done without
> VoiceXML browser (without VXML scripts) with only simple ASR/TTS
> ressources (only launch recognition or synthesis process). Do you
> plan to open / enlarge the DMSP protocol to "simple" Voice server
> (ASR+TTS without VoiceXML) ?

I agree with other's responses to Aurelien. However, we must take care to
not duplicate the function of MRCP. The domain we're working in is the
sychronization of modalities within a dialog. I think if all an application
wants to do is speech enable itself through a low level speech engine
interface then MRCP may be the correct route for that.

chris cross