Subject: [dns-dir] FW: DISCUSS: draft-ietf-enum-combined

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 6 Nov 2008 14:08:10 +0100

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pasi Eronen
Sent: Thursday, November 06, 2008 3:07 PM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: DISCUSS: draft-ietf-enum-combined 

Discuss:
A question: has this document been reviewed by the DNS directorate? 
In particular, I'm wondering if the use of DNAME records is consistent
with current thinking about DNS, and with the currently deployed
infrastructure? (That is, if DNAME records as described would be
created, would the ENUM clients and caching DNS resolvers process them
as intended?)

_______________________________________________
dns-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dns-dir

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 6 Nov 2008 16:03:31 +0100

See in-line. 

Regards,

Dan

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Otmar Lendl
> Sent: Thursday, November 06, 2008 4:30 PM
> To: Pasi Eronen
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: DISCUSS: draft-ietf-enum-combined
> 
> Pasi Eronen wrote:
> > Discuss:
> There has been no formal review by DNS directorate.
> 
> I had extensive discussions regarding this draft with various 
> members, e.g. Olafur, Olaf and Peter.
> 
> What is the procedure to actually initiate a formal review from them?

You send a mail to [email-masked] or ask one of the OPS or INT ADs for
a review. 

In principle when the document comes to the IESG agenda for approval it
will be scanned by the DNS-DIR folks for any DNS-related content, and
then a review is triggered if necessary. 

If you do not want however to get your comments too late it's better for
the authors PROTO shepherd to ask for an early review and discussions
with DNS-DIR. These happened in this case as I understand, even if the
review was not formal. 

> Well, a few points here:
> * This is exactly what DNAME was invented for. If it doesn't work
>   in this case, then DNAME is fundamentally unsound.
> 
> * DNAME is currently being tested as a way to introduce 
> internationalized
>   TLDs: See e.g.
> 
>    
> http://icann.org/announcements/dname-white-paper-verisign-17nov05.pdf
>    http://jprs.co.jp/en/topics/080929.html
> http://www.ripe.net/ripe/meetings/ripe-56/presentations/YONEYA
-DNAME_Issues_Regarding_IDN_TLD.pdf

  There seem to be political issues, but I haven't found a technical
  report listing technical problems with this approach.

* there is not really any installed base to consider: I-ENUM is
  a green field deployment as of now. We don't have to care about
  stone-age DNS elements which have to continue to work.

  This is why I included the section on transition in this ID: so
  that people who start to deploy I-ENUM are aware that their gear
  needs to support DNAME for the future transition process.

cheers,

/ol
--
// Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 //
_______________________________________________
dns-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dns-dir