Subject: Comments on draft-aboba-dnsext-mdns-01.txt?

From: "Bernard Aboba" <[email-masked]>
Date: Sat, 23 Sep 2000 08:02:42 -0700

This is a request for feedback on 
draft-aboba-dnsext-mdns-01.txt. 
Please post comments to the list
and/or the authors. 

Ideally we would like to get a 
revised version of the draft out by 
the second week of October. The
revised version will be renamed
as a WG draft, as decided at IETF 48. 

Since this is an early draft there
are probably a lot of things to be
fixed and improved. To speed that
process along, if you have specific
text you'd like to change, it would
be helpful if you could include the
suggested replacement text with your
comment so that we can incorporate
your changes quickly. 

All suggestions/comments will be
acknowledged in the acknowledgments
section. 

to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.

---

From: "Bernard Aboba" <[email-masked]>
Date: Sat, 30 Sep 2000 11:58:13 -0700

To stimulate discussion, I thought I'd post a
list of issues that came up in the
process of going over the draft. If you have
opinions on these or other topics, please 
respond to the list. 

a. Does mDNS apply only to QCLASS=IN or can it
apply to other QCLASSes as well?
 
b. Should the response only return NS and SOA RRs to a 
   query with QTYPE=ANY? Or should it return other
   records as well? 

c. Are there any OPCODE restrictions (e.g. no OPCODE=1?)

d. What happens if the TC flag is set in the reply?

e. Should the response always have the RA bit clear? What if it doesn't?

f. Are RRs ever returned in the additional section? If so, is any language
required in the draft relating to validation of these RRs?

g. Should the AA bit be set in responses?

h. Should we have any language about what should be permitted in
the ensuing unicast queries?

i. What is the default value of TTL used in unicast queries? 

j. What is the implied TTL for negative caching when there is
no multicast response? 
 
k. Is no response equivalent to NXRRSET or NXDOMAIN?

l. How will mDNS work with DNSSEC? 
     Hosts can generate KEY and SIG RRs, but how can
     they get the KEY record signed? There is no name server
     authoritative for the .lcl.arpa domain, right?