Subject: Fw: DNSSEC (RE: Software for PKI)

From: "James Seng/Personal" <[email-masked]>
Date: Thu, 15 Nov 2001 01:16:20 +0800

----- Original Message -----
From: "Eric Rescorla" <[email-masked]>
To: <[email-masked]>
Cc: "Anders Rundgren" <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Friday, November 09, 2001 11:58 PM
Subject: Re: DNSSEC (RE: Software for PKI)

>
> [email-masked] writes:
> > 5) In a DNSSEC world, browser could obtain a valid ip-address and
public
> > key in the same DNS transaction. By definition, the ip-address is
trusted
> > (so the issue of domain name to ip-address translation is
eliminated).
> > Also, by definition the public key for that "domain
name/ip-address/public
> > key" tuble is trusted. Majority of the protocol setup chatter in the
> > existingf SSL is eliminated ... since there is real-time trusted key
> > distribution (as part of real-time trusted ip-address distribution).
So the
> > only real SSL setup step that is left is the validaty of some signed
> > something from the server.
> Actually, very little of the SSL protocol overhead is concerned with
> certificate issues. Most of it is concerned with ciphersuite
negotiation,
> key exchange and handshake verification, none of which would be
> affected significantly by DNSSEC.
>
> The typical SSL handshake is:
>
> C: ClientHello (ciphersuites, random, session id)
> S: ServerHello (ciphersuite selection, random, session id)
> S: Certificate
> S: ServerHelloDone
> C: ClientKeyExchange
> C: ChangeCipherSpec
> C: Finished
> S: ChangeCipherSpec
> S: Finished
>
> In a hypothetical world in which we had DNSSEC we'd be able to
eliminate
> exactly one of these messages, the server Certificate.
>
> I agree that a world with DNSSEC would be potentially more secure than
> the current world of SSL certificates, but it wouldn't make SSL
> much simpler.
>
> -Ekr
>
> --
> [Eric Rescorla                                   [email-masked]]
>                 http://www.rtfm.com/

to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.

---

From: Brian Wellington <[email-masked]>
Date: Wed, 14 Nov 2001 11:26:47 -0800 (PST)

(If anyone wants to forward this to the original sender, go ahead.  I'm
not going anywhere near a PKIX mailing list)

On Thu, 15 Nov 2001, James Seng/Personal wrote:

> > > key in the same DNS transaction.

Not true.  There is no good way of obtaining records of multiple DNS types 
in a single transaction.  ANY queries don't always work correctly.  While 
a KEY record will often be returned in the additional section of an A 
query, it is the key for the zone, not the host.

> > > By definition, the ip-address is trusted
> > > (so the issue of domain name to ip-address translation is eliminated).

True, but there's still the issue about whether the SSL connection is to 
the correct machine.

> > > Also, by definition the public key for that "domain name/ip-address/public
> > > key" tuble is trusted.

Yes, although an additional DNS query is needed to get the public key.

> > > Majority of the protocol setup chatter in the
> > > distribution (as part of real-time trusted ip-address distribution). So the

I don't think this will really help anything all that much.  It just moves 
a bit of work from the SSL client into the DNS client.  The same amount of 
work still needs to be done.

Brian