Subject: Fw: I-D ACTION:draft-song-dnsext-nai-support-00.txt

From: <[email-masked]>
Date: Fri, 11 Jan 2002 08:54:06 +0900 (KST)

-------DMGEF9SY8VAHC.697QEYERYLH44HQ7.
I would assign a one specific domain name to that
purpose
So for example if I assign/reserver some domain names like
naiservice=2Emit=2Eedu for that purpose, I don't give hostnames having suffix as
naiservice=2Emit=2Eedu for other purpose=2E Then although you concatenate any username
to that domain name like anyusername=2Enaiservice=2Emit=2Eedu, it'll not conflick with
other hostnames

to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.

---

From: "송준혁" <[email-masked]>
Date: Fri, 11 Jan 2002 09:35:12 +0900 (KST)

Hi all,

In 3GPP2 P.S0001-B, we are currently supporting the service call IRS (Internet Reachability Service), which is using DNS "A Record" for one to one mapping between mobile host IP address and NAI (user.realm.  format).  Although NAI actually form of user.specific_node.domain, there are still some possibility can cause some confusion.  I believe separately defining "NAI" as DNS RR, helps clarify that problem.

Speaking of IMPP, what defining NAI in DNS RR can do far more than just instant message service.
One of the application, we are thinking for Internet Reachability Service (IRS) is push service.
Contents provider can provide certain contents service, regardless of location of user.
User can be travelling from Asia to US, and could simply register for updating NAI with temporaly IP address.  It may work regardless of access network (Wideband CDMA, CDMA2000, Bluetooth, and Wireless LAN).  It can provide always on user reachbility which is actually user mobility.
Unlike SIP which is very specific for VoIP, defining NAI as a DNS RR can provide far much general way of user (Mobile Host) location service.

Eventually it may interwork with ENUM which will provide interoperability between Internet and PSTN.
And it is currently under investigate.

Thanks
JunHyuk

Ben Clifford <[email-masked]> writes:

> Perhaps you shouldn't use the root DNS name as the realm name?
> 
> For example,
> warlord.student-realm.mit.edu
> or
> warlord.faculty-realm.mit.edu

You are implying a separation where one does not exist.  There _is_
no "[email-masked]".

My point was that "warlord@.mit.edu." would work but removing the
trailing '@' causes problems.  Obviously there are other naming
tricks we could do (I believe you are suggesting that, but I disagree
with your example suggestion).  I think a better suggestion would
be:
warlord._user.mit.edu.

> If you are putting in symbols to separate out different kinds of object, I
> would think that the standard way to do it (x.subdomain.y.gov) would be
> the better way?

No, because you have the same potential problem... If you ever have a
user name that matches a subdomain you get into trouble.  The only way
to do it is to create a special subdomain (ala SRV records) that uses
a special name which you can pretty much guarantee will never exist.

Never mind the fact that I'm not convinced the NAI record is something
that needs to happen.  We already have IMPP; why do we need DNS to
give the same location information?  IMPP is already designed to have
users register their precense (location) information.  I'm not
convinced that DNS can provide the level of dynamic or duplicate
information that IMPP can provide.

-derek

-- 
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [email-masked]                        PGP key available

---

From: Derek Atkins <[email-masked]>
Date: 10 Jan 2002 20:04:37 -0500

"XXXXXX" <[email-masked]> writes:

> Hi all,
> 
> In 3GPP2 P.S0001-B, we are currently supporting the service call IRS
> (Internet Reachability Service), which is using DNS "A Record" for
> one to one mapping between mobile host IP address and NAI
> (user.realm.  format).  Although NAI actually form of
> user.specific_node.domain, there are still some possibility can
> cause some confusion.  I believe separately defining "NAI" as DNS
> RR, helps clarify that problem.

Why can't you just just the Home Address for this?  Sure, the first
packet will have to go through the home agent, but you just need to
provide a service that says "Mobile Host A.B.C.D is currently located
at Care-of Address W.X.Y.Z".

> just instant message service.

So can IMPP.  The PP stands for "Precence Protocol".  The hope is to
have a general "user X is reachable via this list of protocols" where
each list-entry is a URI defining a communication protocol, an
address, and perhaps a "local name".

For example, my reachability could be:
	im:[email-masked]
	voice:+1.617.555.1212
	fax:+1.617.555.1234
	email:[email-masked]

The PP in IMPP is meant to go far beyond just IM.

> User can be travelling from Asia to US, and could simply register
> for updating NAI with temporaly IP address.  It may work regardless
> of access network (Wideband CDMA, CDMA2000, Bluetooth, and Wireless
> LAN).  It can provide always on user reachbility which is actually
> user mobility.

I don't believe that DNS is the right place to do this.  You really
want a local lookup service based on your home address.  If you're
moving a lot, in a MIPv6 world, you might be changing your care-of
address ever few seconds (or maybe every minute).  DNS just can't keep
up with that level of data dynamics.

> Unlike SIP which is very specific for VoIP, defining NAI as a DNS RR
> can provide far much general way of user (Mobile Host) location
> service.

You are confused.  SIP is not specific to voice.  In fact, SIP happens
to also be the leading IM protocol, too.

> Eventually it may interwork with ENUM which will provide
> interoperability between Internet and PSTN.  And it is currently
> under investigate.

A worthy goal.

-derek

>  Next Entertainment, LYCOS
> ===========================================================================
>  Áñ°ÌÁö ¾ÊÀ¸¸é ÀÎÅÍ³ÝÀÌ ¾Æ´Õ´Ï´Ù!!   http://www.lycos.co.kr
>  2002³â ÀÓ¿À³â! ¿ÃÇØ ³ªÀÇ ¿î¼¼´Â? - ¶óÀÌÄÚ½º ¿î¼¼(http://lucky.lycos.co.kr)
>  ¸»¶ìÇØ¿¡ ÀüÇÏ´Â ½Å³âÃàÇÏ ¸Þ½ÃÁö - ¶óÀÌÄÚ½º eÄ«µå(http://ecard.lycos.co.kr)

---

From: "송준혁" <[email-masked]>
Date: Fri, 11 Jan 2002 10:44:52 +0900 (KST)

Please read below comment.
-----------------------------------------------------
From:	Derek Atkins <[email-masked]> 
Sent: 10 Jan 2002 20:04:37 -0500 
To:	"XXXXXX" <[email-masked]> 
Cc: [email-masked], [email-masked]	
Subject: Re: I-D ACTION:draft-song-dnsext-nai-support-00.txt

(Above are not specific for Mobile IP, it is beneficial for PPP dial up service too.)

(Okay, I wasn't aware of that. In fact I found the some similiarty with ENUM)

(That is not likely happen in real world. Access Router (What we called Packet Data Serving Node) is sometimes covering the size of California.)

(I may be, as fas as I know there is SIMPLE is only thing working on that.)

A worthy goal.

Thanks 
JunHyuk

-derek

>  즐겁지 않으면 인터넷이 아닙니다!!   http://www.lycos.co.kr
>  2002년 임오년! 올해 나의 운세는? - 라이코스 운세(http://lucky.lycos.co.kr)
>  말띠해에 전하는 신년축하 메시지 - 라이코스 e카드(http://ecard.lycos.co.kr)

 Next Entertainment, LYCOS
===========================================================================
 즐겁지 않으면 인터넷이 아닙니다!!   http://www.lycos.co.kr
 2002년 임오년! 올해 나의 운세는? - 라이코스 운세(http://lucky.lycos.co.kr)
 말띠해에 전하는 신년축하 메시지 - 라이코스 e카드(http://ecard.lycos.co.kr)

---

From: Derek Atkins <[email-masked]>
Date: 10 Jan 2002 21:14:40 -0500

Hi,

Before I response, JunHyuk, I should let you know that your mailer
is broken.  Your local MUA/MTA is not assigning a unique Message-ID
to your outgoing messages.  The end result is that when you send a
message both to the list and to me directly, it doesn't get filtered
(because technically they are different messages).  Could you take
a look at your system and try to correct this?  Thanks.

Now, to respond...

> (Above are not specific for Mobile IP, it is beneficial for PPP dial

Fair enough... But the IMPP-type solution as stated below will
still solve the problem for PPP as well as Mobile-IP, and any other
mobility solution.  It would even work when we go to the IETF and
use DHCP to get random addresses ;)

> (Okay, I wasn't aware of that. In fact I found the some similiarty with ENUM)

With all this similarity, why re-invent the wheel?

> (That is not likely happen in real world. Access Router (What we
> called Packet Data Serving Node) is sometimes covering the size of
> California.)

You don't know that this will always be the case.  There are certainly
some people who believe that each and every cell site might be its own
ipv6 subnetwork, with layer-3 MIPv6 handoffs between each cell site.

I think it's reasonable to assume rapid (and frequent) handoffs.  If
they don't happen, then maybe you've over-designed your system a bit.
However, if you don't design your system for frequent, rapid handoffs
and then you find that deployment is going to result in such a system,
you now have an unusable solution.

"'tis better to over-engineer now than re-engineer later."

> (I may be, as fas as I know there is SIMPLE is only thing working on that.)

Well, yes... by definition! (SIMPLE is the group that is standardizing
SIP for IMPP).  My point was that SIP is usuable beyond VoIP.
Besides, SIP was just an example.

My point is that I think there are other (existing) solutions that
solve the NAI "problem" in a way that is both more scalable, more
secure, and more generic.  Don't reinvent the wheel. :)

-derek