Subject: Bohemian NAPTR

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 17 Sep 2002 14:08:11 -0700

OK, Andora is not in Bohemia, but its close.

Let us look at this issue by case analysis, I cannot see where the ambiguity
arises with or without OPTIN.

In the first place let us look at the enum domain, one of the curious facts
about an enum domain is that it can have a maximum of 10 sub domains - 12 if
you want to include # and *. 

So one is most unlikely to be using OPTIN in those domains in the first
place. So the best argument that can be made from the example is that
wildcards be allowed for non opt-in domains.

So now let us look at the wildcard, what does it really mean here?

The * could match:

	0.		Immediate subdomain, 
	0.0.		nested subdomain

The first case is clearly not a compelling reason to require wildcard
support since the subdomains are easily enumerated.

The second case is the one that causes large numbers to be introduced.

I think the problem stems from a basic confusion over what the wildcard
indicates and the application area. In an enum application it is very likely
that there would be a lot of ldap directories up and down the tree:

+44 [national] 0121 [local] 29292932 [Line]

In the example above we have three separate ldap directories that might be
queried. I do not believe that a wildcard would be appropriate in any of
those cases.

A wildcard would indicate that the ldap repository was authoritative for all
information concerning all sub trees while in any practical design the
national, local and line directories are going to be very different with
very different purposes.

The fact that BT runs a national LDAP directory should not pre-empt my
ability to run a local directory for my personal line.

In other words, Paul and the enum group are right. You certainly do not want
to use wildcards in the enum context. 

		Phill

> -----Original Message-----
> From: Randy Bush [mailto:[email-masked]]
> Sent: Tuesday, September 17, 2002 3:12 PM
> To: Roy Arends
> Cc: Paul Vixie; [email-masked]
> Subject: Re: DNSSEXT Yokohama Minutes 
> 
> 
> > The enum WG is well aware that the use of wildcard NAPTR 
> RRs are A Bad
> > Thing. They seriously advice against it, and advice to 
> simply enumerate
> > every number that is in the repository of the zone.
> 
> that's really gonna work great for anything larger then andora
> 
> randy
> 
> 
> --
> to unsubscribe send a message to 
> [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Robert Elz <[email-masked]>
Date: Wed, 18 Sep 2002 18:25:54 +0700

Date:        Tue, 17 Sep 2002 14:08:11 -0700
    From:        "Hallam-Baker, Phillip" <[email-masked]>
    Message-ID:  <[email-masked]>

  | A wildcard would indicate that the ldap repository was authoritative for all
  | information concerning all sub trees

It is kind of mind blowing to believe that anyone on this list
actually believes that wildcards work like that.

kre