Subject: NSEC++ (Example code broken)

From: "Olaf M. Kolkman" <[email-masked]>
Date: Tue, 9 Dec 2003 16:13:58 +0100

WRT: draft-ietf-ndsext-nsec-rdata-01.

While testing some code; I think the example in section 3 should read:

0x04 'h'  'o'  's'  't'
0x07 'e'  'x'  'a'  'm'  'p'  'l'  'e'
0x03 'c'  'o'  'm'  0x00
0x00 0x07 0x40 0x01 0x00 0x00 0x00 0x03
0x00 0x04 0x1b 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x00 0x20 

Can somebody confirm that?

-- Olaf
   namedropper.

---------------------------------| Olaf M. Kolkman
---------------------------------| RIPE NCC

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Scott Rose" <[email-masked]>
Date: Tue, 9 Dec 2003 13:27:01 -0500

I thought it looked okay.  I noticed the trailing 0x00 octet after the 0x03
in the example below.  Isn't that a trailing null octet in the first window?
Is that necessary?

Scott

---

From: Olaf Kolkman <[email-masked]>
Date: Tue, 09 Dec 2003 21:40:57 +0100

"Scott Rose" <[email-masked]> writes:
 * I thought it looked okay.  I noticed the trailing 0x00 octet after the 0x03
 * in the example below.  Isn't that a trailing null octet in the first window?
 * Is that necessary?
 * 

No it is not... I do not understand why I did not catch that in the first place. Hex-diziness I am affraid.

--Olaf