Subject: Re: trying to close Editor's Question Q-29

From: [email-masked] (Ted Lindgreen)
Date: Wed, 11 Feb 2004 14:43:13 +0100

[Quoting [email-masked], on Feb 11, 12:54, in "Re: trying to close  ..."]
...
> Ted, Miek, Sam, anyone
> 
> Could you please state what those 'valid reasons' or 'particular
> circumstances' are that can not be satisfied outside the DNSSEC
> protocol to justify a change to SHOULD ?

I can think of several circumstances one still wants to see the
returned info when the signatures fail, but the most clear one
is probably: when debugging a lookup problem.

This seems to me a typical example of what is meant by the wording
in RFC 2119 for "SHOULD".

In contrast, the wording of "MUST" in RFC 2119 makes debugging
impossible, and that is not what we want, I think.

-- ted

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Scott Rose" <[email-masked]>
Date: Wed, 11 Feb 2004 09:03:46 -0500

If one is debugging DNSSEC, it would make more sense to turn on the CD bit
for queries and not rely on whatever policy is in place at a recursive
resolver.  One wouldn't know if the recursive resolver is accepting out of
date RRSIGs or not.  Use of "SHOULD" might lead to unexpected behavior.

Use of the CD bit overrides any local policy for "pass through" recursive
resolvers for that query.

Scott
----- Original Message ----- 
From: "Ted Lindgreen" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 11, 2004 8:43 AM
Subject: Re: trying to close Editor's Question Q-29

> ....

---

From: [email-masked]
Date: Wed, 11 Feb 2004 15:11:28 +0100 (CET)

> is probably: when debugging a lookup problem.

Debug with CD=1

Roy