Subject: RE: LLMNR and Rendezvous TTL disagreement, a modest proposal

From: "Christian Huitema" <[email-masked]>
Date: Thu, 26 Feb 2004 13:59:38 -0800

> On Thu, Feb 26, 2004 at 12:56:46AM -0800, Bernard Aboba wrote:
> > If there is to be a "compromise" I believe that it should be
> > to set TTL=255 on responses and (optionally) check on the sender,
while
> > *always* setting TTL=1 on queries.
> 
> Sounds reasonable to me.

I would qualify that by setting the TTL=255 only when the response is
sent to a link local address, either IPv6 link local or IPv4 169.254/16.

-- Christian Huitema

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 27 Feb 2004 08:04:59 +0900

Christian;

> sent to a link local address, either IPv6 link local or IPv4 169.254/16.

To stop packets flooding out, it should also be required
that a site administrator is sure that all the local routers
recognize link local addresses, which involves site dependent
configuration.

However, when all the local routers regognize link local
addresses, there are no reason (even invalid reasons as there
are no valid reasons from the beginning) to set TTL 255.

With TTL of 1, the configuration becomes unnecessary.

						Masataka Ohta