Subject: RE: DNS SRV Clarification sought

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 8 Mar 2004 13:17:05 -0800

Registies are over-rated.

Look at the number of programs there are on windows that have their own file
format. Important name collisions are pretty rare considering that it is
essentially a 3 character identifier.

All that matters here is that the identifier be unique and plentiful enough
that they do not run out.

If you try to impose any requirement that is more stringent than first come
first served we end up back with the X-Header problem.

We could adopt the hash-cash scheme that Microsoft is pushing for anti-spam
as a way of rationing code points in tables.

All code points are first come first served. To get the code point 'SPAM' in
table 'SRV' you have to provide a string s such that

	 SHA1(s) - SHA1('SPAM+SRV')  <> 0  AND
	 |SHA1(s) - SHA1('SPAM+SRV')| < 2^(160-n)

I.e. the strings must not be the same and the first n bits must match.

The value of n would increase as the code points in the registry were
exhausted.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Eric A. Hall
> Sent: Monday, March 08, 2004 11:09 AM
> To: Paul Vixie
> Cc: [email-masked]
> Subject: Re: DNS SRV Clarification sought
> 
> 
> 
> On 3/6/2004 12:48 PM, Paul Vixie wrote:
> 
> > iana should create a registry of service identifiers, by 
> importing the
> > BSD file "/etc/services" and then periodically amending it for new
> > standards
> 
> Is that really feasible? Service definitions may require 
> weighting values
> and client-selection algorithms to be useful, all of which 
> requires some
> level of agreement among implementors.
> 
> If we start with a list of defaults and then update the list 
> on-the-fly,
> how does the client know which version of the list entry is in use for
> those SRV RRs that they encounter?
> 
> The nice thing about the current model is that an entry in the list
> connotes agreement among implementors, or at least carries a footnote.
> 
> -- 
> Eric A. Hall                                        
> http://www.ehsco.com/
> Internet Core Protocols          
> http://www.oreilly.com/catalog/coreprot/
> 
> --
> to unsubscribe send a message to 
> [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 15 Mar 2004 12:42:37 -0800

however, a purely SRV-discovered service might not 
> _have_ a default
> port number, in which case 
> ftp://ftp.iana.org/assignments/service-names would
> be the better choice for an SRV's owner name.  

It seems to me that a good long term objective here would
be to stop issuing port numbers completely.

The logical extension of SRV is that you look up
the service in DNS and get back a report of the name
of the server that supports the service, the port address
to use plus any parameters that describe the use of the
port (I support SSL security with profile X).

This is where the Internet will be in a few years time.

		Phill