Subject: RE: I-D ACTION:draft-iab-dns-choices-00.txt

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 18 Oct 2004 16:53:06 -0700

Mark writes

> > WRITING IN CAPITALS DOES NOT CONSTITUTE AN ARGUMENT.
> 
> 	Well the firsting you have to get agreement on is how many
> 	labels does * match in
> 	
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net 
> A 127.0.0.1
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 
> 127.0.0.2
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.3
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.4
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.5
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.6
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.7
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.8
> 	a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.10
> 	a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.11
> 	a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.12
> 	a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.13
> 	a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.14
> 	a.a.a.a.a.a.a.a.*.example.net A 127.0.0.15
> 	a.a.a.a.a.a.a.*.example.net A 127.0.0.16
> 	a.a.a.a.a.a.*.example.net A 127.0.0.17
> 	a.a.a.a.a.*.example.net A 127.0.0.19
> 	a.a.a.a.*.example.net A 127.0.0.20
> 	a.a.a.*.example.net A 127.0.0.21
> 	a.a.*.example.net A 127.0.0.22
> 	a.*.example.net A 127.0.0.24
> 	*.example.net A 127.0.0.25
> 
> 	with a query of
> 
> 	
> a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.
> a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.
> a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.
> example.net
> 
> 	is it *.example.net A 127.0.0.25
> 	or 
> a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.1
> 	or a random one from above or all of them ....
> 
> 	Allowing * to expand in the middle creates large search spaces.

Not at all, since we are talking about macros not wildcards
there is no reason why this has to be standardized and there is 
no reason why servers need to provide unbounded matches.

Even on the entirely artificial example you give there is a simple rule that
can be applied, take the most specific match, starting with the RHS, then
take the LHS. So that gives you 127.0.0.1. 

The matching rule is no worse for the LHS than the RHS. Its a straight FSM
with a very tightly bounded complexity.

You only start creating problems if you allow multi-level macro wildcards
which nobody has asked for. And even that is not really a major problem,
even 1970s technology like UNIX could handle matches on a*b*c. Its undergrad
intro to parser theory 101. All the algorithms are nice and regular.

Please take a look at your examples and spend some time thinking about them
in future before telling us in all caps that there is a problem.

		Phill

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 18 Oct 2004 20:26:58 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Hallam-Baker," == Hallam-Baker, Phillip <[email-masked]> writes:

    Hallam-Baker> Not at all, since we are talking about macros not
    Hallam-Baker> wildcards there is no reason why this has to be
    Hallam-Baker> standardized and there is no reason why servers need
    Hallam-Baker> to provide unbounded matches.

  So, you don't mind if your secondary servers answer differently than
your primaries?

  Or do we have to run the same software everywhere?
  I like diversity.

- --
]     "Elmo went to the wrong fundraiser" - The Simpson         |  firewalls  [
]   Michael Richardson,    Xelerance Corporation, Ottawa, ON    |net architect[
] [email-masked]      http://www.sandelman.ottawa.on.ca/mcr/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [