Subject: RE: I-D ACTION:draft-iab-dns-choices-00.txt

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 18 Oct 2004 15:05:01 -0700

> 	What happens when you have a thousand such records for
> 	different protocols.  You then have to find each and every
> 	potential LHS and try to match those against the query.
> 
> 	THIS DOES NOT SCALE.

Of course it does, same way it works for any other DNS zone
with a thousand entries.

WRITING IN CAPITALS DOES NOT CONSTITUTE AN ARGUMENT.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Tue, 19 Oct 2004 09:25:43 +1000

> WRITING IN CAPITALS DOES NOT CONSTITUTE AN ARGUMENT.

	Well the firsting you have to get agreement on is how many
	labels does * match in
	
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.1
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.2
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.3
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.4
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.5
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.6
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.7
	a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.8
	a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.10
	a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.11
	a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.12
	a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.13
	a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.14
	a.a.a.a.a.a.a.a.*.example.net A 127.0.0.15
	a.a.a.a.a.a.a.*.example.net A 127.0.0.16
	a.a.a.a.a.a.*.example.net A 127.0.0.17
	a.a.a.a.a.*.example.net A 127.0.0.19
	a.a.a.a.*.example.net A 127.0.0.20
	a.a.a.*.example.net A 127.0.0.21
	a.a.*.example.net A 127.0.0.22
	a.*.example.net A 127.0.0.24
	*.example.net A 127.0.0.25

	with a query of

	a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.example.net

	is it *.example.net A 127.0.0.25
	or a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.a.*.example.net A 127.0.0.1
	or a random one from above or all of them ....

	Allowing * to expand in the middle creates large search spaces.

--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]