Subject: TCP response with truncated bit set?

From: Stuart Cheshire <[email-masked]>
Date: Wed, 1 Dec 2004 11:20:27 -0800

If you do a DNS query over UDP and get a response with the TC bit set, 
the client retries using TCP.

If the response received over TCP also has the TC bit set, what does that 
mean?

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Thu, 02 Dec 2004 08:33:54 +1100

> If the response received over TCP also has the TC bit set, what does that 

	It means that the answer would not fit into the buffer used to
	assemble the TCP response.  Note not all implementations use /
	have used 64k buffers.
 
	Mark
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]