Subject: Re: Last Call: 'Domain Name System (DNS) Case Insensitivity Clarification' to Proposed Standard

From: Bob Braden <[email-masked]>
Date: Wed, 2 Feb 2005 14:52:41 -0800 (PST)

[ Moderators note: Post was moderated, either because it was posted by 
   a non-subscriber, or because it was over 20K.  
   With the massive amount of spam, it is easy to miss and therefore 
   delete relevant posts by non-subscribers. Please fix your 
   subscription addresses. ]

  *> 
  *> 
  *> --On Wednesday, 02 February, 2005 14:19 -0500 Bruce Lilly
  *> <[email-masked]> wrote:
  *> 
  *> >...
  *> > Q: Why is the reference to "ASCII" given as the 1968 version
  *> > rather    than ANSI INCITS 4-1986 (R2002)?  [N.B. no typos,
  *> > the dates really    are 1968 and 1986]
  *> >...
  *> 
  *> Because some incompatible changes were made in the ASCII
  *> definition in the early 70s that would have fouled up the
  *> "network virtual terminal" character set.  You will find that
  *> X3.4-1968 is referenced in most Internet applications protocols
  *> that require an ASCII reference, include those for telnet, ftp,
  *> and the email base protocols as well as the DNS ones.
  *> 
  *>    john
  *> 

Presumably, this is the character set defined in RFC 20 ...?

Bob

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Bruce Lilly <[email-masked]>
Date: Wed, 2 Feb 2005 19:27:29 -0500

>  Date: 2005-02-02 15:15
>  From: John C Klensin <[email-masked]>

> Because some incompatible changes were made in the ASCII
> definition in the early 70s that would have fouled up the
> "network virtual terminal" character set.

OK, but I doubt that that would affect the case-insensitivity
issue that is the subject of the draft.  In any event, on
reviewing the one citation in the text to that reference, I
see that it's a chronological reference rather than substantive.
The first DNS RFCs were RFCs 881-883, ca. 1983, so it's a bit
misleading to point to a document which was at that time a
decade and a half old, and by which time changes made in the
early 70's were a decade old.  Not a big issue in any event.