Subject: RE: Randomness requirements for message ID generation

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Mon, 25 Jul 2005 15:00:16 -0400

I can't see the justification for a MUST. A SHOULD would be reasonable as it would mean that you need a good justification to do anything else.

If you want secure DNS transactions you have to use TSIG or SIG(0). 

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Conrad
Sent: Monday, July 25, 2005 1:37 PM
To: Edward Lewis
Cc: Ólafur Guðmundsson /DNSEXT co-chair; Florian Weimer; [email-masked]
Subject: Re: Randomness requirements for message ID generation

On Jul 25, 2005, at 10:12 AM, Edward Lewis wrote:
>> Good randomness should be used by all DNS resolvers on query ID.
...
> I know that this is a dead issue in the WG (fortunately), but I had 
> some real data to throw in.  And I wanted to kill once and for all the 
> notion that the message id had to be "random."

Hmm.  Perhaps this has been mentioned:

http://madchat.org/reseau/tcp-ip/tcpip-seqnb/#otherp

In terms of specification, I believe having query ids be as random as possible should be a MUST.  Anything else increases the likelihood of spoofability.

Rgds,
-drc

--
to unsubscribe send a message to [email-masked] with the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: David Conrad <[email-masked]>
Date: Mon, 25 Jul 2005 17:36:08 -0700

In theory, you're right.  In practice, it has been my experience that  
many developers treat "SHOULD" as "DON'T HAVE TO".  However, maybe  
I'm too cynical.

Rgds,
-drc

On Jul 25, 2005, at 12:00 PM, Eastlake III Donald-LDE008 wrote:

> I can't see the justification for a MUST. A SHOULD would be  
> reasonable as it would mean that you need a good justification to  
> do anything else.
>
> From: [email-masked] [mailto:owner- 
> [email-masked]] On Behalf Of David Conrad
> In terms of specification, I believe having query ids be as random  
> as possible should be a MUST.  Anything else increases the  
> likelihood of spoofability.
>
> Rgds,
> -drc
>
>
> --
> to unsubscribe send a message to [email-masked]  
> with the word 'unsubscribe' in a single line as the message text body.

---

From: Pekka Savola <[email-masked]>
Date: Tue, 26 Jul 2005 08:15:28 +0300 (EEST)

On Mon, 25 Jul 2005, David Conrad wrote:
> In theory, you're right.  In practice, it has been my experience that many 
> developers treat "SHOULD" as "DON'T HAVE TO".  However, maybe I'm too 
> cynical.

As a customer, I've observed the same.  If Foo is not implemented and 
it's SHOULD in the spec, the vendor typically says "we don't need to 
do it (or we could, but it's a low priority item for us)".  If it's 
MUST in the spec, I can require that either the vendor implements Foo 
immediately or doesn't claim compliancy with RFC XXXX.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Edward Lewis <[email-masked]>
Date: Tue, 26 Jul 2005 09:35:58 -0400

A while back I wrote a tool to test the health of 
a portion of the DNS tree.  The tool sent out 
many simultaneous queries, the way I was able to 
manage them in memory while they were outstanding 
was to encode a couple of numbers in the message 
ID.  The message ID's as sent appeared to be 
unpredictable although they were not 
random(ized).  I.e., there was no obvious 
"counting" in the numbers.

If we require that the message ID be "random" 
(whatever that means), then my testing tool would 
be - by specification - a non-conforming 
implementation.  Yet it seemed to be 
interoperable with many DNS servers in use at the 
time.  If the goal of the IETF is interoperable 
specifications, is demanding "random" message 
ID's within scope?

I can see that randomized message ID's would 
boost the reliability of caches, but not all DNS 
implementations are caches.  I'm replying to 
Donald's message because I agree with his 
statement(s).  I'd add - use DNSSEC too.

If I were to write the DNS specification today, 
I'd only mention randomizing, or at least making 
unpredictable, the message ID as a recommendation 
in the Security Considerations section.  I don't 
see that a random message ID helps in 
interoperability.

At 15:00 -0400 7/25/05, Eastlake III Donald-LDE008 wrote:
>I can't see the justification for a MUST. A 
>SHOULD would be reasonable as it would mean that 
>you need a good justification to do anything 
>else.
>
>From: [email-masked] 
>[mailto:[email-masked]] On 
>Behalf Of David Conrad
>In terms of specification, I believe having 
>query ids be as random as possible should be a 
>MUST.  Anything else increases the likelihood of 
>spoofability.
>
>Rgds,
>-drc
>
>
>--
>to unsubscribe send a message to 
>[email-masked] with the word 
>'unsubscribe' in a single line as the message 
>text body.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

If you knew what I was thinking, you'd understand what I was saying.