Subject: RE: DNS IANA Considerations, draft-eastlake-dnsext-2929bis-00.txt

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Thu, 7 Jul 2005 00:35:29 -0400

Ed,

I think our discussion is headed off into a philosophical direction in areas where we seem to disagree. But, I don't think resolving all these questions is necessary to come to some consensus on what should be in 2929bis.

See below at ###

-----Original Message-----
From: Edward Lewis [mailto:[email-masked]] 
Sent: Tuesday, July 05, 2005 3:29 PM
To: Eastlake III Donald-LDE008
Cc: [email-masked]; 'Edward Lewis'
Subject: RE: DNS IANA Considerations, draft-eastlake-dnsext-2929bis-00.txt

At 12:46 -0400 7/4/05, Eastlake III Donald-LDE008 wrote @@@:

>@@@ I'm not too enamored for technical criteria for "innocuous" RR
>@@@ definitions. I'd generally oppose requiring IANA to make technical
>@@@ judgements.

The point of documenting criteria is to avoid the need for judgements.

### "Judgments" was probably the wrong word. Perhaps I should have said "technical assessments". If there are technical criteria, you have to either (1a) assume these criteria are absolutely unambiguous and (1b) that all applicants are absolutely honest in self assessing whether they meet those criteria, or (2) have an authority that makes technical assessments. I content that there are problems with 1. 2 isn't terrible but the current ideal for IANA is, as far as I can tell, that IANA should be able to act as a clerk. The main exception seems to be the Specification Required IANA consideration which required the technical judgment as to whether a specification is adequate for interoperability, a judgment that I suspect IANA currently refers to a technical expert they select.

### So, I'm inclined to implement technical criteria by having a template to be filled out and posted to namedroppers at least two weeks before the early allocation occurs.

>Relying on a personality (as opposed to a person) to do a job does
>not scale - not in volume nor in time.
>
>@@@ Sure it does. Everything has either one person in change, like the
>@@@ Administrator of the (US) Federal Aviation Agendy, or a committee, like
>@@@ the (US) Federal Communications Commission. If they have too much to do,
>@@@ they rrecruit helpers or delegate to staff.

The difference is between a "personality" and a "person in charge." 
To me, "personality" generally means that the person involved is 
inventive, a "person in charge" is a person making sure steps are 
checked off - whether that's a literal bureaucratic checklist or a 
sketchy details list.

### I see no binary difference, only differences in degree. The most literal bureaucratic checklist is subject to interpretation. (cf: it depends what the meaning of "is" is)

For scaling, you want a "person in charge" (or "person responsible") 
and not a "personality."

### No matter how precise the rules, when things get big, you have to delegate authority and provide for appeals, etc. If you choose to do this in an adversarial situation, the persons to who you delegate judgment are typically called Administrative Law Judges. If you do it directly, they are usually called bureaucrats.

(There's an expression "cult of personality" but there's no "cult of 
'person in charge.'")

>@@@ I'm not entirely sure what you are saying here. If people can get an RFC
>@@@ into the RFC Editor's queue, they should be able to get a permanent type
>@@@ code in the Specification Required section.

That's putting the cart in front of the horse though.

### Right, it seems clear that people want an easier way to get at least a temporary Early Allocation than Specification Required.

>@@@ "denial of registry service" on what basis?

Flooding the registry with requests to deplete the parameter space.

### Well, that's one thing you could do but there are others. Generally bureaucracies need a mean to defend themselves from abuse of process. Another example of a requirement for judgment. Perhaps you would deny the bureaucrat such direct authority but they at least need to decide when it is a reasonable to appeal to higher authority to determine is some action is an abuse of process. A case that comes to mind is where people inundated land registries in the western US with federal mineral rights claims (like tens of thousands of them). Despite clear regulations requiring the registries to process these, they ignored them, when to court, and generally got court orders backing them up and ordering the filers to cease.

### Trying to specify too much detail sometimes just ties you in knots.

### Donald

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

If you knew what I was thinking, you'd understand what I was saying.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Edward Lewis <[email-masked]>
Date: Thu, 7 Jul 2005 09:41:54 -0400

At 0:35 -0400 7/7/05, Eastlake III Donald-LDE008 wrote:

>I think our discussion is headed off into a philosophical direction in areas
>where we seem to disagree. But, I don't think resolving all these questions
>is necessary to come to some consensus on what should be in 2929bis.

The questions for the document are:

Can we allow coders to burn a number into code early in the 
development cycle and then lock that same number into the registry 
after review?

What is the review?  Who does it, what is looked at, how is it make 
public (so no other coders pick the same number)?

---

From: "william(at)elan.net" <[email-masked]>
Date: Thu, 7 Jul 2005 07:17:40 -0700 (PDT)

On Thu, 7 Jul 2005, Edward Lewis wrote:

> Can we allow coders to burn a number into code early in the development cycle 
> and then lock that same number into the registry after review?

Not for internal testing within one organization. But if they want their
code used in experimental way by multiple parties on the internet than
they should be allowed to do it.

And note that experimental should not mean published experimental RFC
but I think we should at least expect internet draft or some other 
similar type document publicly available.

> What is the review?  Who does it, what is looked at, how is it make public 
> (so no other coders pick the same number)?

One way is to require them to register the number in provisional way
(with very quick - within 30 days registration by IANA for very limited
period), but provisional registration would be very brief, something
like 6-12 months and continuing provisional registration longer then
that could require technical review (which IANA can designate and
would expect to be either namedroppers or if this WG is closed then
some other appropriate WG or maybe directorate within IETF).

BTW - These are all just some idea to though in for discussion...

-- 
William Leibzon
Elan Networks
[email-masked]