Subject: RE: About draft-ietf-dnsext-ecc-key-07.txt, absence of algorithm restriction in ECC public key encoding

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Wed, 19 Oct 2005 20:28:26 -0400

Actually, if you look in section 5 on page 11, it says you have to use SHA-1...

Donald 

-----Original Message-----
From: Thierry Moreau [mailto:[email-masked]] 
Sent: Monday, August 15, 2005 9:15 AM
To: [email-masked]
Cc: [email-masked]; Eastlake III Donald-LDE008
Subject: About draft-ietf-dnsext-ecc-key-07.txt, absence of algorithm restriction in ECC public key encoding

Dear all:

A quick question/comment about the draft draft-ietf-dnsext-ecc-key-07.txt, "Elliptic Curve KEYs in the DNS". In this draft document, I didn't see any indication of public key algorithm to be used with a given public key (e.g. the same RSA public key value can be used with SHA-1 or MD5 for signatures, and a different DNSKEY RR encoding prevents an RSA-SHA-1 key to be diverted to RSA-MD5). This is somehow different from key usage, i.e. whether DNS zone signing allowed.

For instance of algorithm restriction with ECC public keys, see the draft-ietf-pkix-ecc-pkalgs-01.txt

Am I correct in reading the draft draft-ietf-dnsext-ecc-key-07.txt as omitting algorithm restrictions? If yes, I see a difficulty with algorithm change threat once the ECC crypto is applied to DNS. Thus, I would expect the ECC public key format to be reworked before applied to DNS.

Regards,

-- 

- Thierry Moreau

CONNOTECH Experts-conseils inc.
9130 Place de Montgolfier
Montreal, Qc
Canada   H2M 2A1

Tel.: (514)385-5691
Fax:  (514)385-5900

web site: http://www.connotech.com
e-mail: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Thierry Moreau <[email-masked]>
Date: Fri, 21 Oct 2005 10:29:58 -0400

> Actually, if you look in section 5 on page 11, it says you have to use SHA-1...

Thanks for pointing this out. Since the transition from SHA-1 to other 
hash algorithm is going to be a big issue some time in the future, 
perhaps it should be made more manifest that this draft assigns the 
RFC4034-allocated DNSSEC Algorithm Type value 4 to ECC **with SHA-1**.

Are there other variations in ECC signature algorithms that are fixed by 
the draft and should be made more manifest? Someone pointed out that the 
draft was only "about storing keys". Does it completely specify ECC 
signatures? I think other DNSSEC Algorithm Type values do fully specify 
the respective signature algorithms.

Regards,

-- 

- Thierry Moreau

Tel.: (514)385-5691
Fax:  (514)385-5900