Subject: RE: OASIS and new RR types

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 10 Aug 2006 20:53:51 -0700

Rather than rubbing peoples nose in anything I would rather put 100% of my effort in that regard behind persuading the Redmond club that it would be a good idea to support DNSSEC in their next server release.

Given that the time between server releases is about six years and the feature list on the last one closed some time in 2001 it is hardly suprising that features such as support for unknown RRs that have not had a measurable degree of evangelism effort behind them have not been more widely adopted.

If the world does not listen to you, you can either conclude that they are fools or that you have not spoken well enough.

From: Mark Andrews

> > [ Moderators note: Post was moderated, either because it 
> was posted by
> >    a non-subscriber, or because it was over 20K.  
> >    With the massive amount of spam, it is easy to miss and 
> therefore 
> >    delete relevant posts by non-subscribers. 
> >    Please fix your subscription addresses. ]
> > 
> > I find this whole thing with getting RRs allocated a bit confusing.
> > 
> > Would creating a form on IANA's website make this less of 
> an issue?   
> > Or would that make things worse?
> 
> 	I don't think it will change a thing.  Too many keep spreading
> 	FUD and being Microsoft apologists.
> 
> 	If Microsoft's DNS API can't handle new types then Microsoft
> 	needs to fix the API.  The 20 year old libresolv API can
> 	handle arbitary types.  There was no excuse for Microsoft
> 	writing a API that can't handle unknown types.
> 
> 	If a firewall can't handle a unknown type then the firewall
> 	is broken.  You get the firewall fixed or you replace the
> 	firewall with one from a vendor that knows how to handle
> 	DNS.
> 
> 	It's not the ease of getting a type anymore.  It is easy
> 	to get new types.  A couple of pages like RFC 4431 is all
> 	that is required.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Fri, 11 Aug 2006 14:13:24 +1000

> Rather than rubbing peoples nose in anything I would rather put 100% of my ef
> fort in that regard behind persuading the Redmond club that it would be a goo
> d idea to support DNSSEC in their next server release.
> 
> Given that the time between server releases is about six years and the featur
> e list on the last one closed some time in 2001 it is hardly suprising that f
> eatures such as support for unknown RRs that have not had a measurable degree
>  of evangelism effort behind them have not been more widely adopted.

	RFC 1034 and RFC 1035 basically say you should expect unknown
	RR types.  It shouldn't have required evangelism in 2001.
	Any decent engineer would have seen that unknown was basically
	opaque data.  This was made abandently clear in RFC 2535 (1999)
	as we had to work out how to sign future records.  The use of
	compression pointers (the one sticking point in 1034/1035) in
	rdata had ceased years earlier.

	Sorry. There is was excuse.
 
> If the world does not listen to you, you can either conclude that they are fo
> ols or that you have not spoken well enough.
> 
> 
> From: Mark Andrews
> 
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]