Subject: RE: Removing the SERVFAIL response on hash collisions.

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 17 Aug 2006 09:15:53 -0700

Almost, if SHA-n is broken the whole edifice of *DNSSEC* is broken.

No Paul you are not entitled to selectively posit a weakness in a cryptographic algorithm. Either the algorithm is good or it is vulnerable. If the algorithm is vulnerable then the possibility of the vulnerability being exploited MUST be considered equally likely in all parts of the system.

If SHA-n is broken then so are your possible recovery mechanisms. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Alex Bligh
> Sent: Thursday, August 17, 2006 12:00 PM
> To: Paul Vixie; [email-masked]
> Cc: Alex Bligh
> Subject: Re: Removing the SERVFAIL response on hash collisions. 
> 
> 
> 
> --On 17 August 2006 15:38 +0000 Paul Vixie <[email-masked]> wrote:
> 
> > let's stop dividing large numbers by other large numbers 
> and arguing 
> > about probabilities.  the worry here is not that a hash 
> collision will 
> > occur naturally, but rather unnaturally.  let's stop 
> arguing about how 
> > secure SHA-160 is and whether anybody knows how to break it or how 
> > hard it will be to break it.  if there's an ALG-ID in the protocol, 
> > then we're assuming that SHA-160 will become unsuitable 
> some day, and 
> > we're allowing for the possibility that breakage will occur.
> 
> I think the probability point being made is not that we 
> should rely on SHA-n never being broken, but that if this 
> "exploit" in probabilistic terms becomes breakable, then the 
> whole structure of NSEC (and NSEC-3) will necessarily have 
> already come tumbling down some years earlier. Why bother 
> with SERVFAIL when the intrepid malefactor can spoof much 
> more interesting positive replies?
> 
> Alex
> 
> --
> to unsubscribe send a message to 
> [email-masked] with the word 'unsubscribe' 
> in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Alex Bligh <[email-masked]>
Date: Thu, 17 Aug 2006 17:50:24 +0100

> Almost, if SHA-n is broken the whole edifice of *DNSSEC* is broken.

Quite. That is what I meant but inadequately expressed. Thank-you for
clarifying.

Alex