Subject: RE: a suggestion for super-wildcards

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 4 Aug 2006 11:35:19 -0700

> From: william(at)elan.net [mailto:[email-masked]] 

> On Fri, 4 Aug 2006, Hallam-Baker, Phillip wrote:
> 
> > The problem with Doug's approach is that he is proposing a 
> new record 
> > for each and every policy that is declared. This is not 
> scalable and 
> > creates a situation that has never existed before where the 
> > development of each new Internet protocol is dependent on 
> IANA and IETF action.
> 
> <sarcasm>
> 
> It never existed before? Really?
> 
> </sarcasm>

If you think that the IETF is a place to come for permission you do not understand why it exists.

Jon Postel did not consider his function as a gatekeeper, he regarded his IANA role as being an archivist.

Empirically there are other standards bodies that are creating Internet protocols that the IETF neither has a liason with nor shows any interest in having such a liason.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "william(at)elan.net" <[email-masked]>
Date: Fri, 4 Aug 2006 12:02:11 -0700 (PDT)

> understand why it exists.

It exist to provide technical forum with multi-area review for
developers of new internet protocols/services and to provide
central point to consider updates to existing protocols. This
isn't of course all, but is my understand about the core of it.

> his IANA role as being an archivist.

Yes, I was talking about /etc/services, /etc/protocols, which
sure sounds like IANA is needed to get new protocol deployed
to anything but minimum testing stage. And if you come to think
of it if protocol needs special type of DNS records IANA and
IETF are again needed. Similarly if protocol need to use services
of some other protocol, etc.

I'm not saying this is all good, but I have hard time when somebody
says that IANA is not needed to get new protocol deployed (with
possible exception of peer-peer especially if it is implimented as 
broadcast discovery with incoming port number of neighbors being
advertised in that way), but I view it as more of exception at
least in the current internet.

> Empirically there are other standards bodies that are creating Internet 
> protocols that the IETF neither has a liason with nor shows any interest 
> in having such a liason.