Subject: DNAME [4.13]: PTR Records and DNAME

From: Wouter Wijngaards <[email-masked]>
Date: Thu, 12 Oct 2006 12:30:23 +0200

Issue [4.13]:
   PTR records in the reverse zone must have canonical names as their
   RDATA, like NS and MX records.  The lookup process for PTR records
   owner names may involve DNAME/CNAME records, but the lookup process
   for PTR records RDATA names may not.  RFC 1912.  More problematic
   than NS and MX in operational sense, since the reverse zone may not
   be under the control of the zone operator.

Like issue [4.4]. So DNAME'd domains are not allowed on the right hand
side of PTR records.

Best regards,
   Wouter

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Fri, 13 Oct 2006 10:33:02 +1000

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Issue [4.13]:

	PTR records can point to any name regardless of the types at that
	name or even if it exist.  PTR records are described as being
	similar to CNAME records but are not followed RFC103?.  CNAME
	records can (though it is discouraged) point to CNAME records.

	From a operational point of view DNAME does not change any
	requirement to point to a canonical name.  A name under a DNAME
	is not canonical.
 
> Best regards,
>    Wouter
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.5 (GNU/Linux)
> Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org
> 
> iD8DBQFFLhk/kDLqNwOhpPgRAlYQAJ97W5sLDs6aXU1y5SEknCDQqFIIJACgn+VS
> UkZvrqJFBmDsxRjh2c9VRKg=
> =6wMW
> -----END PGP SIGNATURE-----
> 
> --
--
ISC Training!  October 16-20, 2006, in the San Francisco Bay Area,
covering topics from DNS to DHCP.  Email [email-masked].
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]