Subject: ECC future direction for DNSSEC

From: Ólafur Guðmundsson /DNSEXT chair <[email-masked]>
Date: Thu, 03 Jan 2008 20:43:48 -0500

Note: This message is to start discussion for the benefit of the chair and
AD(s) on this topic.

After some discussions with various security and DNS people,
I'm going to recommend DNSEXT take a different approach in
adding ECC to DNSSEC than was proposed in draft-ietf-dnsext-ecc-key-10

Background:
The old ECC approach in the crypto community followed the philosophy
"Let 10,000 flowers bloom" by allowing multiple different curves to 
be standardized.
The ecc-key draft reflects this approach.

The new philosophy is "pick one curve at each strength level", there are number
of reasons why the philosophy has changed including Interoperabilty and
community feeling that ECC is better understood and rational choices can be
made.

Proposed Path Forward:
DNSEXT should
a.      Pick 2 curves and allocate algorithm codes for them in the 
near future[1]

b.      Decide if we want to use ECDSA signature standard or look for
         something faster as our signature method.

c.      Decide if each curve+digest selected gets its own DNSKEY 
algorithm codes
         (one for each of NSEC + NSEC3)
         or all ECC curves share algorithm codes.

d.      Alternatively: Decide it does not want to do ECC and state why.

Comments?

         Olafur

[1] the suggested curves are p265 and p384

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Fri, 04 Jan 2008 13:17:26 +1100

>          (one for each of NSEC + NSEC3)

	You don't need to distingish between NSEC and NSEC3 so long
	as the assignment of the code point specifies that it covers
	both NSEC and NSEC3.
 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]