Subject: [dnsext] draft-andrews-dnsext-udp-fragmentation-00.txt

From: Mark Andrews <[email-masked]>
Date: Wed, 14 Dec 2011 16:40:48 +1100

draft-andrews-dnsext-udp-fragmentation-00.txt was
	formally submitted to the system.  Comments requested.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE:	+61 2 9871 4742		         INTERNET: [email-masked]

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 17 Dec 2011 07:02:10 +0900

> 	formally submitted to the system.  Comments requested.

The following part of the draft:

   or restricing DNS/UDP
   packets to no more than 1280 bytes including IPv6 headers.

should be

   or restricting DNS/UDP
   packets to no more than 1280 bytes including IPv6 and
   IPv6 extension headers.

because, in RFC2460, "IPv6 header" means 40B IP header only.

It should also be noted that IPv6 extension headers, some
of which, such as fragmentation headers and mobility ones,
MUST be inserted without application's discretion, can be
(in theory) very long that there is no minimum message size
guaranteed to be carried within a 1280B packet.

					Masataka Ohta

---

From: Lawrence Conroy <[email-masked]>
Date: Fri, 16 Dec 2011 23:31:20 +0000

Hi Ohta-san, folks,
I note the esteemed ICANN chair's contribution on this topic; RFC 1776.

Seriously, someone needs to ship a single doc on fragmentation and its
impact on DNS. Frankly, not for people on this list, but for everyone else.

all the best,
 Lawrence