Subject: [dnsext] Presentation and question

From: Noel David Torres Taño <[email-masked]>
Date: Sun, 17 Mar 2013 12:58:46 +0000

Hi all

I'm Noel Torres, sysadmin from Spain.

I have readed in the charter that this WG will be shut down soon. Did I do bad 
by subscribing?

Regards
-------------------------
A: Because it breaks the logical flow of discussion.
Q: Why is top posting bad?

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 17 Mar 2013 16:17:12 -0400

> I have readed in the charter that this WG will be shut down soon. Did I do bad 

No.  There is no intention to shut the list down.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Noel David Torres Taño <[email-masked]>
Date: Sun, 17 Mar 2013 22:49:06 +0000

On Domingo, 17 de marzo de 2013 20:17:12 Andrew Sullivan wrote:
> > I have readed in the charter that this WG will be shut down soon. Did I
> > do bad by subscribing?
> 

Thanks

I want to learn how to create a DNS extension, but I think it is more polite 
to just read and learn first.

Regards

Noel
er Envite

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 17 Mar 2013 20:21:50 -0400

> to just read and learn first.

What sort of extension do you want to create? 

A

-- 
Andrew Sullivan
[email-masked]

---

From: Noel David Torres Taño <[email-masked]>
Date: Mon, 18 Mar 2013 00:41:35 +0000

On Lunes, 18 de marzo de 2013 00:21:50 Andrew Sullivan wrote:
> > I want to learn how to create a DNS extension, but I think it is more
> > polite to just read and learn first.
> 

Thanks for asking. I really did not expect to explain so soon after joining.

I think (of course I may be wrong) that OIDs behave like the DNS tree, where 
there is a single root, branches may be delegated, and each node and leaf has 
a name. Thus a new CLASS may be created for OID management, with root servers 
serving only 0 (ITU-T), 1 (ISO) and 2 (joint-iso-itu-t), and with NS glue 
records like IN class has. This way, for example, 1 can be delegated to ISO, 
1.3.6 can be delegated by ISO to USA DOD, 1.3.6.1 by DOD to IANA, and IANA can 
delegate 1.3.6.1.4.1.* to each "private enterprise" that has applied or 
applies in the future.

There may be SOA records like those of IN class, and NS records alike, but 
instead of A records there may be NAME records complemented by some kind of 
TXT records.

Hope this is not a total madness

Regards

Noel Torres
er Envite

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 17 Mar 2013 21:42:55 -0400

On Mon, Mar 18, 2013 at 12:41:35AM +0000, Noel David Torres Taño wrote:
> a name. Thus a new CLASS may be created for OID management

Historically, efforts to create a new CLASS have failed.  But for this
case, since the whole point is a completely new use case, maybe it'd
work.

You might want to look at what the ONS (in the RFID area:
http://www.gs1.org/gsmp/kc/epcglobal/ons) did.

I'd be a little worried about the space you're working in.  Remember
that a DNS name can't be longer than 255 octets.

Anyway, this doesn't really sound like an extension of the DNS, just a
novel application of the existing protocol to a new use case.  DNSEXT
worked on changes to the wire protocol, and apart from the CLASS
there's no real change here.

Good luck with the project.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 17 Mar 2013 22:21:57 -0400

> case, since the whole point is a completely new use case, maybe it'd

It is my opinion that the only thing that would justify a CLASS is a
very strong desire/need for different root control/servers.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext

---

From: Scott Rose <[email-masked]>
Date: Mon, 18 Mar 2013 09:20:01 -0400

I remember there was at least one previous attempt at this idea (that I was semi-involved with as a sounding board).  There the decision was to use the IN class and put the OID tree under the .arpa TLD since it would fit the definition of architecture.  This was before the new gTLD process was finalized so there was no serious push to have a .oid TLD.

There the idea was to use the existing root/TLD infrastructure.  Not sure what happened to the group that tried to do this.  

Scott

> Good luck with the project.

===================================
Scott Rose
NIST
[email-masked]
+1 301-975-8439
Google Voice: +1 571-249-3671
http://www.dnsops.gov/
===================================

---

From: [email-masked]
Date: Tue, 19 Mar 2013 03:58:05 +0000

my my.. Steve Hotz and I did this 20 years ago - when the DNS was much less ossified
 than it is today.  we started w/ new class, ended up anchoring in the int. tree (when
 we had emptied out arpa of everything but in-addr.... but that is another story).

 it didn't get much traction then, would be happy to work on it again.

/bill

On Mon, Mar 18, 2013 at 12:41:35AM +0000, Noel David Torres Taqo wrote:
> > On Sun, Mar 17, 2013 at 10:49:06PM +0000, Noel David Torres Taqo wrote: