Subject: [dnsext] EDNS exchanges in draft-wouters-edns-tcp-chain-query-00.txt

From: Olaf Kolkman <[email-masked]>
Date: Thu, 31 Oct 2013 14:03:23 +0100

On 11 sep. 2013, at 03:15, Paul Wouters <[email-masked]> wrote:

> 
> Filename:	 draft-wouters-edns-tcp-chain-query
> Revision:	 00
> Title:		 TCP chain query requests in DNS
> Creation date:	 2013-09-10
> Group:		 Individual Submission

Thanks Paul, 

Hereby a few responses after first review.

In 3.3.2 you specify that you MAY include the ENDS option in responses.

I am not sure if there are clients out there that get all nauseous from OPT RRs in the responses and I am also not sure if this would be the first EDNS exchange where a server sends back an OPT RR in the additional section without first having received an EDNS packet from a client.

If conservatism is warranted  I’d suggest to only send back an OPT RR to clients that have shown EDNS support by sending you a query first.

NIT: if you are going to ignore the timeout anyway on the server then a SHOULD set to 0 for clients is sufficient. Violating that MUST doesn’t lead to interoperability issues if the server ignores the value anyhow.

—Olaf

---

From: Ray Bellis <[email-masked]>
Date: Thu, 31 Oct 2013 13:17:02 +0000

On 31 Oct 2013, at 13:03, Olaf Kolkman <[email-masked]> wrote:

> I am not sure if there are clients out there that get all nauseous from OPT RRs in the responses 

There are bound to be - I've certainly seen CPE that get nauseous (FORMERR) with OPT RRs in the request, and I've no reason to believe they wouldn't do just the same for an unsolicited OPT RR in the response.

Ray

---

From: Mark Andrews <[email-masked]>
Date: Fri, 01 Nov 2013 09:50:11 +1100

In message <[email-masked].
uk>, Ray Bellis writes:
> There are bound to be - I've certainly seen CPE that get nauseous (FORMERR)
> with OPT RRs in the request, and I've no reason to believe they wouldn't do
> just the same for an unsolicited OPT RR in the response.

And such CPE are not RFC 103[45] compliant as the server can put
anything it wants into a additional section of a query response
that it believes will be useful to the client.

e.g.
     NAPTR -> SRV records in the additional section -> A + AAAA in the
additional section.

Having a OPT record in a request is different as the additional
section was expected to be empty in RFC 103[45] query requests.

You can't draw conclusions on how a response will be treated based
on how a query is treated.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Joe Abley <[email-masked]>
Date: Thu, 31 Oct 2013 20:38:44 -0400

> There are bound to be - I've certainly seen CPE that get nauseous (FORMERR) with OPT RRs in the request, and I've no reason to believe they wouldn't do just the same for an unsolicited OPT RR in th…

Geoff and George to the courtesy phone!