Subject: Re: [dnsext] The state of DNS support, was Deprecating SPF

From: Noel Torres <[email-masked]>
Date: Mon, 11 Nov 2013 23:42:53 +0000

On 26/10/13 03:56, John Levine wrote:
[...]
> The real problem is that most provisioning software makes it too
> painful to support new RR types.  A handful of TXT-like RRs that
> people will use insonsistently seems unlikely to fix that.

Why should we try to fix bugs on broken provisioning software? We 
should, instead, encourage users to ask their providers or software 
vendors to Do The Right Thing.

SPF record is The Right Thing. TXT spf-like record is an ugly hack, even 
if it is widely supported.

While we can not go against the river flow, we should try to direct it, 
on the long run, to the proper place.

Regards

Noel Torre
er Envite

---

From: Mark Andrews <[email-masked]>
Date: Tue, 12 Nov 2013 11:12:12 +1100

In message <[email-masked]>, Noel Torres writes:
> _______________________________________________
> dnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsext

It really shouldn't be too hard to design provisioning software to be
easily upgradable.  It's not like we don't have a 20 year history of
new records being added regularly.

To help BIND 9.10 includes a tool which is designed to be be used by
provisioning software for checking entered records.

Mark

% nroff -man bin/tools/named-rrchecker.1 
NAMED-RRCHECKER(1)                   BIND9                  NAMED-RRCHECKER(1)

NAME
       named-rrchecker - A syntax checker for individual DNS resource records

DESCRIPTION
       named-rrchecker read a individual DNS resource record from standard
       input and checks if it is syntactically correct.

       The -h prints out the help menu.

       The -o origin option specifies a origin to be used when interpreting
       the record.

       The -p prints out the resulting record in cannonical form. If there is
       no cannonical form defined then the record will be printed in unknown
       record format.

       The -u prints out the resulting record in unknown record form.

       The -C, -T and -P print out the known class, standard type and private
       type nmeomics respectively.

SEE ALSO
       RFC 1034, RFC 1035, named(8)

COPYRIGHT
       Copyright © 2013 Internet Systems Consortium, Inc. ("ISC")

BIND9                            Aug 25, 2009               NAMED-RRCHECKER(1)
% echo "IN A 10.0.0.1" | bin/tools/named-rrchecker -u
CLASS1	TYPE1	\# 4 0a000001
% echo 'CLASS1 TYPE1 \# 4 0a000001' | bin/tools/named-rrchecker -p
IN	A	10.0.0.1
% bin/tools/named-rrchecker -T | fmt
A NS MD MF CNAME SOA MB MG MR NULL WKS PTR HINFO MINFO MX TXT RP
AFSDB X25 ISDN RT NSAP NSAP-PTR SIG KEY PX GPOS AAAA LOC NXT EID
NIMLOC SRV ATMA NAPTR KX CERT A6 DNAME APL DS SSHFP IPSECKEY RRSIG
NSEC DNSKEY DHCID NSEC3 NSEC3PARAM TLSA HIP SPF UINFO UID GID UNSPEC
NID L32 L64 LP EUI48 EUI64 URI DLV
% 

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: "John Levine" <[email-masked]>
Date: 12 Nov 2013 02:27:57 -0000

>new records being added regularly.

Uh, yeah.

You might want to take a look at draft-levine-dnsextlang-07.