Subject: Re: [dnsext] EDNS exchanges in draft-wouters-edns-tcp-chain-query-00.txt

From: Geoff Huston <[email-masked]>
Date: Sat, 2 Nov 2013 01:47:51 +1100

On 1 Nov 2013, at 11:38 am, Joe Abley <[email-masked]> wrote:

> On Oct 31, 2013, at 9:17, Ray Bellis <[email-masked]> wrote:
> 
>> 
>>> On 31 Oct 2013, at 13:03, Olaf Kolkman <[email-masked]> wrote:
>>> 
>>> I am not sure if there are clients out there that get all nauseous from OPT RRs in the responses
>> 
>> There are bound to be - I've certainly seen CPE that get nauseous (FORMERR) with OPT RRs in the request, and I've no reason to believe they wouldn't do just the same for an unsolicited OPT RR in the response.
> 
> Geoff and George to the courtesy phone!

It's a testable / measureable hypothesis.

Geoff

---

From: Nicholas Weaver <[email-masked]>
Date: Fri, 1 Nov 2013 07:52:24 -0700

> It's a testable / measureable hypothesis.

The question is "Is the CPE bypassable?".  So much of it is insanely broken on the forwarding resolver side it isn't funny, but if you can get around it, things are OK.

Unfortunately, for networks like hotspots etc that's often not possible, as we've seen in Netalyzr.  

ObAdvertisement: We now also have Netalyzr on Android, so we should get some cellphone network and more hotspot-type information.  If you use an Android phone, download it and run it...

--
Nicholas Weaver                  it is a tale, told by an idiot,
[email-masked]                full of sound and fury,
510-666-2903                                 .signifying nothing
PGP: http://www1.icsi.berkeley.edu/~nweaver/data/nweaver_pub.asc

---

From: Geoff Huston <[email-masked]>
Date: Sat, 2 Nov 2013 02:39:48 +1100

Geoff