Subject: [dnsext] [Editorial Errata Reported] RFC4343 (5112)

From: RFC Errata System <[email-masked]>
Date: Tue, 12 Sep 2017 12:45:13 -0700 (PDT)

The following errata report has been submitted for RFC4343,
"Domain Name System (DNS) Case Insensitivity Clarification".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5112

--------------------------------------
Type: Editorial
Reported by: Change "should" to must in section 3.(no subsection) <[email-masked]>

Section: 3

Original Text
-------------
comparisons on name lookup for DNS queries should be case insensitive

Corrected Text
--------------
comparisons on name lookup for DNS queries must be case insensitive

Notes
-----
Some authoritative DNS servers and/or mitigation devices/software silently drop queries that have uppercase letters in them.  Furthermore, the clarification of the case insensitive comparison in the following two sentences after that particular sentence use the term MUST.  I suspect some readers of the RFC are reading the word "should" and aren't reading the rest of the paragraph.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4343 (draft-ietf-dnsext-insensitive-06)
--------------------------------------
Title               : Domain Name System (DNS) Case Insensitivity Clarification
Publication Date    : January 2006
Author(s)           : D. Eastlake 3rd
Category            : PROPOSED STANDARD
Source              : DNS Extensions
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "John Levine" <[email-masked]>
Date: 12 Sep 2017 22:15:00 -0000

I would reject this or at most mark it as hold for update.  The word
"should" in lower case appears in two other places where it's not used
in the 2119 sense, and I think this one is not intended to be the 2119
sense either.  The sentence in question is describing the historical
situation, and the following capital MUSTs tell you what to do.  

Having said that, if we ever revisit this document, it would benefit
from rewording to make it clearer when it is telling you what to do
and when it's just giving background.

R's,
John

In article <[email-masked]> you write:
>Some authoritative DNS servers and/or mitigation devices/software silently drop queries that have
>uppercase letters in them.  Furthermore, the clarification of the case insensitive comparison in the
>following two sentences after that particular sentence use the term MUST.  I suspect some readers of the
>RFC are reading the word "should" and aren't reading the rest of the paragraph.
>
>Instructions:
>-------------
>_______________________________________________
>dnsext mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dnsext
>

---

From: Olafur Gudmundsson <[email-masked]>
Date: Wed, 20 Sep 2017 13:03:48 -0400

John and I agree 
please reject this errata 

Olafur

> On Sep 12, 2017, at 6:15 PM, John Levine <[email-masked]> wrote:
>

---

From: Warren Kumari <[email-masked]>
Date: Wed, 20 Sep 2017 14:31:57 -0400

I marked it as "Hold for update" -- next time someone edits this RFC
it might make sense to make it clearer.

Sorry, I thought the errata tool would have sent the mail update.

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Jay Ashworth <[email-masked]>
Date: Tue, 12 Sep 2017 22:38:22 -0400

Long time listener, first-time caller, but the problem I have with this is that it suggests that queries containing capital letters are dropped. 

I recommend to people with overly complicated and long domain names that, as best practice, they spell them in camel case in advertising. 

www.MyBadDomain.com

Partially, of course, this is to attempt to avoid the Pen Island/Who Represents problem.  But I do it knowing that the DNS system will case fold those queries and they will thus work properly.

If there are devices dropping those...  I gotta say I'm a little unhappy. Is there documentation of that?

Cheers,
-- jra

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: "Peter van Dijk" <[email-masked]>
Date: Tue, 26 Sep 2017 22:20:14 +0200

Hello Jay,

neither the original text or the erratum suggest dropping queries with 
capital letters. The original text already says that queries MUST (2119 
capital) match uppercase letters to lowercase letters. The suggested 
erratum (in my eyes unnecessarily) suggests uppercasing a lowercase 
should to make this even more explicit.

As for devices dropping this, I don’t have any documentation handy but 
mixed case is certainly known to trigger bugs in various pieces of 
software now and then.

Kind regards,
-- 
Peter van Dijk
PowerDNS.COM BV - https://www.powerdns.com/

On 13 Sep 2017, at 4:38, Jay Ashworth wrote:

> Long time listener, first-time caller, but the problem I have with 
> this is that it suggests that queries containing capital letters are 
> dropped.
>
> I recommend to people with overly complicated and long domain names 
> that, as best practice, they spell them in camel case in advertising.
>
> www.MyBadDomain.com
>
> Partially, of course, this is to attempt to avoid the Pen Island/Who 
> Represents problem.  But I do it knowing that the DNS system will case 
> fold those queries and they will thus work properly.
>
>>> uppercase letters in them.  Furthermore, the clarification of the 
>>> case
>> insensitive comparison in the

---

From: "Jay R. Ashworth" <[email-masked]>
Date: Tue, 26 Sep 2017 20:55:59 +0000 (UTC)

> From: "Peter van Dijk" <[email-masked]>

I was, in fact, being aghast at this:

>>> Some authoritative DNS servers and/or mitigation devices/software
>>> silently drop queries that have uppercase letters in them.

If there are authoritative zone servers that drop incoming queries with capital
letters in them, I wish someone would let me know where so that I can go set 
them on fire.  That's *terribly* antisocial, aside from violating the RFCs to a
fare-thee-well.

My apologies for being insufficiently clear about what I was responding to.

Cheers,
-- jra
-- 
Jay R. Ashworth                  Baylink                       [email-masked]
Designer                     The Things I Think                       RFC 2100
Ashworth & Associates       http://www.bcp38.info          2000 Land Rover DII
St Petersburg FL USA      BCP38: Ask For It By Name!           +1 727 647 1274