Subject: [dnssd] Solicit feedback on the problems of DNS for Cloud Resources described by the draft-ietf-rtgwg-net2cloud-problem-statement

From: Linda Dunbar <[email-masked]>
Date: Tue, 11 Feb 2020 19:27:41 +0000

DNS experts,

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-net2cloud-problem-statement/ describes the problems that enterprises face today when interconnecting their branch offices with dynamic workloads in third party data centers (a.k.a. Cloud DCs).
There can be many problems associated with network connecting to or among Clouds, many of which probably are out of the IETF scope. The objective of this document is to identify some of the problems that need additional work in IETF Routing area. Other problems are out of the scope of this document.

During IETF 106, we received comments that the document should cover the problems associated with DNS service by different Cloud Operators for Enterprise to utilize Cloud Resources even though DNS is not within the scope of IETF routing area.  We greatly appreciate DNS experts to provide comments to our description.

3.4 DNS for Cloud Resources
DNS name resolution is essential for on-premises and cloud-based resources. For customers with hybrid workloads, which include on-premises and cloud-based resources, extra steps are necessary to configure DNS to work seamlessly across both environments.
Cloud operators have their own DNS to resolve resources within their Cloud DCs and to well-known public domains. Cloud's DNS can be configured to forward queries to customer managed authoritative DNS servers hosted on-premises, and to respond to DNS queries forwarded by on-premises DNS servers.
For enterprises utilizing Cloud services by different cloud operators, it is necessary to establish policies and rules on how/where to forward DNS queries to. When applications in one Cloud need to communication with applications hosted in another Cloud, there could be DNS queries from one Cloud DC being forwarded to the enterprise's on premise DNS, which in turn be forwarded to the DNS service in another Cloud. Needless to say, configuration can be complex depending on the application communication patterns.

Thank you very much.

Linda Dunbar

---

From: David Schinazi <[email-masked]>
Date: Tue, 11 Feb 2020 12:37:29 -0800

Hi Linda,

I think you may have the wrong IETF list.
DNSSD is about DNS Service Discovery (RFC 6763),
not general-purpose DNS. I think you want [email-masked]

David

On Tue, Feb 11, 2020 at 11:28 AM Linda Dunbar <[email-masked]>
wrote:

> DNS experts,
>
>
>
>
> https://datatracker.ietf.org/doc/draft-ietf-rtgwg-net2cloud-problem-statement/
> describes the problems that enterprises face today when interconnecting
> their branch offices with dynamic workloads in third party data centers
> (a..k.a. Cloud DCs).
>
> There can be many problems associated with network connecting to or among
> Clouds, many of which probably are out of the IETF scope. The objective of
> this document is to identify some of the problems that need additional work
> in IETF Routing area. Other problems are out of the scope of this document.
>
>
>
> During IETF 106, we received comments that the document should cover the
> problems associated with DNS service by different Cloud Operators for
> Enterprise to utilize Cloud Resources even though DNS is not within the
> scope of IETF routing area.  We greatly appreciate DNS experts to provide
> comments to our description.
>
>
>
>
> DNS name resolution is essential for on-premises and cloud-based
> resources. For customers with hybrid workloads, which include on-premises
> and cloud-based resources, extra steps are necessary to configure DNS to
> work seamlessly across both environments.
>
> Cloud operators have their own DNS to resolve resources within their Cloud
> DCs and to well-known public domains. Cloud’s DNS can be configured to
> forward queries to customer managed authoritative DNS servers hosted
> on-premises, and to respond to DNS queries forwarded by on-premises DNS
> servers.
>
> For enterprises utilizing Cloud services by different cloud operators, it
> is necessary to establish policies and rules on how/where to forward DNS
> queries to. When applications in one Cloud need to communication with
> applications hosted in another Cloud, there could be DNS queries from one
> Cloud DC being forwarded to the enterprise’s on premise DNS, which in turn
> be forwarded to the DNS service in another Cloud. Needless to say,
> configuration can be complex depending on the application communication
> patterns.
>
>
>
>
>
> Thank you very much.
>
>
>
> Linda Dunbar
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>