Subject: Re: [domainrep] Charter adjustments

From: Nathaniel Borenstein <[email-masked]>
Date: Thu, 1 Sep 2011 21:35:42 -0400

On Aug 31, 2011, at 2:08 PM, Murray S. Kucherawy wrote:

> This conflates some important things.  Portability is irrelevant to mechanism, for example; it has to do with the choice of the expressed reputation (and is thus part of the vocabulary), not the protocol by which it's delivered.
> 
> I prefer the current text.  Is there other feedback?

If you think portability is irrelevant to mechanism, you should compare the design of, say, a portable infant crib with a crib designed to stay in one place.

I like the idea of making it clear that the format's included.  How about

"Both the mechanism and the reputation data type...."

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 1 Sep 2011 21:42:47 -0700

I've updated the charter using this suggestion.

Anyone else, before I ping our AD?

From: Nathaniel Borenstein [mailto:[email-masked]]
Sent: Thursday, September 01, 2011 6:36 PM
To: Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: [domainrep] Charter adjustments

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 1 Sep 2011 21:50:11 -0700

"Portability" in this context, as it was used in the BoF, is the idea that you could ask two different reputation providers the same question, and they mean (roughly) the same thing.  For example, one doesn't use a linear scale from 0 to 1 while the other uses an exponential or logarithmic scale.  So if you change providers, you shouldn't have to change anything else.

Given that definition, the query should be "portable" regardless of whether it uses the simple or the extended mechanism.

---

From: Nathaniel Borenstein <[email-masked]>
Date: Fri, 2 Sep 2011 14:21:19 -0400

I think "portability" means too many things.  (It is too portable a term.)  Alternatives:

Proportionality.  Comparability.  Commensurability.

I like commensurability -- it's legitimate but rarely used.  Commensurability *is* independent of mechanism, for example.  -- Nathaniel

On Sep 2, 2011, at 12:50 AM, Murray S. Kucherawy wrote:

> “Portability” in this context, as it was used in the BoF, is the idea that you could ask two different reputation providers the same question, and they mean (roughly) the same thing.  For example, one doesn’t use a linear scale from 0 to 1 while the other uses an exponential or logarithmic scale.  So if you change providers, you shouldn’t have to change anything else.
>  
> Given that definition, the query should be “portable” regardless of whether it uses the simple or the extended mechanism.
>  
> _______________________________________________
> domainrep mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/domainrep

---

From: "Rolf E. Sonneveld" <[email-masked]>
Date: Sat, 03 Sep 2011 00:29:57 +0200

On 9/2/11 8:21 PM, Nathaniel Borenstein wrote:
> I like commensurability

+1

> -- it's legitimate but rarely used.  Commensurability *is* independent 
> of mechanism, for example.  -- Nathaniel
>
>> “Portability” in this context, as it was used in the BoF, is the idea 
>> that you could ask two different reputation providers the same 
>> question, and they mean (roughly) the same thing.  For example, one 
>> doesn’t use a linear scale from 0 to 1 while the other uses an 
>> exponential or logarithmic scale.  So if you change providers, you 
>> shouldn’t have to change anything else.
>> Given that definition, the query should be “portable” regardless of 
>> whether it uses the simple or the extended mechanism.

Maybe we shouldn't be too concerned about portability/commensurability, 
as even apples and oranges have more in common than we often think: 
http://en.wikipedia.org/wiki/Apples_and_oranges#Scientific. So I suggest 
we'd express reputation in terms/units of apples and oranges, and we 
have a solid basis to provide portability/commensurability between 
reputation providers ;-)

/rolf

---

From: "Rolf E. Sonneveld" <[email-masked]>
Date: Sat, 03 Sep 2011 00:30:35 +0200

On 9/2/11 6:42 AM, Murray S. Kucherawy wrote:
> *From:*Nathaniel Borenstein [mailto:[email-masked]]
> *Sent:* Thursday, September 01, 2011 6:36 PM
> *To:* Murray S. Kucherawy
> *Cc:* [email-masked]
> *Subject:* Re: [domainrep] Charter adjustments
>
> This conflates some important things.  Portability is irrelevant to 
> mechanism, for example; it has to do with the choice of the expressed 
> reputation (and is thus part of the vocabulary), not the protocol by 
> which it's delivered.
>
> If you think portability is irrelevant to mechanism, you should 
> compare the design of, say, a portable infant crib with a crib 
> designed to stay in one place.
>

WFM

/rolf